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Exponential Functions

SQRT(z) is the square root of the expression z.  SQRT(z) is equivalent to z^(1/2).  Square roots are displayed using the Ö symbol, and can be entered by clicking on the Ö on the math symbol toolbar.  If z is a complex expression, then the phase of SQRT(z) in radians lies in the interval (-p/2, p/2].

The rules used to simplify expressions involving square roots take into account the current branch selection (see the Branch field of the Options > Mode Settings > Simplification command) and the declared domain of variables (see the Author > Variable Domain command).

#e is the base of the natural logarithms (2.71828...).  #e displays as ê, and can be entered by clicking on the ê on the math symbol toolbar.  You are free to use the unembellished variable name e to represent energy, eccentricity, etc.

EXP(z) is the exponential of the expression z.  EXP(z) simplifies to ê^z.  

Use the Exponential field of the Options > Mode Settings > Simplification command to control the transformations used to simplify expressions involving exponentials.




Logarithmic Functions

LN(z) is the principal natural (Napierian) logarithm of the expression z.  For example, LN(ê^3) simplifies to 3.  If z is a complex expression, then the imaginary part of LN(z) lies in the interval (-p, p].

LOG(z, w) is the logarithm of z to the base w.  Thus, LOG(z, 10) is the common logarithm of z.  For example, LOG(8, 2) simplifies to 3.  LOG(z, w) simplifies to LN(z)/LN(w).  LOG(z) simplifies to LN(z).

Note that LN and LOG are well-defined for negative and even complex arguments.  For example, LN(-3) simplifies to LN(3) + p·i.

Use the Logarithm field of the Options > Mode Settings > Simplification command to control the transformations used to simplify expressions involving logarithms.




Trigonometric Functions

The argument of the trigonometric functions is an angle.  Angles can be entered in radians using the constant p, or in degrees using the operator °.  

p is the area of the unit circle (3.14159...).  It can be entered by clicking on the p character on the math symbol toolbar, pressing Ctrl+P, or by typing pi on the expression entry line.  Note that the p character on the Greek symbol bar can be used as a variable or function name and is not the area of the unit circle.

° is the degree operator.  It can be entered by clicking on the ° character on the math symbol toolbar, pressing Ctrl+O, or by typing deg on the expression entry line.  ° is a postfix operator that occurs after its operand.  A degree is equivalent to p/180 radians.  For example, 60° is equivalent to p/3 radians.

SIN(z) is the sine of the angle z.

COS(z) is the cosine of the angle z.


TAN(z) is the tangent of the angle z.  TAN(z) is equal to SIN(z)/COS(z).

COT(z) is the cotangent of the angle z.  COT(z) is equal to COS(z)/SIN(z).

SEC(z) is the secant of the angle z.  SEC(z) simplifies to 1/COS(z).

CSC(z) is the cosecant of the angle z.  CSC(z) simplifies to 1/SIN(z).

Use the Trigonometry field of the Options > Mode Settings > Simplification command to control the application of the angle-sum and multiple-angle trigonometric transformations during subsequent simplifications.  

Use the Trig Powers field of the Options > Mode Settings > Simplification command to control the transformation of powers of sines into cosines and vice versa.  

If you want cosecants and secants in simplified results, use the Simplify > Subexpression Substitution command to replace reciprocals of sines and cosines by cosecants and secants. 




Inverse Trigonometric Functions

The following inverse trigonometric functions simplify to an angle displayed in the angular unit (degrees or radians) specified by the Angular Unit field of the Options > Mode Settings > Simplification command.  However, the these functions always
 approximate to an angle in radians.  The following discussion assumes the angular unit is a radian.

ATAN(z) is the principal arctangent of z (i.e. the angle whose tangent is z).  ATAN(y, x) is the angle of the point (x, y) in the x-y plane measured counterclockwise from the positive x-axis.  ATAN(y, x) function simplifies to an equivalent expression using the single-argument ATAN function.

Note that the order of the arguments to ATAN(y, x) is opposite to the usual coordinate pair order.  You can remember this by noting that ATAN(y, x) equals ATAN(y/x) if x is positive.  If x is real, than ATAN(x) lies in the closed-interval [-p/2, p
/2].  If x and y are real, then ATAN(y, x) lies in the interval (-p, p].

ACOT(z) is the principal arccotangent of z (i.e. the angle whose cotangent is z).  ACOT(x, y) is the angle of the point (x, y).  ACOT(z) simplifies to p/2 - ATAN(z).  ACOT(x, y) simplifies to ATAN(y, x), which is further transformed as described above.  If x is real, then ACOT(x) lies in the closed-interval [0, p].  If x and y are real, then ACOT(x, y) lies in the interval (-p, p].

ASIN(z) is the principal arcsine of z.  If x is in the interval [-1, 1], then ASIN(x) lies in the closed-interval [-p/2, p/2].

ACOS(z) is the principal arccosine of z.  ACOS(z) simplifies to p/2 - ASIN(z) which is further transformed as described above.  If x is in the interval [-1, 1], then ACOS(x) lies in the closed-interval [0, p].

ASEC(z) is the arcsecant of z.  ASEC(z) simplifies to ACOS(1/z), which is further transformed as described above.

ACSC(z) is the arccosecant of z.  ACSC(z) is replaced by ASIN(1/z), which is further transformed as described above.

Unlike the above inverse trigonometric functions, the following functions always simplify and approximate to an angle expressed in degrees:

ARCSIN(z) returns the principal arcsine of z expressed in degrees.
ARCCOS(z) returns the principal arccosine of z expressed in degrees.
ARCTAN(z) returns the principal arctangent of z expressed in degrees.  ARCTAN(y,x) returns the angle of the point (x,y) expressed in degrees and measured counterclockwise from the positive x-axis.
ARCCOT(z) returns the principal arccotangent of z expressed in degrees.  ARCCOT(y,x) returns the angle of the point (x,y) expressed in degrees and measured counterclockwise from the positive x-axis.

ARCSEC(z) returns the principal arcsecant of z expressed in degrees.
ARCCSC(z) returns the principal arccosecant of z expressed in degrees.




Hyperbolic Functions

The hyperbolic functions simplify to equivalent expressions involving exponentials.

SINH(z) is the hyperbolic sine of z.  SINH(z) simplifies to

  z      -z 
 ê      ê   
---- - -----
  2      2  

COSH(z) is the hyperbolic cosine of z.  COSH(z) simplifies to

  z      -z 
 ê      ê   
---- + -----
  2      2  

TANH(z) is the hyperbolic tangent of z.  TANH(z) simplifies to

  2·z     
 ê    - 1 
----------
  2·z     
 ê    + 1 

COTH(z) is the hyperbolic cotangent of z.  COTH(z) simplifies to

  2·z     
 ê    + 1 
----------
  2·z     
 ê    - 1 

SECH(z) is the hyperbolic secant of z.  SECH(z) simplifies to

      z   
   2·ê    
----------
  2·z     
 ê    + 1 

CSCH(z) is the hyperbolic cosecant of z.  CSCH(z) simplifies to

      z   
   2·ê    
----------
  2·z     
 ê    - 1




Inverse Hyperbolic Functions

The inverse hyperbolic functions simplify to equivalent expressions involving logarithms.  The following simplified results assume that domain of z has been declared complex.

ASINH(z) is the inverse hyperbolic sine of z.  ASINH(z) simplifies to

      2          
LN(Ö(z  + 1) + z)

ACOSH(z) is the inverse hyperbolic cosine of z.  ACOSH(z) simplifies to

2·LN(Ö(z - 1) + Ö(z + 1)) - LN(2)

ATANH(z) is the inverse hyperbolic tangent of z.  ATANH(z) simplifies to

 LN(z + 1)     LN(1 - z) 
----------- - -----------
     2             2     

ACOTH(z) is the inverse hyperbolic cotangent of z.  ACOTH(z) simplifies to

     z + 1   
 LN(-------) 
     z - 1   
-------------
      2      

ASECH(z) is the inverse hyperbolic secant of z.  ASECH(z) simplifies to

        1 - z        z + 1           
2·LN(Ö(-------) + Ö(-------)) - LN(2)
          z            z             

ACSCH(z) is the inverse hyperbolic cosecant of z.  ACSCH(z) simplifies to

          2            
         z  + 1        
    z·Ö(--------) + 1  
            2          
           z           
LN(-------------------)




Piecewise Continuous Functions

This topic describes the functions used for defining functions in a piecewise manner and how these functions handle real arguments.  Complex Variable Functions describes how they handle complex arguments.  Note that the rules used to simplify expressions involving these functions take into account the user-declared domain of variables (see the Author > Variable Domain command).

ABS(x) simplifies to the absolute value of x.  An absolute value can be entered and is displayed using vertical bars to delimit the argument.  Hence if x is 0 or a positive number, |x| simplifies to x.  If x is a negative number, |x| simplifies to -x.

SIGN(x) simplifies to the sign of x.  Hence if x is a positive number, SIGN(x) simplifies to 1.  If x is a negative number, SIGN(x) simplifies to -1.  Since the sign of 0 is indeterminate, SIGN(0) simplifies to plus-or-minus 1.

The functions MIN and MAX can take any number of arguments, a vector, or a matrix.  If given a vector (see Vectors and Matrices), they are applied to the elements of the vector.  If given a matrix, they are applied to the rows of the matrix, and the results are returned as a vector.

MAX(x1, x2, ..., xn) simplifies to the maximum value of its arguments.  MAX(x , y) simplifies to the equivalent expression ABS(x-y)/2 + (x+y)/2.

MIN(x1, x2 ,..., xn) simplifies to the minimum value of its arguments.  MIN(x, y) simplifies to the equivalent expression (x+y)/2 - ABS(x-y)/2.

STEP(x), the unit step function, simplifies to 1 if x > 0; and to 0 if x < 0.  If the sign of x cannot be determined, STEP(x) simplifies to (SIGN(x)+1)/2.

CHI, the piecewise indicator function, is defined as follows:

·	CHI(a, x, b) simplifies to 1 if a < x < b; to 0 if x < a < b or if a < b < x; and to -CHI(b, x, a) if b < a.  If the relation between a, b, and x cannot be determined, CHI(a, x, b) simplifies to SIGN(x-a)/2 - SIGN(x-b)/2.

·	CHI(x) simplifies to CHI(0, x, 1).

·	CHI(a, x) simplifies to CHI(a, x, 1).

·	CHI(a, x, b, c) simplifies to c if x = a; to 1-c if x = b; otherwise it simplifies to CHI(a, x, b).

·	CHI(a, x, b, c, d) simplifies to c if x = a; to d if x = b; otherwise it simplifies to CHI(a, x, b).

FLOOR(m) simplifies to the greatest integer less than or equal to m.  If m is nonnegative, this is equivalent to the integer-part of m.  FLOOR(m, n) is equivalent to FLOOR(m/n) but is slightly more efficient.  For example,

FLOOR(5.73)

FLOOR(573, 100)

both simplify to 5.

CEILING(m) simplifies to the smallest integer greater than or equal to m.  CEILING(m, n) is equivalent to CEILING(m/n) but is slightly more efficient.  If m or n are not numbers, CEILING(m, n) simplifies to the equivalent expression  - FLOOR
(- m/n).  For example,

CEILING(5.73)

CEILING(573, 100)

both simplify to 6.

ROUND(m) simplifies to the nearest integer to m.  ROUND(m, n) is equivalent to ROUND(m/n) but is slightly more efficient.  For example,

ROUND(5.73)

ROUND(573, 100)

both simplify to 6.

MOD(m, n) simplifies to m modulo n (i.e. the nonnegative remainder of m/n).  MOD(m, 0) simplifies to m.  Since n defaults to 1, MOD(m) simplifies to the fractional-part of m.  For example,

MOD(5.73)

MOD(573, 100)

simplify to 73/100 and 73, respectively.  If m, n>0, and p>0 are integers, MOD(m^p, n) is computed efficiently using the power-mod algorithm to raise m to the power p modulo n.  For example,

VECTOR(MOD(3^(10^n),10007),n,1,10)

simplifies to [9014, 4995, 6823, 5079, 2749, 8517, 594, 6074, 7480, 493].

MODS(m, n) simplifies to the symmetric m modulo n which will be in the half-open interval [-n/2,n/2).  MODS(m, 0) simplifies to m.  n defaults to 1.  

MODS(5.73)

MODS(573, 100)

simplify to -27/100 and -27, respectively.  If m, n>0, and p>0 are integers, MODS(m^p, n) is computed efficiently using the power-mod algorithm to raise m to the power p modulo n.  For example,

VECTOR(MODS(3^(10^n),10007),n,1,10)

simplifies to [-993, 4995, -3184, -4928, 2749, -1490, 594, -3933, -2527, 493].

POLY_MOD(u, n) simplifies to the polynomial whose coefficients are those of u reduced by the modulus n, where n is an integer and u is a polynomial having numeric coefficients.

POLY_MODS(u, n) simplifies to the polynomial whose coefficients are those of u reduced by the symmetric modulus n, where n is an integer and u is a polynomial having numeric coefficients.




Complex Variable Functions

The rules used to simplify expressions involving the complex variable functions take into account the current branch selection (see the Branch field of the Options > Mode Settings > Simplification command) and the user-declared domain of variables (see the Author > Variable Domain command).

#i is the imaginary unit, SQRT(-1).  #i displays as î, and can be entered by clicking on the î on the math symbol toolbar.  You are free to use the unembellished variable name i to represent electrical current, interest, etc.

unit_circle represents some arbitrary point on the unit circle in the complex plane.  For instance, 1, -1, î, and -î are points on the unit circle.  unit_circle may arise in limit problems or when solving equations.  For example, if z is declared complex (see the Author > Variable Domain command), solving the equation |z| = 2 for z gives z = 2·unit_circle.

ABS(z) simplifies to the absolute value (also called magnitude or modulus) of z.  The absolute value of z is the distance between z and the origin of the complex plane.  An absolute value can be entered and is displayed using vertical bars to delimit the argument.  Hence if x and y are real,

|x + î·y|

simplifies to

   2    2 
Ö(x  + y )

SIGN(z) simplifies to the point on the unit circle in the complex plane that has the same phase angle as z.  For example,

SIGN(3 + 4·î)

simplifies to

 3     4·î 
--- + -----
 5      5  

RE(z) simplifies to the real part of z.  Hence if x and y are real, RE(x + îy) simplifies to x.

IM(z) simplifies to the imaginary part of z.  Hence if x and y are real, IM(x + îy) simplifies to y.

CONJ(z) simplifies to the complex conjugate of z.  Hence if x and y are real, CONJ(x+îy) simplifies to x - îy.

PHASE(z) simplifies to the principal phase angle of z, measured counterclockwise from the positive x-axis.  The angle is displayed in the angular unit (degrees or radians) specified by the Angular Unit field of the Options > Mode Settings > Simplification command.  Thus if the angular unit is a radian, PHASE(z) lies in the interval (-p, p] for any z in the complex plane.






Probability Functions

The functions in this topic are useful for solving probability problems.

euler_gamma is Euler's g (gamma) constant.  The constant can be entered by typing euler_gamma on the expression entry line.  The lower case Greek letter g (gamma) on the Greek symbol toolbar is not associated with Euler's gamma constant, so that g can be used as the name of a user-defined variable or function.  In exact mode arithmetic, euler_gamma remains symbolic since it is an irrational number.  In approximate or mixed mode arithmetic, it simplifies to an approximation for g accurate to the current precision.  For example,

APPROX(euler_gamma, 25)

simplifies to 0.5772156649015328606065121.

z! is the factorial function z!, defined for all real and complex z.  If n is a positive integer, n! is the product of the first n integers.  For example,

VECTOR(k!, k, 0, 9)

simplifies to

[1, 1, 2, 6, 24, 120, 720, 5040, 40320, 362880]

and

(3/2)!

simplifies to

 3·Öp 
------
   4  

GAMMA(z) is the gamma function G(z), defined for all real and complex z.  If z is nonnumeric, G(z) simplifies to z-1 factorial.  The function can be entered by typing GAMMA on the expression entry line, or by clicking on the capital Greek letter G (Gamma) on the Greek symbol toolbar.  The incomplete gamma function and its relatives are defined in ProbabilityFunctions.mth.  For example,

VECTOR(GAMMA(k), k, 1, 10)

simplifies to

[1, 1, 2, 6, 24, 120, 720, 5040, 40320, 362880]

DIGAMMA(z) is the digamma function Y(z).  Y(z) is defined as the first derivative of the natural logarithm of G(z).  The function can be entered by typing DIGAMMA on the expression entry line.  The capital Greek letter Y (Psi) on the Greek symbol toolbar is not associated with the digamma function, so that Y can be used as the name of a user-defined variable or function.  If k is a nonnegative integer, S(1/n, n, 1, k) equals Y(k+1) + g (Euler's gamma constant).  For example,

VECTOR(DIGAMMA(k + 1) + euler_gamma, k, 0, 7)

simplifies to

é       3    11    25    137    49    363 ù
ê0, 1, ---, ----, ----, -----, ----, -----ú
ë       2     6    12     60    20    140 û

PERM(m, n) is the number of permutations or arrangements of m things taken n at a time.  If z and w are nonnumeric, PERM(z, w) simplifies to z!/(z-w)!.  For example,

PERM(n, n)

simplifies to n!.

COMB(m, n) is the number of combinations or groupings of m things taken n at a time.  If z and w are nonnumeric, COMB(z, w) simplifies to z!/(w!·(z-w)!).  Note that COMB(m, n) is also the binomial coefficient of m and n.  For example,

VECTOR(VECTOR(COMB(j, k), k, 0, 8), j, 0, 8)

simplifies to the first 9 rows of Pascal's triangle.

RANDOM(n) invokes a pseudo-random number generator.  Random numbers are derived from a random number state variable, s, that is updated using the rule 2654435721·s + 1 mod 2^32 each time a random number is generated.

·	If n>1 is an integer, RANDOM(n) simplifies to a random integer in the interval [0, n).  For example, each time RANDOM(6) is simplified, it returns with equal probability one of the 6 integers from the set {0, 1, 2, 3, 4, 5}.

·	RANDOM(1) simplifies to a random number in the interval [0, 1).

·	If n<0 is an integer, RANDOM(n) simplifies to -n and initializes the random number state variable to -n.

·	RANDOM(0) simplifies to the time in centiseconds since the current calendar year began and initializes the random number state variable to that time.




Statistical Functions

The functions in this topic are useful for solving statistical problems.  The first four can take any number of arguments, a vector, or a matrix.  If given a vector (see Vectors and Matrices), the function is applied to the elements of the vector.  If given a matrix, the function is applied to the rows of the matrix, and the results are returned as a vector.

AVERAGE(z1, z2, ..., zn) simplifies to the arithmetic mean or average of z1, z2, ..., zn (i.e. the sum of the zi’s divided by n).  For example, both

AVERAGE(2, 4, 6, 8)

and

AVERAGE([2, 4, 6, 8])

simplify to 5.

RMS(z1, z2, ..., zn) simplifies to the root mean square of z1, z2, ..., zn (i.e. the square-root of the sum of the squares of the zi’s divided by n).  For example, both

RMS(2, 4, 6, 8)

simplifies to Ö30 and approximates to 5.477225575.

VARIANCE(z1, z2, ..., zn) simplifies to the unbiased sample variance of z1, z2, ..., zn (i.e. the sum of the squares of the difference of zi’s and their average divided by n-1).  For example,

VARIANCE(2, 4, 6, 8)

simplifies to 20/3 and approximates to 6.666666666.

STDEV(z1, z2, ..., zn) simplifies to the sample standard deviation of z1, z2, ..., zn (i.e. the square-root of the variance of z1, z2, ..., zn).  For example,

STDEV(2, 4, 6, 8)

simplifies to 2·Ö15/3 and approximates to 2.581988897.

FIT(v, A) returns the least squares fit of a parameterized expression in label vector v to the set of points in the data matrix A.  A least squares fit minimizes the sum of the squares of the discrepancies at the points.

The elements of the label vector are the data variables followed by the parameterized expression.  The expression should depend on the data variables and one or more parametric variables.  The dependence on the parametric variables should be linear (i.e. if p is a parametric variable, the expression must be of the form  r·p+s,  where r and s are expressions independent of p).  The expression's dependence on the data variables need not be linear.

The elements of each row of the data matrix are the numeric values of the data variables and the corresponding numeric value of the expression given in the label vector.  The data values on each row must correspond one-to-one with the elements of the label vector.

When the number of data matrix rows equals the number of parametric variables, FIT returns an expression that exactly fits the data, to within roundoff error.  For example,

FIT([x, a·x^2 + b·x + c], [-1.5, 0; 0.5, -2; 1.5, -1.5])

simplifies to the parabola

  2               
 x      x     15  
---- - --- - ---- 
  2     2      8  

When the number of data matrix rows exceeds the number of parametric variables, FIT returns an expression that is a least squares fit to the data.  For example, if the value of the variable data is the matrix

é 2.75  -2.3  2.4 ù
ê                 ú
ê -3.5   4.5  4.2 ú
ê                 ú
ê   5    3.5  5.8 ú
ê                 ú
ë  -4    -5   1.3 û

then

FIT([x, y, a·x + b·y + c], data)

approximates to the plane

0.1536447245·x + 0.3577492652·y + 3.352791083

Note that the dependence on the data variables need not be linear, even though the dependence on the parametric variables must be linear.  For example,

FIT([t, q·ATAN(t) + r·SIN(t)], [-4, -1; -1, -1.9; 2, 2.25])

approximates to

1.297230859·ATAN(t) + 0.9613787149·SIN(t)

Even though the dependence on the parametric variables in a parameterized expression is nonlinear, it may be possible to transform the expression so the dependence is linear.  For example, to fit the expression

a·EXP(b·x)

 to a set of data points, first transform it to LN(a)+b·x by taking its natural logarithm.  Then if LN(a) is replaced by a_ in the transformed expression, FIT can be used to find the a_ and b that give the best fit of the transformed expression to the natural logarithm of the original data points.  Finally, approximate EXP(a_) to find a.



Error Functions

The error functions frequently occur in probability and statistics problems.

ERF(z) is the integral of the Gaussian distribution from 0 to z.  

ERF(z, w) is the generalized error function.  ERF(z, w) is defined as the integral of the Gaussian distribution from z to w.  ERF(z, w) simplifies to ERF(w) - ERF(z).

ERFC(z) is the complementary error function.  ERFC(z) simplifies to 1-ERF(z).

NORMAL(z, m, s) is the normal distribution function of z with mean m and standard deviation s.  m defaults to 0 and s defaults to 1.  This makes NORMAL(z) equivalent to the cumulative distribution function.


Zeta Functions

The Riemann zeta functions frequently occur in summation and integration problems.  The utility file ZetaFunctions.mth defines functions for approximating several functions related to the zeta function.  

ZETA(s) is the Riemann zeta function z(s).  If the real part of s is greater than 1, z(s) is defined as the sum of 1/k^s for k=1 to ¥.  Otherwise, it is defined by analytic continuation over the rest of the complex plane.  The function can be entered by typing ZETA on the expression entry line or by clicking on the z character on the math symbol toolbar.  z(s) simplifies to an exact closed form value if one is known.  For example,

VECTOR(ZETA(s), s, -4, 4)

simplifies to

é                                 2           4 ù
ê     1           1      1       ð           ð  ú
ê0, -----, 0, - ----, - ---, ¥, ----, æ(3), ----ú
ë    120         12      2        6          90 û

If s is a real or complex number, z(s) approximates to a numerical value.

ZETA(s, z) is the Hurwitz or generalized zeta function z(s, z).  If the real part of s is greater than 1, z(s, z) is defined as the sum of 1/(k+z)^s for k=0 to ¥.  Otherwise, it is defined by analytic continuation over the rest of the complex plane.  Note that z(s, 1) is equal to z(s) for all s.  z(s, z) simplifies to an exact closed form value if one is known.  For example,

VECTOR(ZETA(s, 1/2), s, -4, 4)

simplifies to

é                              2             4 ù
ê       7         1           ð             ð  ú
ê0, - -----, 0, ----, 0, ±¥, ----, 7·æ(3), ----ú
ë      960       24            2             6 û

A function for approximating z(s, z) is defined in the utility file ZetaFunctions.mth.

DILOG(z) is the dilogarithm function defined as the integral of LN(t)/(1-t) from t=1 to z.  For example, DILOG(1) is 0 and DILOG(0) is p²/6.  Antiderivatives and definite integrals involving logarithms having no closed-form in terms of the elementary functions often simplify to an expression involving DILOG.  For example,

INT(LN(x)/(x - 1), x)

simplifies to

DILOG(1 - x) + LN(x)·LN(1 - x)




Financial Functions

An annuity is a loan, mortgage, or similar contract to make fixed payments of money at regular intervals over a certain period of time in exchange for a sum of money.  Interest is paid on the money at a fixed rate and is compounded each interval.

Derive 's financial functions are based on the equation

                            n               
       n    p·(1+i·t)·((1+i)  - 1)          
v·(1+i)  + ------------------------ + f = 0 
                       i                    

that applies to an annuity with a present value v in which a fixed payment p is paid for n regular periods at a periodic interest rate of i with a future value of f.  Positive numbers represent money you receive; negative numbers represent money you pay out.

The financial functions have an optional fifth argument t, the time of payment.  Make this argument 0 if the payments are made at the end of each period, 1 if the payments are made at the beginning of each period, or a proportionate fraction between 0 and 1 if the payments are made within each period.  The default value of t is 0, indicating that payments are made at the end of each period.

Because of catastrophic cancellation in the above formula, it is advisable to use 10 or more significant digits of precision when using these functions (see the Precision field of the Options > Mode Settings > Simplification command).

PVAL(i, n, p, f, t) is the present value of the contract.  The future value argument f defaults to 0.

FVAL(i, n, p, v, t) is the future value of the contract.  The present value argument v defaults to 0.

PMT(i, n, v, f, t) is the periodic payment of the contract.  The present value argument v and the future value argument f default to 0.

NPER(i, p, v, f, t) is the number of payment periods.  The present value argument v and the future value argument f default to 0.

RATE(n, p, v, f, t) is the periodic interest rate.  Note that RATE returns the interest rate per period, not necessarily the annual interest rate.  The present value argument v and the future value argument f default to 0.  If the interest rate is negative or greater than 1 (i.e. 100%), lower and upper bounds on the rate must be entered as the 6th and 7th argument of RATE, respectively.

For example, to compute the monthly payment on a 4 year car loan of $15,000 at a 10% annual interest rate, approximate

PMT(10%/12, 4·12, 15000)

using 10 significant digits of precision.  This gives a monthly payment of -380.4387515.  The amount is negative because it represents an outflow of money.

As another example, to compute the balance of a savings account in 5 years after making an initial deposit of $1,000, making monthly payments of $100 at the beginning of the month, and earning 5.5% annual interest compounded monthly, approximate

FVAL(5.5%/12, 5·12, -100, -1000, 1)

using 10 significant digits of precision.  This gives a future balance of 8235.356459.  The monthly payment and the initial deposit are negative because they represent an outflow of money




Number Theory Functions

The built-in functions in this topic are useful for investigations in number theory.  Additional functions for this purpose are defined in the utility file NumberTheoryFunctions.mth.

The functions GCD and LCM can take any number of arguments, a vector, or a matrix.  If given a vector (see Vectors and Matrices ), they are applied to the elements of the vector.  If given a matrix, they are applied to the rows of the matrix, and the results are returned as a vector.

GCD(m1, m2, ..., mn) simplifies to the greatest common divisor of the numbers m1, m2, ..., mn.  For example, GCD(6, 15) simplifies to 3.

LCM(m1, m2, ..., mn) simplifies to the least common multiple of the numbers m1, m2, ..., mn.  For example, LCM([6, 15, 14]) simplifies to 210.  If m or n are not numbers, LCM(m, n) simplifies to the equivalent expression ABS(m·n)/GCD(n, m).

INVERSE_MOD(a, m) simplifies to the inverse of a mod m if it exists, and a question mark otherwise.  For example, to determine the inverse of 37 mod 53, simplify the expression

INVERSE_MOD(37, 53)

POWER_MOD(a, n, m) returns a^n mod m.  For example, to raise 2 to the 500th power mod 100, simplify the expression

POWER_MOD(2, 500, 100)

PRIME?(m) simplifies to true if m is a prime; to false if m is a non-prime number; otherwise it does not simplify further.  A prime is an integer greater than 1 and divisible only by itself and 1.  The methods used to test primality include the prime number sieve, the Rabin-Miller primality test, and the Lucas primality test.  For example,

PRIME?(22564845703)

simplifies to false, since 22564845703 equals 106219 · 212437.

NEXT_PRIME(m) simplifies to the next prime larger than the number m.  It uses the same primality tests as the function PRIME?.  For example,

NEXT_PRIME(1000)

simplifies to 1009.

PREVIOUS_PRIME(m) simplifies to the first prime number smaller than the number m, if one exists; otherwise it simplifies to ?.  It uses the same primality tests as the function PRIME?.  For example,

PREVIOUS_PRIME(1000)

simplifies to 997




Expression Type Functions

The functions in this topic are primarily used when writing Derive function definitions to determine the data type of expressions.  By convention, the function names includes a ? to emphasize that they are predicates that return a truth-value (i.e. true or false).

INTEGER?(u) simplifies to true if u is an integer; otherwise it simplifies to false.  For example, 5, 0, -1, and 3 are integers.  Note that, the expressions FLOOR(x) and SIGN(x) are not integers, although their data type is integer.  Use INTEGER-TYPE? to test for such expressions.

RATIONAL?(u) simplifies to true if u is rational number (including integers); otherwise it simplifies to false.  For example, 2/3, -7/2, 5, and 0 are rational numbers.

EVEN?(u) simplifies to true if u is an even number (including fractions whose numerator or denominator is even); otherwise it simplifies to false.  For example, 4, 0, -6, 2/3, and 3/2 are even numbers.

ODD?(u) simplifies to true if u is an odd number (including fractions whose numerator and denominator is odd); otherwise it simplifies to false.  For example, 1, -7, and 3/5 are odd numbers.

NUMBER?(u) simplifies to true if u is a real or complex number; otherwise it simplifies to false.  For example, 3, -2/3, 2·î, and 3-5·î are numbers.  Note that, the expressions SIN(x) and x^2 are not numbers, although their data type is number.  Use REAL_TYPE? and NUMBER-TYPE? to test for such expressions.

VARIABLE?(u) simplifies to true if u is a variable; otherwise it simplifies to false.  For example, x, a, and Real are variables.

STRING?(u) simplifies to true if u is a string variable; otherwise it simplifies to false.  For example, "a=b" and "Derive" are string variables.

SUM?(u) simplifies to true if u is a sum; otherwise it simplifies to false.  For example, x+y and x-y are sums.

PRODUCT?(u) simplifies to true if u is a product; otherwise it simplifies to false.  For example, x·y and x/y are products.

POWER?(u) simplifies to true if u is a power having a numeric degree; otherwise it simplifies to false.  For example, x^2 and SQRT(x) are powers.

VECTOR?(u) simplifies to true if u is a vector or matrix; otherwise it simplifies to false.  For example, [a, b, c] and [a, b; c, d] are vectors.  Note that, the variable v is not a vector, even though the data type of v has been declared vector using the Author > Variable Domain command.  Use VECTOR_TYPE? to test for such variables.

MATRIX?(u) simplifies to true if u is a matrix (i.e. a vector of one or more vectors of equal length); otherwise it simplifies to false.  For example, [a, b; c, d] (or equivalently, [[a, b], [c, d]]) is a matrix.

SET?(u) simplifies to true if u is a set; otherwise it simplifies to false.  For example, {a, b, c} and { } are sets.  Note that, the variable s is not a set, even though the data type of s has been declared set using the Author > Variable Domain command.  Use SET_TYPE? to test for such variables.

LOGICAL?(u) simplifies to true if u is a logical truth-value; otherwise it simplifies to false.  true and false are the only two truth-values.  Note that, the variable p is not a logical truth-value, even though the data type of p has been declared logical using the Author > Variable Domain command.  Use LOGICAL_TYPE? to test for such variables.

INTEGER_TYPE?(u) simplifies to true if the data type of u is an integer; otherwise it simplifies to false.  For example, the data type of 3, FLOOR(x), and SIGN(x) is integer.

REAL_TYPE?(u) simplifies to true if the data type of u is a real number; otherwise it simplifies to false.  For example, the data type of 3, -2/3, x+y, and SIN(x)  is real.

NUMBER_TYPE?(u) simplifies to true if the data type of u is a real or complex number; otherwise it simplifies to false.  For example, the data type of a-3·î, SQRT(x), and LN(x) is a real or complex number.

VECTOR_TYPE?(u) simplifies to true if the data type of u is a vector; otherwise it simplifies to false.  For example, the data type of [a, b, c] and [a, b; c, d] is vector.

SET_TYPE?(u) simplifies to true if the data type of u is a set; otherwise it simplifies to false.  For example, the data type of {a, b, c} and a UNION b is set.

LOGICAL_TYPE?(u) simplifies to true if the data type of u is a logical truth-value; otherwise it simplifies to false.  For example, the data type of true and p AND q is logical.

IDENTICAL?(u, v) simplifies to true if u is identical to v; otherwise it simplifies to false.




Expression Decomposition Functions

The built-in functions in this topic are useful for decomposing expressions into their component parts.  Some of the functions require that their arguments be polynomials or numbers.

NUMERATOR(u) returns the numerator of the numeric or symbolic expression u.  To put an expression over a common denominator before calling NUMERATOR, factor out its trivial content using the Simplify > Factor command or the FACTOR function.  For example,

NUMERATOR(FACTOR(a/b + c/d, Trivial, a))

simplifies to a·d + b·c.

DENOMINATOR(u) returns the denominator of the numeric or symbolic expression u.  To put an expression over a common denominator before calling DENOMINATOR, factor out its trivial content using the Simplify > Factor command or the FACTOR function.  For example,

DENOMINATOR(FACTOR(a/b + c/d, Trivial, a))

simplifies to b·d.

QUOTIENT(u, v) returns the polynomial quotient of u divided by v, where u and v are polynomials.  For example,

QUOTIENT(x^4 + 3·x^3 + 5·x + 6, x^2 - 5)

simplifies to x^2 + 3·x + 5.  QUOTIENT(u, v, x) returns the polynomial quotient of u divided by v, where u and v are polynomials in the variable x.  Use the FLOOR function to find quotients over the ring Z of integers (for details, see the Piecewise Continuous Functions).

REMAINDER(u, v) returns the polynomial remainder of u divided by v, where u and v are polynomials.  For example,

REMAINDER(x^4 + 3·x^3 + 5·x + 6, x^2 - 5)

simplifies to 20·x + 31.  REMAINDER(u, v, x) returns the polynomial remainder of u divided by v, where u and v are polynomials in the variable x.  Use the MOD function to find remainders over the ring Z of integers (for details, see the Piecewise Continuous Functions).

POLY_GCD(u, v) returns the polynomial greatest common divisor (gcd) of u and v, where u and v are polynomials.  For example,

POLY_GCD(x^3 + 3·x^2 + 5·x + 6, x^3 + 2·x - 3)

simplifies to x^2 + x + 3.  Use the GCD function to find gcds over the ring Z of integers (for details, see the Number Theory Functions).

VARIABLES(u) returns a vector of the free variables of u ordered from most to least main.

LHS(u) returns the Left Hand Side (i.e. the left operand) of u if it is an equation, inequality, conjunction, disjunction, union, or intersection.  If u is a vector, LHS(u) returns a vector consisting of the Left Hand Sides of the elements of u.  For example,

LHS([2·x + y = 5, x < y - 3, NOT p AND q, a UNION b])

simplifies to

[2·x + y, x, ¬ p, a]

RHS(u) returns the Right Hand Side (i.e. the right operand) of u if it is an equation, inequality, conjunction, disjunction, union, or intersection.  If u is a vector, RHS(u) returns a vector consisting of the Right Hand Sides of the elements of u.  For example,

RHS([2·x + y = 5, x < y - 3, NOT p AND q, a UNION b])

simplifies to

[5, y - 3, q, b]


Expansion Functions

The built-in functions in this topic are for expanding polynomials, rational functions, and Boolean expressions (for details, see Expanding Polynomials, Expanding Rational Functions, and Boolean Functions, respectively).  To expand expressions involving the elementary functions see Exponential Functions, Logarithmic Functions, and Trigonometric Functions.

If u is a polynomial, EXPAND(u) expands u with respect to all its variables.  For example,

EXPAND((x + x·y + 3)^2)

simplifies to

 2  2      2      2                   
x ·y  + 2·x ·y + x  + 6·x·y + 6·x + 9 

If u is a polynomial, EXPAND(u, x, y, ...) expands u with respect to the variables x, y, ... .  For example,

EXPAND((x + x·y + 3)^2, x)

simplifies to

 2        2                   
x ·(y + 1)  + 6·x·(y + 1) + 9 

If u is a rational function and amount is Trivial, Squarefree, Rational or Radical, EXPAND(u, amount) expands u to partial fractions with respect to all its variables by factoring the denominator of u by amount.  If the amount argument is omitted, Rational is the default denominator factoring amount.  For example,

EXPAND(1/(x^4 - 4·x^2))

simplifies to

      1              1           1   
------------ - ------------ - ------ 
 16·(x - 2)     16·(x + 2)        2  
                               4·x   

If u is a rational function, EXPAND(u, amount, x, y, ...) expands u to partial fractions with respect to the variables x, y, ... by factoring the denominator of u by amount.  For example,

EXPAND(1/(x^4 - 4·x^2), Squarefree, x)

simplifies to

      1           1   
------------ - ------ 
     2             2  
 4·(x  - 4)     4·x   

If u is a Boolean expression, EXPAND(u) expands u to disjunctive normal form returning the result as a Boolean expression. For example,

EXPAND(p AND (q OR r))

simplifies to

(p Ù q) Ú (p Ù r)

If u is a scalar expression, TERMS(u) returns the terms of u as a vector.  If u is a set or vector of expressions, TERMS(u) distributes over the elements of u.  Note that products and powers are not necessarily expanded.  For example,

TERMS(x·(a + b)^2 + c)

simplifies to

é         2   ù
ëx·(a + b) , cû

If u is a polynomial or rational function and amount is Trivial, Squarefree, Rational or Radical, TERMS(u, amount, x, y, ...) actively expands u by amount with respect to the variables x, y, ... and returns the result as a vector of terms.  For example,

TERMS(x·(a + b)^2 + c, Trivial)

simplifies to

é 2              2     ù
ëa ·x, 2·a·b·x, b ·x, cû


If u is a Boolean expression, TERMS(u) expands u to disjunctive normal form returning the result as a vector of conjuncts. For example,

TERMS(p AND (q OR r))

simplifies to

[p Ù q , p Ù r]

Since TERMS distributes over vectors, if v is a Boolean expression the composition TERMS(FACTORS(v)) simplifies to a vector of vectors of the literal atoms of the conjunctive normal form of v.  For example,

TERMS(FACTORS(NOT(NOT(a) OR b) OR NOT(c)))

simplifies to

é  a   ¬ c ù
ê          ú
ë ¬ b  ¬ c û





Factoring Functions

The built-in functions in this topic are for factoring numbers, polynomials, matrices, and Boolean expressions (for details, see Factoring Numbers, Factoring Polynomials, Factoring Matrices, and Boolean Functions, respectively).  To collect expressions involving the elementary functions see Exponential Functions, Logarithmic Functions, and Trigonometric Functions.

If n is a number, FACTOR(n, Number) factors n into its prime decomposition.  For example,

FACTOR(10!, Number)

simplifies to

 8  4  2   
2 ·3 ·5 ·7 

If u is a polynomial and amount is Trivial, Squarefree, Rational, Radical, or Complex, then FACTOR(u, amount) factors u with respect to all its variables.  FACTOR(u, amount, x, y, ...) factors u with respect to the variables x, y, ... .  If the amount argument is omitted, Rational is the default factoring amount for polynomials.  For example,

FACTOR(4·x^3 - 8·x^2 - 11·x - 3, Rational, x)

simplifies to

                 2 
(x - 3)·(2·x + 1)  

If u is a vector or matrix, FACTOR(u, Trivial) or just FACTOR(u) factors out the scalar content of the elements of u.

If u is a matrix, FACTOR(u, Turing) factors u to Turing form and FACTOR(u, Schmidt) factors u to Gram-Schmidt form.

If u is a Boolean expression, FACTOR(u) expands u to conjunctive normal form returning the result as a Boolean expression. For example,

FACTOR(p OR (q AND r))

simplifies to

(p Ú q) Ù (p Ú r)

If n is a number, FACTORS(n) factors n into its prime decomposition (factorization) as a vector of pairs of primes and their powers.  For example, 

FACTORS(10!)

simplifies to [2, 8; 3, 4; 5, 2; 7, 1].

If u is a nonnumeric expression, FACTORS(u) returns the factors of u as a vector of base-degree pairs.  If u is a set or vector of expressions, FACTORS(u) distributes over the elements of u.  Note that sums are not necessarily factored.  For example,

FACTORS((x^2 - 1)·(x + 3)^2)

simplifies to [x^2 - 1, 1; x + 3, 2].

If u is a polynomial and amount is Trivial, Squarefree, Rational, Radical, or Complex, FACTORS(u, amount, x, y, ...) actively amount factors u by amount with respect to the variables x, y, ... and returns the result as a vector of base-degree pairs.  For example,

FACTORS((x^2 - 1)·(x + 3)^2, Rational)

simplifies to [x + 3, 2; x - 1, 1; x + 1, 1].

If u is a vector or matrix, FACTORS(u, Trivial) factors out the scalar content of the elements of u, and returns the result as a vector of base-degree pairs.

If u is a matrix, FACTORS(u, Turing) factors u to Turing form and FACTORS(u, Schmidt) factors u to Gram-Schmidt form, and returns the result as a vector of matrices.

If u is a Boolean expression, FACTORS(u) expands u to conjunctive normal form returning the result as a vector of disjuncts. For example,

FACTORS(p OR (q AND r))

simplifies to

[p Ú q, p Ú r]

Since FACTORS distributes over vectors, if v is a Boolean expression the composition FACTORS(TERMS(v)) simplifies to a vector of vectors of the literal atoms of the disjunctive normal form of v.  For example,

FACTORS(TERMS(NOT(NOT(a) OR b) OR NOT(c)))

simplifies to [[a, ¬ b], [¬ c]].




Numerical Operators

Use the standard symbols for entering the four basic mathematical operators:

·	The plus operator, +, denotes addition.

·	The minus operator, -, denotes subtraction or negation.

·	The times operators, × and *, denote multiplication.

·	The quotient operator, /, denotes division.  Derive normally uses a built-up fraction to display quotients.

These binary infix operators are placed between their operands.  + and - are also unary prefix operators placed before their operand.

Use parentheses, ( ), to control the order in which operators are applied.  Brackets, [ ], and braces, { }, are not equivalent to parentheses and can not be used to control the order of application of operators or to enclose the arguments of functions.  Instead, brackets are used for entering vectors and matrices.  Braces are used for entering sets.

* and / have a higher operator precedence than + and -.  In the absence of parentheses, operators with higher precedence are applied before operators with lower precedence.  For example, entering 3 + 4 * 5 is equivalent to 3 + (4 * 5) rather than (3 + 4) * 5.

+ and - have equal precedence, as do * and /.  In the absence of parentheses, operators with equal precedence are applied left to right.  For example, entering 1 / 2 * 3 is equivalent to (1 / 2) * 3 rather than 1 / (2 * 3).

Instead of using * to explicitly indicate multiplication, separating two expressions with one or more spaces and/or parentheses implicitly indicates multiplication.  For example, entering 2 (3 + 5) is equivalent to 2 * (3 + 5).

Sometimes books print rational numbers as an integer followed by the fractional part.  For example, 3.5 is printed as 3 1/2.  This is short for 3 plus 1/2, not 3 times 1/2.  In Derive, use the + operator between the integer and fractional part of a number to prevent it from being interpreted as implicit multiplication.  For example, enter 3 1/2 - 2 1/4 as (3+1/2) - (2+1/4).

·	^ (exponentiation  operator) is used to denote exponentiation  (raising an expression to a power).  Derive normally uses a raised exponent to indicate exponentiation.

The exponentiation operator is a binary infix operator that is placed between its operands.  On most keyboards "^" is entered by pressing "6" while holding down the shift key.  For example, 3 squared (i.e. 3²) is entered as 3^2.

^ has a higher precedence than +, -, *, and /.  Thus operands of ^ that include these operators should be enclosed in parentheses.  For example, the cube root of 9 (i.e. 9 to the 1/3 power) must be entered as 9^(1/3) rather than 9^1/3.

Unlike other operators, ^ associates to the right.  Thus in the absence of parentheses, successive ^ operators are applied right to left.  For example, entering 4^3^2 is equivalent to 4^(3^2) rather than (4^3)^2.

The ^ operator can also be used to enter numbers in scientific notation.  For example, the number 6.02  times 10 to the 23rd can be entered as 6.02 * 10^23.

·	% (percent operator) is used to denote percentage (one hundredth of an expression).

This postfix operator is placed after its operand.  For example, 22% + 36% is equal to 0.58.

The % operator has a higher precedence than any of the operators discussed above.




Relational Operators

Equations and inequalities are in a class of expressions called relations.  In Derive a relation consists of two expressions separated by a relational operator.  The following table summarizes the relational operators and the one or two characters required to type in the operator on the expression entry line.  

=	=	equal operator

¹	/=	not equal operator
<	<	less than operator
£	<=	less than or equal operator
>	>	greater than operator
³	>=	greater than or equal operator

The relational operators can also be entered by clicking on them on the math symbol toolbar.  The relational operators are binary infix operators.  Thus to enter a relation, enter the left operand, the relational operator, and then the right operand.

The Simplify commands independently simplify the left and right sides of top-level equations.  For example,

x + 2·x = c + x·x

simplifies to

       2     
3·x = x  + c 

However, the Simplify commands simplify inequalities and non-top-level equations to a logically equivalent form with constants on the right and variables on the left. For example,

2·x + 3 < 5

simplifies to x<1.

Use the Solve commands to solve individual or systems of equations and inequalities for one or more variables.  For example,

SOLVE(x + 2·x = c + x·x, x)

simplifies to

     3 - Ö(9 - 4·c)           Ö(9 - 4·c) + 3  
x = ----------------  Ú  x = ---------------- 
            2                        2        

Alternatively, you can solve equations and inequalities in a step-by-step manner for pedagogical reasons (see Step-by-Step Equation Solving).

Relations are not automatically regarded as simultaneous facts, and they are not automatically tested for truth or consistency.  Think of a Derive worksheet as a blackboard containing relatively independent expressions, including relations.  Some of these expressions may be derived from earlier ones.  However, others may have no relation to each other.  Variables may mean different things in different parts of a problem or a set of problems.  You can choose to combine subsets of these expressions (see Entering Mathematical Expressions), while ignoring other perhaps contradictory expressions


Set Operators and Functions

Sets are entered as a list of elements separated by commas and enclosed in braces.  For example,  the empty set is entered as {}.  Ellipses can be used to shorten the entry of sets.  For example,

{1,...,10}

simplifies to

{1,2,3,4,5,6,7,8,9,10}

and

{1,3,...,10}

simplifies to

{1,3,5,7,9}

Use MEMBER? to test for set membership.  If u is an expression and v is a set or vector, MEMBER?(u, v) returns true if u is a member of v; otherwise it returns false.  For example,

MEMBER?(2*x, {x, x+x, x^2})

simplifies to true.

Set operators make it possible to combine sets.  The following set operators are built into Derive:

·	s` is the complement of s.  ` is a postfix operator.  The complement operator can be entered by clicking on the ` on the math symbol toolbar or by typing ` on the keyboard.  Derive just uses the complement operator for algebraically simplifying expressions involving sets, since the complement of a finite set is not representable.  For example,

s``

simplifies to s and

(s UNION t)`

simplifies to

s` Ç t`

·	s Ç t is the intersection of s and t.  Ç is a binary infix set operator.  The intersection operator can be entered by clicking on the Ç on the math symbol toolbar, by pressing Ctrl+N, or by typing INTERSECTION.  For example,

{1,3,5,7,9} INTERSECTION {2,3,5,8,13}

simplifies to

{3,5}

·	s È t is the union of s and t.  È is a binary infix set operator.  The union operator can be entered by clicking on the È on the math symbol toolbar, by pressing Ctrl+U, or by typing UNION.  For example,

{1,3,5,7,9} UNION {2,3,5,8,13}

simplifies to

{1,2,3,5,7,8,9,13}

·	s \ t is the set difference of s and t (i.e. those elements of s not in t).  The difference operator can be entered by clicking on the \ on the math symbol toolbar or typing \ on the keyboard.  For example,

{1,...,10}\{2,3,5,7}

simplifies to

{1,4,6,8,9,10}

As with the Numerical Operators, you can use parentheses to control the order in which set operators are applied.  In the absence of parentheses, set operators with higher precedence are applied before those with lower precedence.  The set operators above are listed in order of decreasing precedence.  For example, entering

r` È s Ç t

is equivalent to entering

(r`) È (s Ç t)

Expressions involving set operators may have many logically equivalent forms.  Derive uses the laws of Boolean algebra to simplify expressions involving sets into simpler ones that are equivalent.  The following identities, valid for any sets r, s, and t, are among those used to simplify expressions involving Ç and È:

r Ç s  ÜÞ  s Ç r
r È s  ÜÞ  s È r
r Ç (s Ç t)  ÜÞ  (r Ç s) Ç t
r È (s È t)  ÜÞ  (r È s) È t
(r Ç s) È (r Ç t)  ÜÞ  r Ç (s È t)
(r È s) Ç (r È t)  ÜÞ  r È (s Ç t)

The first two identities indicate that Ç and È are commutative.  The second two indicate that Ç and È are associative.  The last two indicate that Ç distributes over È, and that È distributes over Ç.  To simplify expressions involving sets, Derive applies the last two identities in the left-to-right direction.  

The following identities are among those used to simplify expressions involving the ` complement operator:

s``  ÜÞ  s
(s Ç t)`  ÜÞ  s` È t`
(s È t)`  ÜÞ  s` Ç t`

The last two identities, called De Morgan's laws, allow the complement operator to be distributed over the intersection and union operators.  To simplify expressions involving sets, Derive repeatedly applies the above rules to force the complement operator to the lowest level.

Use the function POWER_SET to generate the power set (i.e. all the subsets) of a set.  POWER_SET(s) simplifies to all the subsets of s.  For example,

POWER_SET({a, b, c})

simplifies to

{{}, {c}, {b}, {b, c}, {a}, {a, c}, {a, b}, {a, b, c}}

POWER_SET(s,n) simplifies to all the subsets of s having exactly n elements.  For example,

POWER_SET({a, b, c}, 2)

simplifies to

{{b, c}, {a, c}, {a, b}}

In Derive sets of ordered pairs can be considered to define a function.  In general, if u is a set of vectors and s equals the first element of one of the vectors, then u¯s simplifies to the second element of the vector.  The subscript operator can be entered by clicking on the ¯ on the math symbol toolbar or by typing SUB.  For example,

{[2, 3], [3, 5], [1, 7]} SUB 2

simplifies to 3.

The product of two sets simplifies to the Cartesian product (also called the outer product) of the sets.  For example,

{a, b}*{1, 2}

simplifies to

{[a, 1], [a, 2], [b, 1], [b, 2]}




Boolean Constants and Operators

Boolean (logical) constants and operators make it possible to logically combine relations and/or truth-valued variables into Boolean expressions.  For functions that perform operations on Boolean expressions (such as putting them in normal form) see the Boolean Functions.

The Boolean truth value constants are denoted by true and false.  The following are the Boolean operators:

·	NOT p (displayed as Øp) is the negation of p.  NOT is a unary prefix Boolean operator.  If p is true, NOT p simplifies to false.  If p is false, NOT p simplifies to true.  For example, NOT x>5 is true if x is not greater than 5 (i.e. if x is less than or equal to 5).

·	p AND q (displayed as p Ù q) is the conjunction of p and q.  AND is a binary infix Boolean operator.  If both p and q are true, p AND q simplifies to true.  If either p or q or both are false, p AND q simplifies to false.  For example, x<3 AND y=7 is true if both x is less than 3 and y is 7.

·	p OR q (displayed as p Ú q) is the disjunction (inclusive or) of p and q.  OR is a binary infix Boolean operator.  If either p or q or both are true, p OR q simplifies to true.  If both p and q are false, p OR q simplifies to false.  For example, x<3 OR y=7 is true if either x is less than 3 or y is 7 or both are true.

·	p XOR q (displayed as p Ú q) is the exclusive or of p and q.  XOR is a binary infix Boolean operator.  If either p or q but not both are true, p XOR q simplifies to true.  If both p and q are false or if both p and q are true, p XOR q simplifies to false.  If the truth values of p and q are unknown, p XOR q simplifies to the equivalent Boolean expression (NOT p AND q) OR (p AND NOT q).

·	p IMP q (displayed as p ® q) is a conditional (implication) with antecedent p and consequent q.  IMP is a binary infix Boolean operator.  If p is false or q is true, p IMP q simplifies to true.  If p is true and q is false, p IMP q simplifies to false.  If the truth values of p and q are unknown, p IMP q simplifies to the equivalent Boolean expression NOT p OR q.

·	p IFF q (displayed as p « q) is the logical equivalence of p and q.  IFF (if-and-only-if) is a binary infix Boolean operator.   If both p and q are true or if both p and q are false, p IFF q simplifies to true.   If p is true and q is false or if p is false and q is true, p IFF q simplifies to false.  If the truth values of p and q are unknown, p IFF q simplifies to the equivalent Boolean expression (¬ p OR q) AND (p OR ¬ q).

As with the Numerical Operators, you can use parentheses to control the order in which Boolean operators are applied.  In the absence of parentheses, Boolean operators with higher precedence are applied before those with lower precedence.  The Boolean operators above are listed in order of decreasing precedence.  For example, entering

NOT p OR q AND r

is equivalent to entering

(NOT p) OR (q AND r)

Expressions involving Boolean operators may have many logically equivalent forms.  Derive uses the laws of Boolean algebra to simplify Boolean expressions into simpler ones having the same truth value.  The following identities, valid for any truth values p, q, and r, are among those used to simplify expressions involving AND and OR:

p AND q  ÜÞ  q AND p
p OR q  ÜÞ  q OR p
p AND (q AND r)  ÜÞ  (p AND q) AND r
p OR (q OR r)  ÜÞ  (p OR q) OR r
p AND q OR p AND r  ÜÞ  p AND (q OR r)
(p OR q) AND (p OR r)  ÜÞ  p OR q AND r

The first two identities indicate that AND and OR are commutative.  The second two indicate that AND and OR are associative.  The last two indicate that AND distributes over OR and that OR distributes over AND.  To simplify Boolean expressions, Derive applies the last two identities in the left-to-right direction.  For example,

(x>0 AND y=3) OR (x>0 AND z=5)

simplifies to

(y = 3 Ú z = 5) Ù x > 0

and

p AND ((p AND q) OR r)

simplifies to

p Ù (q Ú r)

The following transformations are among those used to simplify Boolean expressions involving NOT:

p OR NOT p Þ true
p AND NOT p Þ false
NOT NOT p  Þ  p
NOT (p AND q)  Þ  NOT p  OR  NOT q
NOT (p OR q)  Þ  NOT p  AND NOT q

The last two identities, called De Morgan's laws, allow NOT to be distributed over conjunctions and disjunctions.  To simplify Boolean expressions, Derive repeatedly applies the above rules to force the NOT operator to the lowest level.

Relations combined by Boolean operators are also simplified when possible.  For example,

6 >= -2·x AND 3·x /= -9

simplifies to

x > -3

When given integer operands, the Boolean (logical) operators perform bit-wise logical operations on the integers.  The operations are performed as if integers are stored using a "half-infinite" two's-complement representation.  For example,

3 OR 5

simplifies to 7, and

NOT 5

simplifies to -6.




Boolean Functions

The Boolean functions perform various operations on Boolean expressions and return Boolean values.  The Boolean Operators also operate on such expressions.  

If u is a Boolean expression, the predicate function EVERY(u,x,c) evaluates u(x) for x equal to each element of c until a result is false in which case EVERY immediately returns false.  If no result is false, EVERY returns true.  EVERY
(u,k,m,n,s) evaluates u(k) for k=m to n in steps of size s until a result is false or all results are true.

Similarly, if u is a Boolean expression, the predicate function SOME(u,x,c) evaluates u(x) for x equal to each element of c until a result is true in which case SOME immediately returns true.  If no result is true, SOME returns false.  SOME
(u,k,m,n,s) evaluates u(k) for k=m to n in steps of size s until a result is true or all results are false.

Use the Simplify > Expand command or the Expansion Functions to transform Boolean expressions into disjunctive normal form.  Use the Simplify > Factor command or the Factoring Functions to transform Boolean expressions into conjunctive normal form.  


Truth Table Functions

A truth table shows each of the truth values of a Boolean expression when its variables are assigned all possible permutations of truth values.  Use the TRUTH_TABLE function to generate a truth table matrix for one or more Boolean expressions.  If p1, p2, ... are truth variables,

TRUTH_TABLE(p1, p2, ..., boolean1, boolean2, ...)

generates a truth table matrix for the Boolean expressions.  For example,

TRUTH_TABLE(p, q, p AND q, p OR q, p XOR q, p IMP q, p IFF q)

simplifies to

é   p      q    p Ù q  p Ú q  p Ú q  p ® q  p « q ù
ê                                                   ú
ê true   true   true   true   false  true    true   ú
ê                                                   ú
ê true   false  false  true   true   false   false  ú
ê                                                   ú
ê false  true   false  true   true   true    false  ú
ê                                                   ú
ë false  false  false  false  false  true    true   û




Utility File Library

The utility files distributed with Derive define functions and assign constants that supplement the built-in functions and constants.  When a function in any of the utility files listed below is first used, all the definitions and assignments in the file are automatically loaded.  Then the function is evaluated and returns a value, just like it normally would.

If Derive  needs to autoload a utility file, it looks for the file in the directory specified by the Options > Startup command.  If the file is not there, it looks for the file in the \Math subdirectory created when Derive is installed.  If the file is not there, it looks in the \Math subdirectory of the "Start in" directory (also called the working directory) specified by the properties of the desktop icon used to launch Derive.  To determine the "Start in" directory, right click on the Derive desktop icon and select the "Properties" option.

Utility file can be loaded manually using either the File > Load > Math File command or the File > Load > Utility File command.  If the latter load command is used, the file's function definitions and variable assignments are made, but expressions for the definitions and assignments are not added to the algebra window's worksheet.  However, the function definitions can still be examined using the Author > Function Definition command and variable assignments using the Author > Variable Value command.


Combinatorial Functions 
	Equation Solving 
	Linear Algebra 
	Number Theory Functions 
	Rational Approximation 
	Vector and Matrix Functions 
	Miscellaneous Functions 

	Calculus:
		Differentiation Applications 
		Integration Applications 
		Numerical Approximations 

	Differential and Recurrence Equations:

First-order Ordinary Differentials Equations 
		Second-order Ordinary Differential Equations 
		Approximate Solutions of ODEs 
		Recurrence Equations 

	Graphics Functions:
		Plotting Areas and Integrals 
		Coordinate System Conversion Functions 
		Plotting Space Curves and Parametric Surfaces 
		Plotting Complex-valued Expressions 

Plotting Grid Lines and Points 
		Filling Polygons 

	Physical Units and Constants:
		English Units Conversion 
		Metric Units Conversion 
		Physical Constants 

	Special Functions:
		Bessel Functions 
		Elliptic Integrals 
		Exponentials Integrals 
		Fresnel Integrals 
		Hypergeometric Functions 

Orthogonal Polynomials 
		Probability Functions 
		Riemann’s Zeta Functions 





Combinatorial Functions

The file CombinatorialFunctions.mth defines various combinatorial functions.  The function definitions in the file are automatically loaded when any of its functions are first used.

CATALAN(n) simplifies to the nth Catalan number.  For example, to determine the first 10 Catalan numbers, simplify the expression

VECTOR(CATALAN(n), n, 1, 10)

If n and k are positive integers, STIRLING(n, k) simplifies to the number of ways n objects can be partitioned into k nonempty subsets (i.e. the Stirling number of the second kind S(n, k) ).  If n and k are positive integers, STIRLING(-k, -n) simplifies to the number of permutations of n objects containing exactly k cycles (i.e. the Stirling number of the first kind s(n, k) ).  For example, to generate a table of the first 10 Stirling numbers of the first and second kinds with k=5, simplify the expression

TABLE([STIRLING(-5,-n),STIRLING(n,5)], n, 1, 10)

If n and k are positive integers, STIRLING1(n, k) and STIRLING_CYCLE(n, k) simplify to the Stirling number of the first kind s(n, k).  For example, to determine the first 10 Stirling numbers of the first kind containing exactly 5 cycles, simplify the expression

VECTOR(STIRLING1(n,5), n, 1, 10)

If n and k are positive integers, STIRLING2(n, k) and STIRLING_SUBSET(n, k) simplify to the Stirling number of the second kind S(n, k).  For example, to determine the first 10 Stirling numbers of the second kind with 5 nonempty subsets, simplify the expression

VECTOR(STIRLING2(n,5), n, 1, 10)

BERNOULLI(n) simplifies to the nth Bernoulli number.  For example, to determine the first 10 Bernoulli numbers, simplify the expression

VECTOR(BERNOULLI(n), n, 1, 10)

BERNOULLI_POLY(n, x) simplifies to the nth Bernoulli polynomial evaluated at x.  For example, to make a table of the first 6 Bernoulli polynomials, simplify the expression

TABLE(BERNOULLI_POLY(n,x), n, 1, 6)

EULER(n) simplifies to the nth Euler number.  For example, to determine the first 10 Euler numbers, simplify the expression

VECTOR(EULER(n), n, 1, 10)

EULER_POLY(n, x) simplifies to the nth Euler polynomial evaluated at x.  For example, to make a table of the first 6 Euler polynomials, simplify the expression

TABLE(EULER_POLY(n,x), n, 1, 6)

PARTS(n) simplifies to the number of decompositions of n into integer summands without regard to order.  For example, to verify that the number of parts of 4 = 1+3 = 2+2 = 1+1+2 = 1+1+1 is 5, simplify the expression

PARTS(4)

PARTS_LIST(n) simplifies to an n+1-element vector of the number of decompositions of 0 through n into integer summands without regard to order.  For example, to determine the number of parts of 0 through 4, simplify the expression

PARTS_LIST(4)

DISTINCT_PARTS(n) simplifies to the number of decompositions of n into distinct integer summands without regard to order.  For example, to verify that the number of distinct parts of 4 = 1+3 is 2, simplify the expression,

DISTINCT_PARTS(4)

BELL(n) simplifies to the nth Bell or exponential number.  For example, to determine the first 11 Bell numbers, simplify the expression

VECTOR(BELL(n), n, 0, 10)

RECURRENCE(u, v , v0, m) simplifies to a vector of m elements of the recurrence u where v0 is a vector of the first elements and v is a variable.  For example, to determine the first 8 Fibonacci numbers, simplify the expression

RECURRENCE(v SUB 1 + v SUB 2, v, [1,1], 8)

TRIANGULAR(n) simplifies to the nth triangular number.  For example, to determine the first 10 triangular numbers, simplify the expression

VECTOR(TRIANGULAR(n), n, 1, 10)

TETRAHEDRAL(n) simplifies to the nth tetrahedral number.  For example, to determine the first 10 tetrahedral numbers, simplify the expression

VECTOR(TETRAHEDRAL(n), n, 1, 10)

PENTATOPE(n) simplifies to the nth pentatope number.  For example, to determine the first 10 pentatope numbers, simplify the expression

VECTOR(PENTATOPE(n), n, 1, 10)

POLYGONAL(n, p) simplifies to the nth p-sided polygonal number, p³2.  For example, to determine the first 10 4-sided polygonal numbers, simplify the expression

VECTOR(POLYGONAL(n, 4), n, 1, 10)

POLYGONAL_PYRAMID(n, p, d) simplifies to the nth p-sided d-dimensional polygonal pyramid number, p³2.  For example, to determine the first 10 4-sided 4th dimensional polygonal pyramid numbers, simplify the expression

VECTOR(POLYGONAL_PYRAMID(n, 4, 4), n, 1, 10)

HEX(n) simplifies to the nth hex (i.e. 6-sided centered) number.  For example, to determine the first 10 hex numbers, simplify the expression

VECTOR(HEX(n), n, 1, 10)

STAR(n) simplifies to the nth star (i.e. 12-sided centered) number.  For example, to determine the first 10 star numbers, simplify the expression

VECTOR(STAR(n), n, 1, 10)

CENTERED(n, p) simplifies to the nth p-sided centered number.  For example, to determine the first 10 8-sided centered numbers, simplify the expression

VECTOR(CENTERED(n,8), n, 1, 10)


OCTAHEDRAL(n) simplifies to the nth octahedral number.  For example, to determine the first 10 octahedral numbers, simplify the expression

VECTOR(OCTAHEDRAL(n), n, 1, 10)

CENTERED_PYRAMID(n, p, d) simplifies to the nth p-sided d-dimensional centered pyramid number, p³2.  For example, to determine the first 10 6-sided 3-dimensional numbers, simplify the expression

VECTOR(CENTERED_PYRAMID(n, 6, 3), n, 1, 10)

CENTERED_CUBE(n, d) simplifies to the nth d-dimensional centered cube number.  For example, to determine the first 10 3-dimensional centered cube numbers, simplify the expression

VECTOR(CENTERED_CUBE(n, 3), n, 1, 10)

RHOMBIC_DODECAHEDRAL(n) simplifies to the nth rhombic dodecahedral number.  For example, to determine the first 10 rhombic dodecahedral numbers, simplify the expression

VECTOR(RHOMBIC_DODECAHEDRAL(n), n, 1, 10)

CENTERED_HEX(n, d) simplifies to the nth d-dimensional centered hex number.  For example, to determine the first 10 4-dimensional centered hex numbers, simplify the expression

VECTOR(CENTERED_HEX(n, 4), n, 1, 10)




Equation Solving

The Solve command and the built-in SOLVE and NSOLVE functions can find real or complex solutions to individual algebraic equations and to systems of polynomial equations using exact and/or approximate methods.  To supplement these capabilities, the file EquationSolving.mth defines functions useful for finding approximate solutions (real or complex) to individual algebraic equations and to systems of algebraic equations using iterative methods.  The function definitions in the file are automatically loaded when any of its functions are first used.

Given a univariate expression u(x) and an initial guess of x0, Newton's method uses repeated applications of the update formula xnew ¬ x - u(x)/u(x)'  evaluated at the current value of x to find an x such that u(x) is arbitrarily close to zero.  Newton's method can be used to find an approximate solution of a univariate equation by taking the difference of the two sides of the equation.  Also, the method can be extended to solve a system of m equations dependent on m variables.   Note that Newton's method requires that Derive be able to differentiate the expressions with respect to each of the solution variables.

NEWTON(u, x, x0, n) approximates to a vector of n+1 approximations for the variable x resulting from n applications of Newton's method to the univariate expression u(x) beginning with an initial guess of x0.  NEWTON(u, x, x0) approximates to a vector of the approximations for x until they converge at the current digits of precision.  For example, at 10 digits of precision, the expression

NEWTON(x^2-3, x, 2)

approximates to

[2, 1.75, 1.732142857, 1.732050810, 1.732050810, 1.732050810]

Note that the last element is a good approximation to the square root of 3.

If u is a vector of m expressions, x is a vector of m variables, and x0 is a vector of m initial guesses, NEWTONS(u, x, x0, n) approximates to a matrix of n+1 rows of approximations for the variables of x from n applications of Newton's method to the expressions in u beginning with the initial guesses in x0.  To solve a system of m equations in m variables, call NEWTONS with a vector of the difference in the two sides of each equation, a vector of the m variables, and a vector of the m initial guesses.  For example, to solve the equations exp(x·y) = x + 2·y and atan(x·y) = 2·x+y, approximate the expression

NEWTONS([EXP(x·y)-x-2·y, ATAN(x·y)-2·x-y], [x, y], [-1, -1], 7)

This results in an 8-row by 2-column matrix whose last row is an approximate solution to the equations based on 7 applications of Newton's method.  This solution can be verified by substitution of these values for x and y into the original equations.

NEWTONS(u, x, x0) approximates to a matrix of approximations for the variables of x until all converge at the current digits of precision.  Note that different rational numbers may look the same when displayed in scientific or decimal notation.  For example, the expression

NEWTONS([EXP(x·y)-x-2·y, ATAN(x·y)-2·x-y], [x, y], [-1, -1])

approximates to a matrix having 10 rows at 6 digits of precision and a matrix having 39 rows at 10 digits of precision.

If you are interested in solutions containing complex numbers, use such numbers in the components of the initial guess.  When a complex solution is found, its complex conjugate is often a good guess for another solution since complex solutions often occur in conjugate pairs.

Even if there is a solution, Newton's method may not converge to it unless your initial guess is sufficiently close.  Also, divergence may generate large magnitude numbers that exhaust memory and/or take a long time to abort.  Thus, it is usually best to begin by limiting NEWTONS to a small number of iterations.  Then by examining the last few rows of the resulting matrix, you can determine whether Newton's method is converging.  If convergence does not begin within ten iterations or so, it is usually best to try a different initial guess rather than increasing the number of iterations.

If s is the last row of the resulting matrix, you can approximate the limit of u as x approaches s to determine if the residual is acceptably small.  If s has converged to within roundoff error at the current precision and you want more accuracy, increase the precision by a few digits and use s as your initial guess.  This is usually more efficient than doing the whole calculation at the higher precision.

If Newton's method is taking an unexpectedly long time, the iteration may be diverging.  Abort the computation, and retry using a smaller number of iterations or a better initial guess.

NEWTONS only finds one solution at a time.  To find additional solutions, you can use a different initial guess.  However, NEWTONS may still converge to the solution you already know.  To prevent this, the original system can be reduced to a deflated system of equations.  If the vector [s1, s2, ..., sm] is a solution to the system represented by the vector u, the vector for the deflated system is

u
------------
(x1-s1) (x2-s2) ... (xm-sm)

If you find a solution to the deflated system, you can apply NEWTONS to the original system using this solution as an initial guess.  This eliminates roundoff error caused by deflation and gives a more accurate, purified solution.

The difficulty of finding sufficiently good initial guesses increases sharply with the number of variables.  Consequently, it is usually wise to eliminate as many variables as possible using the Solve > Expression command before resorting to NEWTONS.

Another way to solve a system of equations approximately is to convert the system to a vector fixed-point form x=g, with g=[g1, g2, ..., gm], where expressions g1 through gm may each depend on any or all of the variables in x=[x1, x2, ..., xm].  You can then substitute the initial guesses for x1 through xm into g to compute updated guesses for x.  You can continue to substitute the most recent set of components into g to compute a more recent set of guess components.

If there is a solution, the magnitudes of the partial derivatives of g1 through gm are small in the neighborhood of the solution, and the initial guess is close to the solution, then fixed-point iteration may converge to the solution and the convergence may occur in an acceptable amount of time.  To compensate for these discouraging provisos, fixed-point iteration does not require differentiability and does not require space to store derivatives, unlike Newton's method.

FIXED_POINT(g, x, x0, n) approximates to an n+1 by m matrix.  g is the vector of expressions [g1, g2, ..., gm].  The other arguments, the returned result, and the usage suggestions are similar to those described for NEWTONS.  For example, use complex numbers in the components of your initial guess if you are interested in complex solutions.

However, FIXED_POINT may diverge no matter how close the initial guess is to an exact solution:  The most important determinants of success are choosing a close enough initial guess and choosing a particular fixed-point form for which g1 through gm have small magnitude partial derivatives near the guess:  Ideally each equation has a portion that is invertible with respect to a distinct variable, and the magnitude of the partial derivative of this portion with respect to that variable is dominant near your guess.  You can then solve each equation for its dominant variable xk in its dominant portion in terms of the other portions to obtain the form xk=gk.  The same variable may occur on the right side too, but weakly.

Even if an equation cannot be solved exactly and extra parameters make it impossible to solve numerically, it may still be possible to find a truncated Taylor series solution.  The series solution can extend an exact or approximate solution at a particular point into a useful neighborhood around the point.  Of course, it is necessary that a truncated series solution exists at the point.

TAYLOR_SOLVE(u, x, y, x0, y0, n) simplifies to an nth degree truncated Taylor series solution y(x) of the equation u(x, y)=0, given u(x0, y0)=0.  For example, since y0=0 at x0=0 is a solution of the equation sin(y) + y + x·exp(x) = 0,

TAYLOR_SOLVE(SIN(y) + y + x·EXP(x), x, y, 0, 0, 3)

simplifies to

       3      2        
   25·x      x      x  
- ------- - ---- - --- 
     96       2     2  

This is the 3th degree truncated Taylor series solution of the equation expanded about the point y0=0 at x0=0.  Note that it is impossible to solve this transcendental equation exactly for y.  Also the extra parameter x makes it impossible to solve the equation numerically.

TAYLOR_INVERSE(u, x, y, x0, n) simplifies to an nth degree truncated Taylor series expansion of the inverse of the function defined by y=u(x), expanded about y0=u(x0).  This is useful when u(x) cannot be inverted exactly in closed form.  For example,

TAYLOR_INVERSE(x·EXP(x), x, y, 0, 3)

simplifies to

    3           
 3·y      2     
------ - y  + y 




Linear Algebra

The file LinearAlgebra.mth defines functions that supplement the built-in linear algebra capabilities of Derive.  The function definitions in the file are automatically loaded when any of its functions are first used.  The file LinearAlgebra.dfw includes the definitions in the mth file along with comments and examples.


Row Reduction Primitives

The five functions in this section can be used to reduce a matrix to row echelon form, one step at a time using Gaussian or Gauss-Jordan elimination.  This is useful for educational purposes, or because you may be able to make a better choice of pivots than the built-in function for finding the Row Echelon Form of a matrix.

SCALE_ELEMENT(v, i, s) simplifies to a copy of vector v with the ith element multiplied by the expression s.  Note that if v is a matrix, the ith row is multiplied by s.  For example,

SCALE_ELEMENT([1, 2, 3; 4, 5, 6; 7, 8, 9], 1, 4)

simplifies to

é 4  8  12 ù
ê          ú
ê 4  5   6 ú
ê          ú
ë 7  8   9 û

SWAP_ELEMENTS(v, i, j) simplifies to a copy of vector v with ith and jth elements interchanged.  Note that if v is a matrix, the ith and jth rows are interchanged.  For example,

SWAP_ELEMENTS([1, 2, 3; 4, 5, 6; 7, 8, 9], 1, 3)

simplifies to

é 7  8  9 ù
ê         ú
ê 4  5  6 ú
ê         ú
ë 1  2  3 û

SUBTRACT_ELEMENTS(v, i, j, s) simplifies to a copy of vector v in which the ith element is replaced with the ith element minus s times the jth element.  s defaults to 1.  For example,

SUBTRACT_ELEMENTS([1, 2, 3; 4, 5, 6; 7, 8, 9], 2, 1, 4)

simplifies to

é 1   2   3 ù
ê           ú
ê 0  -3  -6 ú
ê           ú
ë 7   8   9 û

FORCE0(A, i, j, p) simplifies to a copy of matrix A in which element Aij is forced to zero by subtracting an appropriate multiple of pivot row p from row i.  FORCE0 combines scaling and subtraction to force an element of a matrix to zero in a single step.  For example,

FORCE0([1, 2, 3; 4, 5, 6; 7, 8, 9], 2, 1, 1)

simplifies to

é 1   2   3 ù
ê           ú
ê 0  -3  -6 ú
ê           ú
ë 7   8   9 û

PIVOT(A, i, j) simplifies to a copy of matrix A in which the elements in the jth column below the ith row are forced to zero by subtracting appropriate multiples of the ith row from the rows below it.  For example,

PIVOT([1, 2, 3; 4, 5, 6; 7, 8, 9], 1, 1)

simplifies to

é 1   2   3  ù
ê            ú
ê 0  -3  -6  ú
ê            ú
ë 0  -6  -12 û

Inverses and Adjoints by Cofactor Expansion

The three functions in this section can be used to compute determinants and inverses from first principles.

MINOR(A, i, j) simplifies to a copy of matrix A in which the ith row and the jth column are omitted.  For example,

MINOR([1, 2, 3; 4, 5, 6; 7, 8, 9], 2, 2)

simplifies to

é 1  3 ù
ê      ú
ë 7  9 û

COFACTOR(A, i, j) simplifies to the numerator of the row j column i element of the inverse of square matrix A.  The corresponding element of the inverse is this numerator divided by the determinant of A.  

Element growth is severe when computing inverses of matrices having nonnumeric elements.  COFACTOR allows you to compute the matrix inverse one element at a time.  Alternatively, a matrix inverse can be computed one column at a time by simplifying expressions of the form  ROW_REDUCE(A, v), where v is a column of the identity matrix for dimension A.

COFACTOR can also be used to compute the determinant of a square matrix A, if simplifying DET(A) exhausts memory.  If A is an n by n matrix, the determinant of A is the sum of expressions of the form A1i·COFACTOR(A, 1, i), where i goes from 1 to n.  The determinant can also be computed by similarly expanding about any row or column of the matrix.

ADJOINT(A) simplifies to the adjoint or adjugate of square matrix A.  The adjoint of A is the transpose of the matrix of cofactors of A.  For example,

ADJOINT([2, x; 1, 3])

simplifies to

é  3  -x ù
ê        ú
ë -1   2 û




Eigenvalues and Eigenvectors

The three functions in this section are for computing the null space and eigenvectors of matrices.

NULL_SPACE(M) simplifies to a basis for the null space of the matrix M.  The null space is the set of vectors x satisfying the matrix equation M·x=0.  The null space will be empty if M is invertible, and will be nonempty if M is rank-deficient.  NULL_SPACE simplifies to a matrix in which each column is one basis vector for the null space.  The result is in a form sometimes called the rational basis as distinct from the ortho-normal basis.  Note that the product M·NULL_SPACE(M) should always simplify to the zero or empty matrix.  For example,

NULL_SPACE([1, 2, 3; 1, 2, 3; 1, 2, 3])

simplifies to

é  2   3 ù
ê        ú
ê -1   0 ú
ê        ú
ë  0  -1 û

EXACT_EIGENVECTOR(A, µ) simplifies to the eigenvectors of matrix A corresponding to the exact eigenvalue µ.  If µ is an exact eigenvalue of the square matrix A, the corresponding eigenvectors (characteristic vectors) are the nonzero vectors x that satisfies the singular homogeneous system (A - µ·I) x = 0.  Equivalently, the eigenvectors form the null space of the matrix (A - µ·I).  If the eigenvalue has multiplicity m, then generally there are m eigenvectors; otherwise the matrix is called defective.  The built-in function EIGENVALUES can be used to compute the exact eigenvalues of a matrix (see Eigenvalues).  For example,

EIGENVALUES([1, 2; 1, 1])

simplifies to [SQRT(2) + 1, 1 - SQRT(2)], and

EXACT_EIGENVECTOR([1, 2; 1, 1], SQRT(2) + 1)

simplifies to [- SQRT(2); -1].

If µ is only an approximate eigenvalue, the matrix A - µ·I is nonsingular.  In that case EXACT_EIGENVECTOR returns the zero vector since that is the only solution of (A - µ·I)·x = 0.  Exact irrational eigenvalues may also produce the zero vector if Derive is unable to determine that certain complicated irrational expressions are equivalent to 0.  Moreover, nonnumeric or irrational eigenvalues are likely to exhaust memory or yield extremely bulky eigenvector expressions.  For these reasons, EXACT_EIGENVECTOR is effectively limited to a maximum of 4 by 4 matrices.  APPROX_EIGENVECTOR is usually a better choice for numerical matrices larger than 3 by 3.

APPROX_EIGENVECTOR(A, µ) approximates to an eigenvector of numerical matrix A corresponding to the eigenvalue that µ approximates.  µ must be a number that is not an exact eigenvalue.  The result is normalized to unit magnitude, making it unique to within a factor of plus or minus one for eigenvalues of multiplicity one.  Multiply the result by a parameter such as @1 if you want a more general eigenvector.  To assess the accuracy of a result vector x, compare it to A · x / µ to see how closely they agree.  APPROX_EIGENVECTOR uses inverse iteration to approximate eigenvectors.




Number Theory Functions

The exact precision integer and rational arithmetic provided by Derive make it ideal for explorations into the theory of numbers.  The built-in Piecewise Continuous Functions and Probability Functions are especially useful for this purpose.  The file NumberTheoryFunctions.mth defines additional number theory functions in terms of the built-in functions.  The function definitions in the file are automatically loaded when any of its functions are first used.

EXTENDED_GCD(a, b) simplifies for integers a and b to a vector [d, [x, y]] of integers such that

d = gcd(a, b) = x·a + y·b

using the extended Euclidean gcd algorithm.  For example, to find the extended gcd of 20580 and 85176, simplify the expression

EXTENDED_GCD(20580, 85176)

SOLVE_MOD(u, x, m) simplifies to a vector of solutions of the linear congruence equation u(x) mod m.  For example, to solve the equation 3·x = 30 mod 9, simplify either of the expressions

SOLVE_MOD(3·x = 30, x, 9)
SOLVE_MOD(3·x - 30, x, 9)

CRT(a, m) simplifies to the solution of the system of linear congruence equations x = ai mod mi, where the elements of m must be pairwise coprime, using the Chinese Remainder Theorem (CRT).  For example, to solve the congruences x = 1 mod 4, x = 2 mod 5, and x = 3 mod 11, simplify the expression

CRT([1, 2, 3], [4, 5, 11])

NTH_PRIME(n) simplifies to the nth prime number.  For example, to make a table of the first 50 primes, simplify the expression

VECTOR(VECTOR(NTH_PRIME(n+m), m, 0, 40, 10), n, 1, 10)

PRIMEPI(x, d, a) simplifies to the number of primes p £ x, where x is a positive real number, such that p is of the form p = k·d + a for some k ³ 0.  d and a must be coprime natural numbers.  PRIMEPI(x) simplifies to the number of primes up to x.  For example,

[PRIMEPI(10000, 6, 1), PRIMEPI(10000, 6, 5) + 2, PRIMEPI(10000)]

simplifies to [611, 618, 1229].

FAREY(n) simplifies to a vector of Farey fractions of order n (i.e. all the fractions in the interval (0,1] whose denominator is not greater than n).  For example, to determine the Farey fractions of order 6, simplify the expression

FAREY(6)

DIVISORS(n) simplifies to the ordered vector of all the positive divisors of n.  For example, to determine the divisors of 28, simplify the expression

DIVISORS(28)

DIVISOR_SIGMA(k, n) simplifies to the sum of the kth powers of the positive divisors of n where k is a nonnegative integer.  For example, to determine the sum of the cubes of the divisors of 1000, simplify the expression

DIVISOR_SIGMA(3, 1000)

DIVISOR_TAU(n) simplifies to the number of divisors of n (i.e. it is equivalent to DIVISOR_SIGMA(0, n) ).  For example, to determine the number of divisors of 28, simplify the expression

DIVISOR_TAU(28)

EULER_PHI(n) simplifies to the Euler's totient function f(n) (i.e. the number of positive integers not greater than n that are relatively prime to n).  For example, to determine f(100), simplify the expression

EULER_PHI(100)

PRIME_POWER?(n) simplifies to true, if n is a power of a prime; otherwise it simplifies to false.  For example, to determine all prime powers not greater than 100, simplify the expression

SELECT(PRIME_POWER?(n), n, 1, 100)

PRIMITIVE_ROOT(n) simplifies to the smallest primitive root modulo n, if one exists; otherwise it simplifies to a question mark.  For example, to determine the primitive root modulo 54, simplify the expression

PRIMITIVE_ROOT(54)

MOEBIUS_MU(n) simplifies to the Moebius mu function of n.  For example, to determine the Moebius mu function of 100, simplify the expression

MOEBIUS_MU(100)

SQUAREFREE(n) simplifies to true, if n is square free (i.e. not divisible by the square of a prime); otherwise it simplifies to false.  For example, to determine if 837 is square free, simplify the expression

SQUAREFREE(837)

CYCLOTOMIC(n, x) simplifies to the nth cyclotomic polynomial in x.  For example, to determine the first 6 cyclotomic polynomials, simplify the expression

VECTOR([n, CYCLOTOMIC(n,x)], n, 1, 6)

GEN_LUCAS(n, p, q, L0, L1) simplifies to the nth term of the generalized Lucas sequence L(n) where L(0) = L0, L(1) = L1, and L(n+2) = p·L(n+1) - q·L(n).

U_LUCAS(n, p, q) simplifies to the nth term of the Lucas sequence U(n) where U(0)=0, U(1)=1, and U(n+2)=p·U(n+1)-q·U(n).  For example, to determine U(30) with p=1 and q=-1, simplify the expression

U_LUCAS(30, 1, -1)

V_LUCAS(n, p, q) simplifies to the nth term of the Lucas sequence V(n) where V(0)=2, V(1)=p, and V(n+2)=p·V(n+1)-q·V(n).  For example, to determine V(30) with p=1 and q=-1, simplify the expression

V_LUCAS(31, 1, -1)

U_MOD(n, p, q, m) simplifies to U_LUCAS(n, p, q) mod m, but is much more efficient.  If the discriminant p²-4·q is 0 mod m, a question mark is returned.  For example, to show that U(30) is divisible by 31 with p=1 and q=-1, simplify the expression

U_MOD(30, 1, -1, 31)

V_MOD(n, p, q, m) simplifies to V_LUCAS(n, p, q) mod m, but is much more efficient.  For example, to find V(31) mod 31 with p=1 and q=-1, simplify the expression

V_MOD(31, 1, -1, 31)

LUCAS(n) simplifies to the nth Lucas number (i.e. it is equivalent to V_LUCAS(n,1,-1)).  For example, to determine the first 11 Lucas numbers, simplify the expression

VECTOR(LUCAS(n), n, 0, 10)

FIBONACCI(n) simplifies to the nth Fibonacci number.  For example, to determine the first 11 Fibonacci numbers, simplify the expression

VECTOR(FIBONACCI(n), n, 0, 10)

PELL(n) simplifies to the nth Pell number.  For example, to determine the first 11 Pell numbers, simplify the expression

VECTOR(PELL(n), n, 0, 10)

LUCAS_LEHMER(p) simplifies to true, if the Mersenne number 2^p-1, where p is an odd prime, is prime, otherwise it simplifies to false.  For example, to determine if 2^31-1 is prime, simplify the expression

LUCAS_LEHMER(31)

NEXT_MERSENNE_DEGREE(n) simplifies to the smallest prime p > n such that the Mersenne number 2^p - 1 is prime.  For example, to determine the first prime p > 31 such that 2^p - 1 is prime, simplify the expression

NEXT_MERSENNE_DEGREE(31)

MERSENNE_LIST(n) simplifies to the first n primes p for which the corresponding Mersenne number 2^p - 1 is prime.  For example, to find the 12 smallest exponents of this kind, simplify the expression

MERSENNE_LIST(12)

MERSENNE_DEGREE(n) is the nth exponent (ordered by size) for which the corresponding Mersenne number is known to be prime.  For example, to determine the exponent of the largest known Mersenne prime as of 13 August 1999, simplify the expression

MERSENNE_DEGREE(38)

MERSENNE(n) simplifies to the nth Mersenne prime.  For example, to determine the first 12 Mersenne primes, simplify the expression

VECTOR(MERSENNE(n), n, 1, 12)

PERFECT(n) simplifies to the nth perfect number (i.e. numbers that are equal to the sum of their divisors).  For example, to determine the first 10 perfect numbers, simplify the expression

VECTOR(PERFECT(n), n, 1, 10)

CONTINUED_FRACTION(u, n) approximates to a vector of n+1 partial quotients of the continued fraction of u.  If ?s appear in the result, use the Precision field of the Options > Mode Settings > Simplification command to increase the precision.  For example, to determine the first 8 partial quotients of the continued fraction for the base of the natural logarithms e, simplify the expression

CONTINUED_FRACTION(#e, 8)

CONVERGENT(x, k) simplifies to the kth convergent of x based on the continued fraction of x.  For example, to approximate Ö2 using the 10th convergent, simplify the expression

CONVERGENT(SQRT(2), 10)

CONVERGENTS(x, k) simplifies to a vector of the 0 through kth convergents of x based on the continued fraction for x.  For example, to generate a vector of the first 11 convergents of Ö2, simplify the expression

CONVERGENTS(SQRT(2), 10)

JACOBI(a, b) simplifies to the Jacobi symbol (a/b), where a is assumed to be an integer and b an odd natural number.  Jacobi symbols play an important role in number theory.  In particular, if b is an odd prime, then 1 + (a/b) is the number of mod b incongruent solutions of the congruence x^2 = a mod b.  For example, to see whether 2 is a square mod 23 or not, simplify the expression

JACOBI(2, 23)

SQUARE_ROOT(a, p) simplifies to a square root of a mod p, where a is an integer and p a prime, if one exists and a question mark otherwise.  For example, to determine a square root of 2 mod 23, simplify the expression

SQUARE_ROOT(2,23)





Rational Approximation

The file RationalApproximation.mth defines functions that compute Pade rational approximations and Chebyshev series approximations to an expression.  The function definitions in the file are automatically loaded when any of its functions are first used.

PADE(y, x, x0, n, d) simplifies to the Pade rational approximation to expression y depending on variable x, centered at x0, requesting a numerator of degree n and a denominator of degree d.  y must be differentiable through order n+d.

Pade approximations are often more efficient and have a larger region of convergence than Taylor series, particularly in the neighborhood of non-polynomial behavior in y, such as asymptotes.  For example,

PADE(#e^x, x, 0, 3, 3)

simplifies to the following cubic over cubic rational approximation of e^x centered on x=0:

    3       2               
   x  + 12·x  + 60·x + 120  
- ------------------------- 
    3       2               
   x  - 12·x  + 60·x - 120  

CHEBYSHEV_T_SERIES(u, x, a, b, k, n) simplifies to the Chebyshev series approximation of u(x) over the interval [a, b] up to x^k using the nth order Maclaurin series approximation for u(x).  The integer k must be less than or equal to n.  If k=n, CHEBYSHEV_T_SERIES simplifies to the nth order Maclaurin series approximation for u(x).  For example,

CHEBYSHEV_T_SERIES(EXP(x), x, -1/2, 1/2, 4, 5)

simplifies to the following 4th degree Chebyshev series approximation of e^x over the interval -1/2 to 1/2:

  4         3      2                 
 x      65·x      x      6143·x      
---- + ------- + ---- + -------- + 1 
 24      384       2      6144       





Vector and Matrix Functions

The file VectorMatrixFunctions.mth defines functions that automate some of the operations commonly performed on vectors and matrices.  The function definitions in the file are automatically loaded when any of its functions are first used.

In Derive, an n by m matrix is stored internally as a vector of n elements, each of which is an m element vector.  Therefore, it is possible to write functions that apply operations to the rows of a matrix.  Moreover, by transposing a matrix, applying a function that operates on the rows of the resulting matrix, and finally transposing the result, makes it possible to apply operations to the columns of a matrix.

i_  simplifies to the vector [1, 0, 0].
j_  simplifies to the vector [0, 1, 0].
k_  simplifies to the vector [0, 0, 1].

These three assigned variables represent the unit vectors i, j, and k for the rectangular (Cartesian) coordinate system.  The underscore in their names is meant to suggest a vector and to distinguish them from the user variables i, j, and k.  Any Cartesian coordinate vector can be entered as a linear combination of unit vectors.  For example,

a·i_ + 3·j_ - k_

simplifies to

[a, 3, -1]

OUTER(v, w) simplifies to the outer product of vectors v and w.  For example,

OUTER([a, b], [2, 3, 4])

simplifies to

é 2·a  3·a  4·a ù
ê               ú
ë 2·b  3·b  4·b û

KRONECKER(i, j) simplifies to 1 if integer i equals integer j, otherwise it simplifies to 0.  The Kronecker delta function of i and j is often written as delta sub i, j .  KRONECKER is a useful utility function for implementing various vector and matrix operations.

The next several functions perform various operations on vectors and matrices:

APPEND_COLUMNS(A, B, ...) appends the columns of its arguments, which all must be matrices having the same number of rows.  It can be given any number of matrices or a vector of matrices.  For example,

APPEND_COLUMNS([a, b; c, d], [e; f], [g; h])

and

APPEND_COLUMNS([[a, b; c, d], [e; f], [g; h]])

both simplify to

é a  b  e  f ù
ê            ú
ë c  d  g  h û

PARTITION(v, n, d) simplifies to a partition of vector v into vectors of length n with an offset delta of d.  d defaults to n.  For example,

PARTITION([1, 2, 3, 4, 5], 3, 2)

simplifies to

é 1  2  3 ù
ê         ú
ë 3  4  5 û

REMOVE_ELEMENTS(v, v_) removes any occurrences of the elements in v_ from the vector v.  For example,

REMOVE_ELEMENTS([a, b, b, c, d, d, d, d, e, e], [b, d, e])

simplifies to

[a, c]

v_ need not necessarily be a vector.  To remove one element, say d in the previous example, then simplifying

REMOVE_ELEMENTS([a, b, b, c, d, d, d, d, e, e], d)

yields the vector

[a, b, b, c, e, e]

MATPROD(A, B, i, j) simplifies to the element on the ith row and jth column of the dot product of matrices A and B.  The elements of the product of two matrices with nonnumeric elements are often much bulkier than the elements of the original matrices.  MATPROD allows you to compute a matrix product one element at a time.  Alternatively, a matrix product can be computed one row at a time by simplifying expressions of the form A SUB i · B, for i=1 to the dimension of A.

The file VectorMatrixFunctions.mth makes the following assignments for polar-cylindrical and spherical coordinate geometry matrices for use with the built-in vector calculus functions (see Differential Vector Calculus and Integral Vector Calculus):

               é r  è  z ù
cylindrical := ê         ú
               ë 1  r  1 û

and

             é r      è     Ö ù
spherical := ê                ú
             ë 1  r·SIN(Ö)  r û

The file also defines functions for finding other coordinate geometry matrices in any orthogonal, curvilinear coordinate system.  First, compute the Jacobian matrix of the transformation from curvilinear to rectangular (Cartesian) coordinates.  Next, compute the covariant metric tensor from the Jacobian matrix.  If this matrix is diagonal, the coordinates are orthogonal, and you can proceed to compute the geometry matrix from the curvilinear coordinates and this diagonal:

Assume the transformation from curvilinear to some rectangular (Cartesian) coordinates is given by

x = u(q1, q2, ..., qm)

where x is a vector of n rectangular coordinates, and u is a vector of n expressions depending on curvilinear coordinates q1 through qm, with m £ n.  (m < n corresponds to a hyper-surface imbedded in a higher-dimensional space.)

JACOBIAN(u, q) simplifies to the Jacobian matrix of the above transformation, where q = [q1, q2, ..., qm].  The Jacobian is the n by m matrix of partial derivatives of u, with dui/dqj located at row i and column j.  For example, the transformation from parabolic to rectangular (Cartesian) coordinates is x = (w²-v²)/2 and y = w·v and

JACOBIAN([(w^2 - v^2)/2, w·v], [w, v])

simplifies to

é w  -v ù
ê       ú
ë v   w û

COVARIANT_METRIC_TENSOR(A) simplifies to the covariant metric tensor of the Jacobian matrix A.  Note that a coordinate system is orthogonal only if the elements off the main diagonal of the covariant metric tensor of its Jacobian matrix are 0.  For example, the parabolic coordinate system is orthogonal since

COVARIANT_METRIC_TENSOR([w, -v; v, w])


simplifies to

é  2    2          ù
ê v  + w      0    ú
ê                  ú
ê           2    2 ú
ë    0     v  + w  û

GEOMETRY_MATRIX(q, G) simplifies to the geometry matrix for curvilinear coordinate vector q having a covariant metric tensor G.  For example,

GEOMETRY_MATRIX([u, v], [v^2 + w^2, 0; 0, v^2 + w^2])

simplifies to

é      u           v     ù
ê                        ú
ê    2    2      2    2  ú
ë Ö(v  + w )  Ö(v  + w ) û

Note that the second row of the geometry matrix is just the square roots of the diagonal elements of the covariant tensor.  In some cases, simplification of the square roots may lead to unwanted absolute values unless you use the Author > Variable Domain command to appropriately restrict the domain of some coordinate variables.  For example, with spherical coordinates r should be declared nonnegative and F should be declared between 0 and p.

RECTANGULAR_TO_POLAR(x, y) simplifies to a vector of the polar coordinates of the point (x,y) expressed in rectangular coordinates.  For example,

RECTANGULAR_TO_POLAR(3, 4)

simplifies to

é    ð          æ 1 öù
ê5, --- - 2·ATANç---÷ú
ë    2          è 3 øû

and approximates to [5, 0.9272952180].

POLAR_TO_RECTANGULAR(r, q) simplifies to a vector of the rectangular coordinates of the point (r,q) expressed in polar coordinates.  For example,

POLAR_TO_RECTANGULAR(2, pi/3)

simplifies to [1, Ö3].

POLAR_SUM(p, q) simplifies to the vector sum of the points p and q each expressed in polar coordinates as a two-element vector.  For example,

POLAR_SUM([1, pi/2], [2, pi/3])

simplifies to

[Ö(2·Ö3 + 5), ATAN(Ö3 + 1)]

and approximates to [2.909312911, 1.219916915].





Miscellaneous Functions

The file MiscellaneousFunctions.mth contains functions for miscellaneous tasks that do not fit the categories of the other utility files.  The function definitions in the file are automatically loaded when any of its functions are first used.

SQUARE_WAVE(n) simplifies to 1 if n mod 2 is less than 1, otherwise it simplifies to -1.

Consider the sum of t from n=a to infinity where t is an expression dependent on index variable n.  To determine if the series converges or diverges for a given t, first enter the above sum and see if it simplifies to a closed form of finite or infinite magnitude.  Success in finding a closed form sum may require restricting the domains of variables in t (other than the index variable n) to appropriate intervals (see the Author > Variable Domain command).

If Derive does not return a closed form sum, there are many tests you can use to determine if a series converges or diverges.  For example, Leibniz's alternating series test states that a series converges if

·	t alternates in sign beyond a certain n,

·	the limit of t as n approaches infinity is 0, and

·	|t| is nonincreasing beyond a certain n.

Convergence tests for non-alternating series are given in Calculus textbooks.  Most of these tests are easy to apply directly using Derive's Calculus Limit or  Calculus Integrate commands.  However, the particularly useful ratio test requires a substitution followed by a limit, so the following function is defined in MiscellaneousFunctions.mth to facilitate performing this test:

RATIO_TEST(t, n) simplifies to the limit of the absolute value of the ratio of the n+1th term of the series to the nth term, as n approaches infinity.  If the result is greater than 1, the series diverges.  If the result is less than 1, the series converges.  If the result equals 1, the test is inconclusive.

If u(x,y) is an expression dependent on the variables x and y, Derive simplifies LIM(u, [x, y], [x0, y0]) by first computing the limit with respect to x, then with respect to y.  This result may be different than LIM(u, [y, x], [y0, x0]).  In contrast, the following function returns the multivariate limit:

LIM2(u, x, y, x0, y0) simplifies to the limit of u as [x, y] approaches [x0, y0] along a straight line of slope @1.  For example,

LIM2((x^2-y^2)/(x^2+y^2),x,y,0,0)

simplifies to (1-@1^2)/(@1^2+1).  If the result is independent of @1, the limit is independent of the direction of approach.  For example,

LIM2((SIN(x^2)-SIN(y^2))/(x-y),x,y,0,0)

simplifies to 0, and so the limit is independent of the direction of approach.

The adaptive Simpson's Rule method Derive uses to numerically approximate definite integrals is fast, robust, and accurate (see the Calculus Integrate command).  However, simpler numerical integration methods are useful for educational purposes; for obtaining rigorous bounds on the integrals of monotonic, concave, or convex integrands; and for approximating definite integrals when the integrands depend on parameters other than the integration variable.

LEFT_RIEMANN(u, x, a, b, n) approximates to the left Riemann sum for the integral of expression u from x=a through b, using n equal-width rectangular strips.  If Derive can determine a closed form for the sum for symbolic n, then you may prefer to use the  Simplify Basic Command rather than the Simplify Approximate Command so that you can simplify the limit of that closed-form sum as n approaches infinity.  Otherwise you should use numeric n and the Simplify Approximate command.

There may be expressions for which Derive is unable to find a closed form antiderivative, even though one exists.  You may be able to help Derive integrate such expressions by using one of the following functions to explicitly integrate by parts or to make a change of variable.  

INT_PARTS(u, v, x) uses integration by parts to find the antiderivative of the expression u·v with respect to x.

INT_SUBST(y, x, u) finds the antiderivative of the expression y(x) with respect to x by substituting the inverse of u(x) for x in y, integrating, and then substituting u(x) for x in the result.  This technique is called integration by substitution.  For example,

INT_SUBST(t·SIN(t^2), t, t^2)

simplifies to

        2  
   COS(t ) 
- ---------
      2    

DEF_INT_SUBST(y, x, u, a, b) finds the definite integral of the expression y(x) from x=a to x=b by substituting the inverse of u(x) for x in y and integrating the result from u(a) to u(b).

INVERSE(u, x) simplifies to the inverse of expression u(x) with respect to x.  For example,

INVERSE(SIN(x/b), x)

simplifies to b·asin(x).  Note that making appropriate domain declarations (see the Author > Variable Domain command) of variables that occur in u will help INVERSE produce the desired result.


Derive can assist with many proofs, including inductive ones.  The classic example of an inductive proof is showing that the sum of t(k) from k=a to n equals s(n).  This can be done by proving that t(a) - s(a) = 0 and proving that

s(n) + t(n+1) - s(n+1) = 0

This is just substitution followed by algebraic simplification, seeking two expressions equivalent to zero.  Consequently, it is easily automated using the LIM function to do the substitutions:

PROVE_SUM(t, k, a, n, s) simplifies to a vector of two expressions.  If both expressions are equivalent to 0, the sum formula above is proved.  If either expression is not equivalent to 0, the sum formula is disproved.  The technique used in PROVE_SUM can be adapted to many other broad categories of inductive proofs.

The following two functions are for extracting components of polynomials:

POLY_COEFF(u, x, n) simplifies to the coefficient of the x^n term(s) of the polynomial u(x).

POLY_DEGREE(u, x) simplifies to the degree of x in the polynomial u(x).  Note that it returns -1 as the degree of 0, the zero polynomial.  If desired, the definition of POLY_DEGREE can be modified using an IF expression to return 0 if u=0.  Others may prefer that it be modified to return minus infinity if u=0.

The following functions and variable show how the pseudo-random number generator function (see the Probability Functions) can be used:

random_sign simplifies to either 1 or -1 randomly with equal probability.

RANDOM_POLY(x, d, s) simplifies to a polynomial of degree d in the variable x with random number coefficients between -s and s exclusive.

RANDOM_VECTOR(n, s) simplifies to an n element vector with random number elements between -s and s exclusive.

RANDOM_MATRIX(m, n, s) simplifies to an m by n element matrix with random number elements between -s and s exclusive.

RANDOM_NORMAL(s,m) simplifies to a random value with a normal distribution having a standard deviation of s and a mean value of m.

The following function indicates how well an expression approximates a set of data points:

GOODNESS_OF_FIT(u, x, A) returns the standard deviation of expression u(x) from the values given in data matrix A.  u(x) can be the expression returned by the built-in function FIT, provided u(x) is dependent on only one data variable (see the Statistical Functions).  For numerical data, GOODNESS_OF_FIT should be approximated rather than simplified.

POLY_INTERPOLATE(A, x)  simplifies to the polynomial in variable x that interpolates the  [x, y]  coordinate pairs given by the rows of the two-column matrix A.  When applicable, POLY_INTERPOLATE is generally preferable to the built-in FIT function (see the Statistical Functions).  For example,

POLY_INTERPOLATE([[0,0], [1,1], [2,2], [3,0]], x)

simplifies to

  2         
 x ·(3 - x) 
------------
      2     

POLY_INTERPOLATE_EXPRESSION(u, x, a)  simplifies to the polynomial in variable x that interpolates the expression u given the one dimensional vector of supporting points a.








INDICIES

Derive Constants

Several mathematical constants are defined in Derive.  The first column shows how the constants are displayed on the screen.  The second column shows how the constants can be typed in on the expression entry line.  

The following are the built-in Derive constants.  The first 5 built-in constants can also be entered by pressing the indicated control key ("hotkey") combination or by selecting them off the math symbol toolbar.

p	pi  (Ctrl+P)	area of unit circle (3.14159...)

e	#e  (Ctrl+E)	base of natural logarithms (2.71828...)
i	#i  (Ctrl+I)	imaginary unit (square root of -1)
¥	inf  (Ctrl+0)	plus infinity
g	euler_gamma	Euler's constant (0.577215...)
true	true	logical constant ‘true’
false	false	logical constant ‘false’
unit_circle	unit_circle	arbitrary point on unit circle

The following constants are defined in the VectorMatrixFunctions.mth utility file:

cylindrical	cylindrical	cylindrical geometry matrix r, q, z

spherical	spherical	spherical geometry matrix r, q, F
i_	i_	[1, 0, 0]: unit vector for x-axis
j_	j_	[0, 1, 0]: unit vector for y-axis
k_	k_	[0, 0, 1]: unit vector for z-axis

The following constant is defined in the GraphicsFunctions.mth utility file:

axes	axes	3D coordinate axes




Derive Operators

The following are the mathematical operators in Derive.  The first column shows how the operators are displayed on the screen.  The second column shows how the operators can be typed in on the expression entry line.  Alternatively, the operators can be entered by selecting them off the math symbol toolbar or by pressing the indicated control key (hotkey) combination:



Mathematical Operators

u + v	u + v	u plus v
-u	-u	minus u
u - v	u - v	u minus v
u · v	u * v	u times v
u / v	u / v	u divided by v
u ^ v	u ^ v	u raised to v
vu	SQRT(u)	square root of u (Ctrl+Q)
u%	u%	u percent
u!	u!	u factorial
u°	u deg	u degrees (Ctrl+O)
±u	"+-"u	plus or minus u
'x	'x	quote x



Relational Operators

u = v	u = v	u equals v
u ¹ v	u /= v	u not equal v
u < v	u < v	u less than v
u £ v	u <= v	u less than or equal to v
u > v	u > v	u greater than v
u ³ v	u >= v	u greater than or equal to v



Boolean Operators

(If operands are integers, bit-wise logical operations are performed on them.)

Ø p	NOT p	negation of p
p Ù q	p AND q	conjunction of p and q
p Ú q	p OR q	disjunction of p and q
p Ú q	p XOR q	exclusive or of p and q
p ® q	p IMP q	logical implication of p and q
p « q	p IFF q	logical equivalence of p and q



Set Operators

u`	u`	complement of set u
u Ç v	u INTERSECTION v	intersection of sets u and v (Ctrl+N)
u È v	u UNION v	union of sets u and v (Ctrl+U)
u \ v	u \ v	set difference of sets u and v
u Í v	u SUBSET v	true if u is a subset of v; otherwise false



Vector Operators

u · v	u . v	sum of products of elements of vectors u and v
u · v	u DOTPRODUCT v	dot product of vectors u and v
u ´ v	u CROSSPRODUCT v	cross product of vectors u and v
v ¯ n	v SUB n	nth element of vector v (Ctrl+B)
v ¯ [n1,...,nm]	v SUB [n1,...,nm]	vector of elements n1 through nm of vector v





Matrix Operators

A`	A`	transpose of matrix A (Ctrl+T)
A · B	A . B	product of matrices A and B
v · A	v . A	product of vector v and matrix A
A · v	A . v	product of matrix A and vector v
A ROW n	A ROW n	nth row of matrix A
A COL n	A COL n	nth column of matrix A
A ¯ n	A SUB n	nth row of matrix A
A ¯¯ n	A SUB SUB n	nth column of matrix A
A ¯ n ¯ m	A SUB n SUB m	element in nth row and mth column of matrix A
A ¯ [n1,...,nm]	A SUB [n1,...,nm]	matrix of rows n1 through nm of matrix A

A ¯¯ [n1,...,nm]	A SUB SUB [n1,...,nm]	matrix of columns n1 through nm of matrix A

Assignment Operators

x :=	declare x an arbitrary variable
x := u	declare x a variable and assign it the value u
F(x, y, ...) :=	declare F an arbitrary function with formal variables x, y, ...
F(x, y, ...) := u	declare F a function with formal variables x, y, ... defined as u(x, y, ...)
F v := u	declare F a function of  any number of variables defined as u(x, y, ...)
x :Î domain	declare x an arbitrary variable in the given domain
x :Î domain interval	declare x an arbitrary variable in the given domain and interval

Update Operators

x :+ u	assign variable x the value x+u
x :- u	assign variable x the value x-u
x :* u	assign variable x the value x·u
x :/ u	assign variable x the value x/u





Built-in Functions

The following is an alphabetical list of the functions built-into Derive (see Built-in Functions and Constants).


ABS(x)	absolute value of real x
ABS(z)	magnitude (modulus) of complex z
ABS(v)	magnitude (length) of vector v
ACOS(z)	angle whose cosine is z
ACOSH(z)	inverse hyperbolic cosine of z
ACOT(x,y)	angle of the point (x,y)
ACOT(z)	angle whose cotangent is z
ACOTH(z)	inverse hyperbolic cotangent of z
ACSC(z)	angle whose cosecant is z

ACSCH(z)	inverse hyperbolic cosecant of z
ADJOIN(u,v)	adjoin u to the front of vector v
APPEND(v,w)	vector of elements of v followed by elements of w
APPROX(u)	approximate u using the current digits of precision
APPROX(u,n)	approximate u using n digits of precision
ASEC(z)	angle whose secant is z
ASECH(z)	inverse hyperbolic secant of z
ASIN(z)	angle whose sine is z
ASINH(z)	inverse hyperbolic sine of z
ASSIGN(v,u)	if the value of v is a variable, assigns that variable the value u
ATAN(y,x)	angle of the point (x,y)
ATAN(z)	angle whose tangent is z
ATANH(z)	inverse hyperbolic tangent of z
AVERAGE(z1,...,zn)	arithmetic mean (average) of z1, ..., zn

CEILING(m)	smallest integer ³ m
CEILING(m,n)	smallest integer ³ m/n
CHARPOLY(A,v)	characteristic polynomial of square matrix A in terms of variable v
CHI(a,x,b)	if a<x<b, returns 1; if x<a or x>b, returns 0
CHI(a,x,b,c)	if x=a, returns c; if x=b, returns 1-c; else returns CHI(a,x,b)
CHI(a,x,b,c,d)	if x=a, returns c; if x=b, returns d; else returns CHI(a,x,b)

CODES_TO_NAME(v)	string or integer corresponding to ASCII codes in vector v
COMB(z,w)	combinations of z things taken w at a time
CONJ(z)	complex conjugate of z
COS(z)	cosine of z radians
COSH(z)	hyperbolic cosine of z
COT(z)	cotangent of z radians
COTH(z)	hyperbolic cotangent of z
CSC(z)	cosecant of z radians
CSCH(z)	hyperbolic cosecant of z

CURL(v)	curl of 2 or 3 element vector v wrt variables x, y, and z
CURL(v,w)	curl of 2 or 3 element vector v wrt variables in vector w
CURL(v,A)	curl of 2 or 3 element vector v using coordinate geometry matrix A

DELETE(v,n)	delete element n from vector v
DENOMINATOR(u)	syntactic denominator of u
DET(A)	determinant of matrix A
DIF(u,x)	derivative of u(x) wrt x
DIF(u,x,n)	nth order derivative of u(x) wrt x
DIF(u,x,-n)	nth-order antiderivative of u(x) wrt x
DIGAMMA(x)	digamma function y(x)
DIM(v)	number of elements of vector v
DISPLAY(u,n)	display u using up to n lines of text in a new text box

DIV(v)	divergence of vector v wrt variables x, y, and z
DIV(v,w)	divergence of vector v wrt variables in vector w
DIV(v,A)	divergence of vector v using coordinate geometry matrix A

EIGENVALUES(A,v)	eigenvalues of square matrix A in terms of variable v
ELEMENT(v,n)	nth element of vector v
ELEMENT(A,j,k)	element in jth row and kth column of matrix A
ERF(z)	error function of z
ERF(z,w)	generalized error function of z and w
ERFC(z)	complementary error function of z
EVEN?(k)	if k is an even number, return true; otherwise return false
EVERY(u,x,c)	if u(x) is true for every x in c, return true; otherwise return false

EVERY(u,k,m,n,s)	if u(k) is true for every k=m to n in steps of s, return true; otherwise return false
EXP(z)	exponential of z (that is e^z)
EXPAND(u,amount,x,y,...)	expand u by amount wrt variables x,y,...

FACTOR(u,amount,x,y,...)	factor u by amount wrt variables x,y,...
FACTORS(n)	vector of pairs of primes and their powers of factorization of integer n
FACTORS(u)	vector of pairs of syntactic factors and their powers of expression u
FIRST(v)	first element of vector v
FIT(v,A)	least squares fit of label vector v to data matrix A
FLOOR(m)	integer part of m
FLOOR(m,n)	greatest integer £ m/n

FVAL(i,nper,pmt,pval,time)	future value of contract

GAMMA(z)	gamma function of z
GCD(m,n,...)	greatest common divisor of m, n, ...
GRAD(u)	gradient of expression u wrt variables x, y, and z
GRAD(u,w)	gradient of expression u wrt variables in vector w
GRAD(u,A)	gradient of expression u using coordinate geometry matrix A
GROEBNER_BASIS(polys,vars)	Gröbner basis of polys based on lexicographic ordering vars
HEX(n)	nth hex (i.e. 6-sided centered) number

IDENTICAL?(u,v)	if u is identical to v, return true; otherwise return false
IDENTITY_MATRIX(n)	n by n identity matrix
IF(r)	if r is true, return 1; if r is false, return 0
IF(r,t,f)	if r is true, return expression t; if r is false, return expression f
IF(r,t,f,u)	if r is true, return expression t; if false, return expression f; if unknown, return u
IM(z)	imaginary part of z

INSERT(u,v,n)	insert u before the nth element of v
INT(u,x)	antiderivative of u(x) wrt x
INT(u,x,a,b)	definite integral of u(x) from x=a to b
INTEGER?(k)	if k is an integer, return true; otherwise return false
INTEGER_TYPE?(u)	if expression u is of integer type, return true; otherwise return false
INVERSE_MOD(a,m)	inverse of a mod m if it exists, and a question mark otherwise

ITERATE(u,x,x0)	1st repeated element of sequence x0, u(x0), u(u(x0)), ...
ITERATE(u,x,x0,n)	element n+1 of sequence x0, u(x0), u(u(x0)), ...
ITERATE(u,[x1,x2,...],[x01, x02,...])	1st repeated element of sequence [x01, x02,...],u(x01, x02,...),...
ITERATES(u,x,x0)	vector [x0,u(x0),u(u(x0)),...] until an element is repeated
ITERATES(u,x,x0,n)	1st n+1 elements of vector [x0,u(x0),u(u(x0)),...]

LAPLACIAN(u)	divergence of gradient of expression u wrt variables x, y, and z
LAPLACIAN(u,w)	divergence of gradient of expression u wrt variables in vector w
LAPLACIAN(u,A)	divergence of gradient of expression u using coordinate geometry matrix A
LCM(m,n,...)	least common multiple of m, n, ...
LHS(r)	left hand side (left operand) of relation r
LIM(u,x,a)	limit of u(x) as x approaches a

LIM(u,x,a,1)	limit of u(x) as x approaches a from above
LIM(u,x,a,-1)	limit of u(x) as x approaches a from below
LN(z)	natural logarithm of z
LOAD(filename)	load the utility file named filename
LOG(z)	natural logarithm of z
LOG(z,w)	logarithm of z to the base w
LOGICAL?(k)	if k is a truth-value (i.e. true or false), return true; otherwise return false
LOGICAL_TYPE?(u)	if expression u is of truth-value type, return true; otherwise return false

LOOP(s1,...,sn)	repeatedly simplify statements s1 through sn until a RETURN or EXIT statement encountered

MAP(u,x,c)	evaluates u(x) for x equal to elements of collection c and returns true
MAP(u,k,m,n,s)	evaluates u(k) for k=m to n in steps of size s and returns true
MAP_LIST(u,x,c)	evaluates u(x) for x equal to elements of collection c and returns result as a collection
MAP_LIST(u,k,m,n,s)	evaluates u(k) for k=m to n in steps of size s and returns result as a vector
MATRIX?(u)	if u is a matrix, return true; otherwise return false

MAX(x1,x2,...)	maximum of x1, x2, ...
MAX(v)	maximum element of vector v
MEMBER?(u,v)	if u is a member of v, return true; otherwise return false
MIN(x1,x2,...)	minimum of x1, x2, ...
MIN(v)	minimum element of vector v
MOD(m)	fractional part of m
MOD(m,n)	m modulo n (nonnegative remainder of m/n)
MODS(m,n)	symmetric m modulo n

NAME_TO_CODES(v)	vector of ASCII codes corresponding to the characters in string or integer s
NEXT_PRIME(n)	next prime larger than n
NORMAL(z)	cumulative distribution function of z
NORMAL(z,m,s)	normal distribution function of z with mean m and standard deviation s
NPER(i,pmt,pval,fval,time)	number of payment periods
NSOLUTIONS(u,x)	vector of approximate solutions of equation u=0 for variable x

NSOLUTIONS(B,x)	vector of approximate solutions of Boolean B for variable x
NSOLUTIONS(B,x,Real)	vector of approximate real solutions of Boolean B for variable x
NSOLUTIONS(B,v)	vector of vectors of simultaneous solutions of Boolean B for variables in vector v
NSOLUTIONS(w,v)	vector of vectors of simultaneous solutions of Booleans in vector w for variables in vector v
NSOLVE(u,x)	approximate solution of equation u=0 for variable x expressed as a Boolean equivalent to u=0

NSOLVE(B,x)	approximate solution of Boolean B for variable x expressed as a Boolean equivalent to B
NSOLVE(B,x,Real)	approximate real solution of Boolean B for variable x expressed as a Boolean equivalent to B
NSOLVE(B,v)	solution of Boolean B for variables in vector v expressed as a Boolean equivalent to B
NSOLVE(w,v)	solution of Booleans in vector w for variables in vector v expressed as a vector of Booleans whose disjunction is equivalent to the conjunction of the Booleans in vector w
NSOLUTIONS(w,v)	vector of vectors of simultaneous solutions of Booleans in vector w for variables in vector v
NSOLVE(u,x)	approximate solution of equation u=0 for variable x expressed as a Boolean equivalent to u=0

NSOLVE(B,x)	approximate solution of Boolean B for variable x expressed as a Boolean equivalent to B
NSOLVE(B,x,Real)	approximate real solution of Boolean B for variable x expressed as a Boolean equivalent to B
NSOLVE(B,v)	solution of Boolean B for variables in vector v expressed as a Boolean equivalent to B
NSOLVE(w,v)	solution of Booleans in vector w for variables in vector v expressed as a vector of Booleans whose disjunction is equivalent to the conjunction of the Booleans in vector w

NUMBER?(k)	if k is a real or complex number, return true; otherwise return false
NUMBER_TYPE?(u)	if expression u is real or complex, return true; otherwise return false
NUMERATOR(u)	syntactic numerator of u

ODD?(k)	if k is an odd number, return true; otherwise return false

PERM(z,w)	permutations of z things taken w at a time
PHASE(z)	phase angle of z
PMT(i,nper,pval,fval,time)	periodic payment
POLY_GCD(u,v)	polynomial gcd of u and v
POLY_MOD(u,n)	polynomial whose coefficients are those of polynomial u reduced by modulus n
POLY_MODS(u,n)	polynomial whose coefficients are those of polynomial u reduced by symetric modulus n
POSITION(e,v,n)	position of expression e in vector v after the nth element

POTENTIAL(v)	scalar potential of vector v starting at (0,0,0) wrt variables x, y, and z
POTENTIAL(v,w)	scalar potential of vector v starting at coordinates in vector w wrt variables x, y, and z
POTENTIAL(v,w,u)	scalar potential of vector v starting at coordinates in vector w wrt variables in vector u
POTENTIAL(v,w,A)	scalar potential of vector v starting at coordinates in vector w using geometry matrix A
POWER?(u)	if expression u is a power, return true; otherwise return false

POWER_MOD(n,d,m)	n^d mod m
POWER_SET(s)	all subsets of s
PREVIOUS_PRIME(n)	first prime smaller than n
PRIME?(n)	if n is prime, return true; otherwise return false
PRODUCT(c)	product of the elements of collection c
PRODUCT(u,k)	antiquotient of u(k) wrt k
PRODUCT(u,k,c)	product of u(k) for k an element of collection c
PRODUCT(u,k,m,n)	definite product of u(k) from k=m to n

PRODUCT?(u)	if expression u is a product, return true; otherwise return false
PROG(s1,...,sn)	simplify statements s1 through sn unless a RETURN(u) or EXIT statement encountered

PVAL(i,nper,pmt,fval,time)	present value of contract

QUOTIENT(u,v)	polynomial quotient of u divided by v

RANDOM(n)	if n=0, initialize seed based on current time
RANDOM(n)	if n=1, a random number in the interval [0,1)
RANDOM(n)	if n>1, a random integer  in the interval [0,n)
RANDOM(n)	if n<1, initialize random number seed to n
RANK(A)	rank of matrix A
RATE(nper,pmt,pval,fval,time,min,max)	periodic interest rate
RATIONAL?(k)	if k is a rational number, return true; otherwise return false

RE(z)	real part of z
REAL_TYPE?(u)	if expression u is real, return true; otherwise return false
REMAINDER(u,v)	polynomial remainder of u divided by v
REPLACE(u,v,n)	replace the nth element of v with u
REST(v)	returns a vector of all but the first element of v
RETURN(u)	immediately exit function and return u as its value
REVERSE(v)	reverse elements of vector v

RHS(r)	right hand side (right operand) of relation r
RMS(z1,...,zn)	root mean square of z1 through zn
ROUND(m,n)	nearest integer to m/n (n defaults to 1)
ROW_REDUCE(A)	row echelon form of A
ROW_REDUCE(A,B)	row echelon form of A augmented by B

SEC(z)	secant of z radians
SECH(z)	hyperbolic secant of z
SELECT(u,k,m,n,s)	vector of k as k goes from m thru n in steps of s for which u(k) is true
SELECT(u,k,c)	collection of those elements of collection c for which u(k) is true
SET?(u)	if u is a set, return true; otherwise return false
SET_TYPE?(u)	if expression u is of set type, return true; otherwise return false
SIGN(x)	sign of x
SIGN(z)	radial projection of z on unit circle
SIN(z)	sine of z radians
SIN(z·deg)	sine of z degrees
SINH(z)	hyperbolic sine of z
SOLUTIONS(u,x)	vector of solutions of equation u=0 for variable x
SOLUTIONS(B,x)	vector of solutions of Boolean B for variable x
SOLUTIONS(B,x,Real)	vector of real solutions of Boolean B for variable x
SOLUTIONS(B,v)	vector of vectors of simultaneous solutions of Boolean B for variables in vector v

SOLUTIONS(w,v)	vector of vectors of simultaneous solutions of Booleans in vector w for variables in vector v
SOLVE(u,x)	solution of equation u=0 for variable x expressed as a Boolean equivalent to u=0
SOLVE(B,x)	solution of Boolean B for variable x expressed as a Boolean equivalent to B
SOLVE(B,x,Real)	real solution of Boolean B for variable x expressed as a Boolean equivalent to B
SOLVE(B,v)	solution of Boolean B for variables in vector v expressed as a Boolean equivalent to B

SOLVE(w,v)	solution of Booleans in vector w for variables in vector v expressed as a vector of Booleans whose disjunction is equivalent to the conjunction of the Booleans in vector w
SOME(u,x,c)	if u(x) is true for some x in c, return true; otherwise return false
SOME(u,k,m,n,s)	if u(k) is true for some k=m to n in steps of s, return true; otherwise return false
SORT(v)	function to sort the elements of a vector or set v, and return the result as a vector

SQRT(z)	square root of z
STDEV(z1,...,zn)	standard deviation of z1 through zn
STEP(x)	step function of x
STRING(v)	string variable having same display name as variable v
STRING?(u)	if expression u is a string variable, return true; otherwise return false
SUBST(u,old,new)	substitute new for old in u
SUM(c)	sum of the elements of collection c
SUM(u,k)	antidifference of u(k) wrt k

SUM(u,k,c)	sum of u(k) for k an element of collection c
SUM(u,k,m,n)	definite sum of u(k) from k=m to n
SUM?(u)	if expression u is a sum, return true; otherwise return false

TABLE(u,k,m,n,s)	table of (n-m+1)/s rows of u(k) simplified with k=m to n in steps of size s
TAN(z)	tangent of z radians
TANH(z)	hyperbolic tangent of z
TAYLOR(u,x,a,n)	nth order Taylor approximation of u(x) about x=a
TERMS(u)	vector of syntactic terms of u
TRACE(A)	trace of matrix A (sum of diagonal elements)
TRUTH_TABLE(p1,p2,...,bool1,bool2,...)	truth table matrix for Boolean expressions bool1, bool2, ...

VARIABLE?(u)	if u is a variable, return true; otherwise return false
VARIABLES(u)	a vector of the free variables in u
VARIANCE(z1,...,zn)	variance of z1, ..., zn
VECTOR(u,k,v)	vector of u(k) applied to elements of vector v
VECTOR(u,k,n)	vector of u(k) as k goes from 1 thru n in steps of 1
VECTOR(u,k,m,n)	vector of u(k) as k goes from m thru n in steps of 1
VECTOR(u,k,m,n,s)	vector of u(k) as k goes from m thru n in steps of s

VECTOR?(u)	if u is a vector, return true; otherwise return false
VECTOR_POTENTIAL(v)	vector potential of vector v starting at (0,0,0) wrt variables x, y, and z
VECTOR_POTENTIAL(v,w)	vector potential of vector v starting at vector w wrt variables x, y, and z
VECTOR_POTENTIAL(v,w,u)	vector potential of vector v starting at vector w wrt variables in vector u
VECTOR_POTENTIAL(v,w,A)	vector potential of vector v starting at vector w using geometry matrix A

VECTOR_TYPE?(u)	if expression u is of vector type, return true; otherwise return false

WRITE(u)	write u as a line of text on the Algebra window status line

ZETA(s)	the Riemann zeta function z(s)
ZETA(s,z)	the Hurwitz zeta function z(s,z)





Utility File Functions

The following is an alphabetical list of the functions defined in the utility files in Math directory distributed with Derive (see the Utility File Library).  These functions are automatically load on demand.


ADJOINT(A)	adjoint of square matrix A
AI_SERIES(z,m)	m+1 terms of series approximation for Airy function Ai(z)
ALMOST_LIN(r,b,p,q,x,y,x0,y0)	implicit solution of r(x,y)y'+p(x)b(y)=q(x) if almost linear
ALMOST_LIN_GEN(r,b,p,q,x,y,c)	general solution of r(x,y)y'+p(x)b(y)=q(x) if almost linear
APPEND_COLUMNS(A,B)	append columns of A and B
APPROX_EIGENVECTOR(A,m)	approximate eigenvector of A for approximate eigenvalue m

ARC_LENGTH(y,x,x1,x2)	arc length of y(x) from x=x1 to x2
ARC_LENGTH(y,x,x1,x2,m)	integral of m(x) along arc y(x) from x=x1 to x2
ARCS(w,z,r0,rm,m,q0,qn,n)	w-plane map of polar z-plane grid r=r0...rm, q=q0...qn
AREA(x,x1,x2,y,y1,y2)	area of region x=x1 to x2 and y=y1(x) to y2(x)
AREA(x,x1,x2,y,y1,y2,m)	integral of m(x,y) over region

AREA_CENTROID(x,x1,x2,y,y1,y2)	area centroid of region
AREA_CENTROID(x,x1,x2,y,y1,y2,m)	centroid of density m(x,y) over region
AREA_INERTIA(x,x1,x2,y,y1,y2)	area inertia tensor of region
AREA_INERTIA(x,x1,x2,y,y1,y2,m)	inertia tensor of density m(x,y)
AREA_OF_REVOLUTION(y,x,x1,x2)	area of y(x) revolved about x-axis
AreaBetweenCurves(u,v,x,a,b)	plots area between u(x) and v(x) from x = a to b (a < b)

AreaOverCurves(u,x,a,b)	plots area over u(x) and under the x-axis from x = a to b (a < b)
AreaUnderCurves(u,x,a,b)	plots area under u(x) and above the x-axis from x = a to b (a < b)
AREAY_OF_REVOLUTION(y,x,x1,x2)	area of y(x) revolved about y-axis
ASSOCIATED_LEGENDRE_P(n,m,x)	nth associated Legendre polynomial Pn(m)(x)
AUTONOMOUS(r,v)	dv/dy, given y"=r(y,v), reducing to sequence of two 1st order

AUTONOMOUS_CONSERVATIVE(q,x,y,x0,y0,v0)	solves y"=q(y), y=y0 and y'=v0 at x=x0

BELL(n)	nth Bell or exponential number
BERNOULLI(n)	nth Bernoulli number
BERNOULLI_ODE(p,q,k,x,y,x0,y0)	implicit solution of Bernoulli equation y'+p(x)y=q(x)y^k
BERNOULLI_ODE_GEN(p,q,k,x,y,c)	general solution of Bernoulli equation y'+p(x)y=q(x)y^k
BERNOULLI_POLY(n,x)	nth Bernoulli polynomial evaluated at x
BESSEL_I(n,z)	modified Bessel function of 1st kind In(z)
BESSEL_I_ASYMP(n,z)	2-term asymptotic approximation for In(z)

BESSEL_I_SERIES(n,z,m)	m+1 terms of series approximation for In(z)
BESSEL_J(n,z)	Bessel function of 1st kind Jn(z)
BESSEL_J_ASYMP(n,z)	1-term asymptotic approximation for Jn(z)
BESSEL_J_LIST(n,z)	vector of Bessel functions of 1st kind J0(z) through Jn(z)
BESSEL_J_SERIES(n,z,m)	m+1 terms of series approximation for Jn(z)
BESSEL_K(n,z)	modified Bessel function of 2nd kind Kn(z)

BESSEL_K_ASYMP(n,z)	2-term asymptotic approximation for Kn(z)
BESSEL_Y(n,z)	Bessel function of 2nd kind Yn(z), n fractional
BESSEL_Y_ASYMP(n,z)	1-term asymptotic approximation for Yn(z)
BESSEL_Y_SERIES(n,z,m)	m+1 terms of series approximation for Yn(z), n integer
BI_SERIES(z,m)	m+1 terms of series approximation for Airy function Bi(z)
BINOMIAL_DENSITY(k,n,p)	binomial probability density function

BINOMIAL_DISTRIBUTION(k,n,p)	cumulative probability binomial distribution function

CATALAN(n)	nth Catalan number
CENTER_OF_CURVATURE(y,x)	center of curvature of y(x)
CENTERED(n,p)	nth p-sided centered number
CENTERED_CUBE(n,d)	nth d-dimensional centered cube number
CENTERED_HEX(n,d)	nth d-dimensional centered hex number
CENTERED_PYRAMID(n,p)	nth p-sided d-dimensional centered pyramid number
CHEBYCHEV_T(n,x)	nth Chebychev polynomial of 1st kind Tn(x)

CHEBYCHEV_T_LIST(n,x)	vector of first n Chebychev polynomials of 1st kind
CHEBYCHEV_U(n,x)	nth Chebychev polynomial of 2nd kind Un(x)
CHEBYCHEV_U_LIST(n,x)	vector of first n Chebychev polynomials of 2st kind
CHI_SQUARE(u,v)	Chi-square distribution P(u|v), u = c²
CI(z)	cosine integral Ci(z), -p < phase z < p
CLAIRAUT(p,q,x,y,v,c)	vector of general and implicit solutions of generalized Clairaut differential equation
CLAIRAUT_DIF(p,q,d,x,y,c)	implicit solution of Clairaut difference equation
COFACTOR(A,i,j)	numerator of element i,j of inverse of square matrix A
CONE(f,q,z)	3D coordinate vector of cone at an angle of f radians from z-axis
CONTINUED_FRACTION(x,n)	vector of n+1 partial quotients of continued fraction of x
CONVERGENT(x,k)	kth convergent of x based on continued fraction of x

CONVERGENTS(x,k)	vector of first k+1 convergents of x based on continued fraction of x
COPROJECTION(A)	convert matrix A from lines of constant t to constant s
COVARIANT_METRIC_TENSOR(A)	covariant metric tensor of Jacobian matrix A
CRT(a,m)	solution of system of linear congruence equations x = ai mod mi
CURVATURE(y,x)	curvature of y(x)
CYCLOTOMIC(n,x)	simplifies to the nth cyclotomic polynomial in x

CYLINDER(r,q,z)	3D coordinate vector of cylinder of radius r from z-axis
CYLINDRICAL_VOLUME(r, r1,r2,q,q1,q2,z,z1,z2)	volume of region in cylindrical coordinates
CYLINDRICAL_VOLUME(r,r1,r2,q,q1,q2,z,z1,z2,m)	integral of m(r,q,z) over region in cylindrical coordinates

DAWSON(x)	Dawson’s integral F(x)
DEF_INT_PARTS(u,v,x,a,b)	integral of u(x)·v(x) from x=a to b using integration by parts
DEF_INT_SUBST(y,x,u,a,b)	integral of y(x) from x=a to b using substitution
DIF_DATA(A)	1st derivative of 2-column numeric data matrix A
DIF_NUMERIC(y,x,x0,h,n)	nth derivative of y wrt x at x0 using step size h
DIF2_DATA(A)	2nd derivative of 2-column numeric data matrix A

DIGAMMA_PSI(z)	approximation for digamma function y(z)
DILOG(x)	dilogarithm function of x
DIRECTION_FIELD(r,x,x0,xm,m,y,y0,yn,n)	vector that plots as direction field for y'=r(x,y)
DISTINCT_PARTS(n)	number of decompositions of n into integer summands
DIVISOR_SIGMA(k,n)	sum of kth powers of positive divisors of n
DIVISOR_TAU(n)	number of divisors of n
DIVISORS(n)	ordered vector of all positive divisors of n

DSOLVE1(p,q,x,y,x0,y0)	specific solution of p(x,y)+q(x,y)y'=0 with initial conditions y=y0 at x=x0
DSOLVE1_GEN(p,q,x,y,c)	general solution of p(x,y)+q(x,y)y'=0 in terms of c
DSOLVE2(p,q,r,x,c1,c2)	general solution of y"+p(x)y'+q(x)y=r(x) in terms of c1 and c2
DSOLVE2_BV(p,q,r,x,x0,y0,x2,y2)	specific solution of y"+p(x)y'+q(x)y=r(x) with boundary conditions
DSOLVE2_IV(p,q,r,x,x0,y0,v0)	specific solution of y"+p(x)y'+q(x)y=r(x) with initial conditions

EI(x,m)	m terms of series approximation for exponential integral Ei(x)
EI1(z,m)	m terms of series approximation for E1(z), -p < phase z < p
EIF(F,m,n)	n iteration approximation of elliptic integral of 1st kind F(F|m)
ELLIPTIC_E(F,m)	approximation of elliptic integral of 2nd kind E(F|m)
ELLIPTIC_F(F,m)	approximation of elliptic integral of 1st kind F(F|m)

ELLIPTIC_PI(F,m,n)	approximation of elliptic integral of 3rd kind II(n;F|m)
EN(n,z)	nth exponential integral En(z), real part of z > 0
EN_ASYMP(n,z,m)	m+1 terms of asymptotic approximation for En(z)
EULER(n)	nth Euler number
EULER_ODE(r,x,y,x0,y0,h,n)	vector of n+1 solution points of y'=r(x,y) using Euler's method
EULER_BETA(z,w)	Euler's beta function B(z,w)

EULER_PHI(n)	Euler's totient function f(n)
EULER_POLY(n,x)	nth Euler polynomial evaluated at x
EXACT(p,q,x,y,x0,y0)	implicit specific solution of p(x,y)+q(x,y)y'=0, if it is exact
EXACT_EIGENVECTOR(A,m)	eigenvector of matrix A corresponding to exact eigenvalue m
EXACT_GEN(p,q,x,y,c)	implicit general solution of p(x,y)+q(x,y)y'=0, if it is exact
EXACT2(p,q,x,y,v,c)	reduces order of p(x,y,v)y"+q(x,y,v)=0 with v=y', if it is exact

EXTENDED_GCD(a,b)	vector [g, [x, y]] of integers such that g = gcd(a, b) = x·a+y·b
EXTRACT_2_COLUMNS(A,j,k)	matrix composed of jth and kth columns of matrix A

F_DISTRIBUTION(F,v1,v2)	cumulative probability F-distribution P(F|v1,v2)
FAREY(n)	vector of Farey fractions of order n
FIBONACCI(n)	nth Fibonacci number
FIXED_POINT(g,x,x0,n)	n iterations of vector x=g(x), starting at x=x0
FORCE0(A,i,j,p)	force element i,j of A to 0 using pivot row p
FOURIER(y,t,t1,t2,n)	nth harmonic Fourier series of y(t) from t=t1 to t2
FRESNEL_COS(z)	approximates to Fresnel cosine integral C(z)
FRESNEL_COS_ASYMP(z)	5-term asymptotic approximation for cosine integral C(z)
FRESNEL_COS_J(z,m)	approximation of C(z) based on sum of m+1 spherical Bessel functions
FRESNEL_COS_SERIES(z,m)	m+1 terms of series approximation for cosine integral C(z)
FRESNEL_SIN(z)	approximates to Fresnel sine integral S(z)
FRESNEL_SIN_ASYMP(z)	5-term asymptotic approximation for sine integral S(z)
FRESNEL_SIN_J(z,m)	approximation of S(z) based on sum of m+1 spherical Bessel functions

FRESNEL_SIN_SERIES(z,m)	m+1 terms of series approximation for sine integral S(z)
FUN_LIN_CCF(r,p,q,k,x,y,x0,y0)	implicit solution of y'=r(p·x+q·y+k), if p,q,k constant
FUN_LIN_CCF_GEN(r,p,q,k,x,y,c)	general solutions of y'=r(p·x+q·y+k), if p,q,k constant

GAUSS(a,b,c,z)	Gauss hypergeometric function F(a,b;c;z)
GAUSS_SERIES(a,b,c,z,m)	m+1 terms of series for Gauss hypergeometric function
GEGENBAUER_C(n,a,x)	nth Gegenbauer ultraspherical polynomial Cn(a)(x)
GEGENBAUER_C_LIST(n,a,x)	vector of first n Gegenbauer ultraspherical polynomials
GEN_HOM(r,x,y,x0,y0)	implicit specific solution of y'=r(x,y), if r is generalized homogeneous
GEN_HOM_GEN(r,x,y,c)	implicit general solution of y'=r(x,y), if r is generalized homogeneous

GEN_LUCAS(n,p,q,L0,L1)	nth term of the generalized Lucas sequence L(n)
GENERALIZED_LAGUERRE(n,a,x)	nth generalized Laguerre polynomial Ln(a)(x)
GENERALIZED_LAGUERRE_LIST(n,a,x)	vector of first n generalized Laguerre a polynomials
GEOMETRIC1(k,p,q,x,x0,y0)	solution of 1st order linear-geometric recurrence equation
GEOMETRY_MATRIX(q,G)	geometry matrix for coordinate vector q having metric tensor G

GOODNESS_OF_FIT(u,x,A)	standard deviation of u(x) from data in matrix A
GRID_LINES(a,b,s,o)	plots as three sets of grid lines in a 3D-plot window
GRID_POINTS(a,b,s,o)	plots as three sets of grid points in a 3D-plot window

HERMITE_H(n,x)	nth Hermite polynomial Hn(x)
HERMITE_H_LIST(n,x)	vector of first n Hermite polynomials
HERMITE_HE(n,x)	nth associated Hermite polynomial HEn(x)
HERMITE_HE_LIST(n,x)	vector of first n associated Hermite polynomials
HOMOGENEOUS(r,x,y,x0,y0)	specific solution of y'=r(x,y), if r is homogeneous
HOMOGENEOUS_GEN(r,x,y,c)	general solution of y'=r(x,y), if r is homogeneous

HORIZONTALS(w,z,z00,zmn,m,n)	2D plots as w-plane map of z-plane grid from z00 to zmn
HURWITZ_ZETA(s,a,m)	m+1 terms of series approximation for Hurwitz generalized zeta function
HYPERGEOMETRIC_DENSITY(k,n,m,j)	hypergeometric probability density function
HYPERGEOMETRIC_DISTRIBUTION(k,n,m,j)	cumulative hypergeometric probability distribution function
HYPERGEOMETRIC_SERIES(plist,qlist,z,m)	m+1 terms of series for generalized hypergeometric function

IMP_CENTER_OF_ CURVATURE(u,x,y)	center of curvature of implicit function u(x,y)=0
IMP_CURVATURE(u,x,y)	curvature of implicit function u(x,y)=0
IMP_DIF(u,x,y,n)	nth derivative of implicit function u(x,y)=0
IMP_OSCULATING_CIRCLE(u,x,y,x0,y0,q)	circle osculating implicit function u(x,y)=0 at (x0,y0) in terms of q
IMP_PERPENDICULAR(u,x,y,x0,y0)	line perpendicular to implicit function u(x,y)=0 at (x0,y0)

IMP_TANGENT(u,x,y,x0,y0)	line tangent to implicit function u(x,y)=0 at (x0,y0)
INCOMPLETE_BETA(x,z,w)	incomplete beta function Bx(z,w)
INCOMPLETE_GAMMA(z,w)	incomplete gamma function P(z,w), real part z > 0
INCOMPLETE_GAMMA_SERIES(z,w,m)	m+1 terms of series approximation for P(z,w)
INT_DATA(A)	antiderivative of numerical data matrix A
INT_PARTS(u,v,x)	antiderivative of u(x)·v(x) using integration by parts

INT_SUBST(y,x,u)	antiderivative of y(x) by substituting x for u(x)
INTEGRATING_FACTOR(p,q,x,y,x0,y0)	specific solution of p(x,y)+q(x,y)y'=0, if integrating factor exists
INTEGRATING_FACTOR_GEN(p,q,x,y,c)	general solution of p(x,y)+q(x,y)y'=0, if integrating factor exists
INVERSE(u,x)	inverse of u(x) with respect to x
ISOMETRIC(v)	2D isometric projection of 3D coordinate vector v
ISOMETRICS(v,s,s0,sm,m,t,t0,tn,n)	vector that 2D plots as isometric projection of 3D coordinate vector v

JACOBI(a,b)	Jacobi symbol (a/b)
JACOBI_AM(u,m,n)	Jacobi elliptic amplitude function
JACOBI_P(n,a,b,x)	nth Jacobi polynomial Pn(a,b)(x)
JACOBI_P_LIST(n,a,b,x)	vector of 1st n Jacobi (a,b) polynomials
JACOBIAN(u,v)	Jacobian matrix of the coordinate transformation x=u(v1,v2, …, vm)

KI(m,n)	complete elliptic integral of the 1st kind
KRONECKER(i,j)	Kronecker delta function
KUMMER(a,b,z)	Kummer's confluent hypergeometric function M(a,b,z)
KUMMER_SERIES(a,b,z,m)	m+1 terms of series approximation for M(a,b,z)
LAGUERRE_L(n,x)	nth Laguerre polynomial Ln(x)
LAGUERRE_L_LIST(n,x)	vector of first n Laguerre polynomials
LAPLACE(y,t,s)	Laplace transform of y(t) for transform domain variable
LEFT_RIEMANN(u,x,a,b,n)	left Riemann sum of n rectangles of integral of u(x) from x=a to b
LEGENDRE_P(n,x)	nth Legendre polynomial Pn(x)
LEGENDRE_P_LIST(n,x)	vector of first n Legendre polynomials

LERCH_PHI(z,s,a,m)	m terms of series approximation for Lerch transcendent function F(z,s,a)
LI(x,m)	m terms of series approximation for logarithmic integral li(x), x>1
LIM2(u,x,y,x0,y0)	limit of u as [x,y] -> [x0,y0] along slope of @1
LIN_FRAC(r,a,b,c,p,q,k,x,y,x0,y0)	specific solution of linear fractional equation y'=r((ax+by+c)/(px+qy+k))
LIN_FRAC_ GEN(r,a,b,c,p,q,k,x,y,c)	general solution of linear fractional equation y'=r((ax+by+c)/(px+qy+k))

LIN1_DIFFERENCE(p,q,x, x0,y0)	specific solution of recurrence equation y(x+1)=p(x)y(x)+q(x), y(x0)=y0

LIN2_CCF(p,q,r,x,c1,c2)	general solution of difference equation y(x+2)+p·y(x+1)+q·y(x)=r(x)
LIN2_CCF_BV(p,q,r,x,x0,y0,x2,y2)	specific solution of difference equation y(x+2)+p·y(x+1)+q·y(x)=r(x)
LINEAR_CORRELATION_COEFFICIENT(A)	linear correlation coefficient of 2-column x-y matrix A
LINEAR1(p,q,x,y,x0,y0)	explicit solution of linear monic equation y'+p(x)y=q(x)

LINEAR1_GEN(p,q,x,y,c)	general solution of linear monic equation y'+p(x)y=q(x)
LIOUVILLE(p,q,x,y,c1,c2)	general solution of Liouville equation y"+p(x)y'+q(y)(y')^2=0
LUCAS(n)	nth Lucas number beginning at 1
LUCAS_LEHMER(p)	if p is an odd prime and 2^p-1 is prime, returns true; otherwise returns false

MATPROD(A,B,i,j)	element i,j of the dot product of A and B
MERSENNE(n)	nth Mersenne prime 2^p - 1
MERSENNE_DEGREE(n)	exponent p of nth Mersenne prime 2^p - 1
MERSENNE_LIST(n)	exponents p of first n Mersenne prime 2^p - 1
MINOR(A,i,j)	delete row i and column j from A
MOEBIUS_MU(n)	Moebius mu function of n
MONOMIAL_TEST(p,q,x,y)	integrating factor of p(x,y)+q(x,y)y'=0, if result of the form x^m·y^n

NEWTON(u,x,x0,n)	n iterations of Newton's method applied to equation u(x)=0 with initial guess of x=x0
NEWTONS(u,x,x0,n)	n iterations of Newton's method applied to a system of equations
NEXT_MERSENNE_DEGREE(n)	smallest prime p>n such that Mersenne number 2^p - 1 is prime
NORMAL_LINE(u,v,v0,t)	line normal to surface u=0 at v=v0, using parameter t
NTH_PRIME(n)	nth prime number

OCTAHEDRAL(n)	nth octahedral number
OSCULATING_CIRCLE(y,x,q)	circle osculating y(x), in terms of q
OUTER(v,w)	outer product of vectors v and w

PADE(y,x,x0,n,d)	approx y(x) near x=x0, n=numr deg, d=denr deg, n=d or d-1
PARA_ARC_LENGTH(v,t,t1,t2)	arc length of vector v(t) from t=t1 to t2
PARA_ARC_LENGTH(v,t,t1,t2,m)	integral of m(t) along v(t) from t=t1 to t2
PARA_CENTER_OF_CURVATURE(v,t)	center of curvature of v=[x(t),y(t)]
PARA_CURVATURE(v,t)	curvature of v=[x(t),y(t)]
PARA_DIF(v,t,n)	nth derivative of v=[x(t),y(t)]

PARA_OSCULATING_CIRCLE(v,t,t0,F)	circle osculating v=[x(t),y(t)] at t=t0 in terms of F
PARA_PERPENDICULAR(v,t,t0,x)	line perpendicular to v=[x(t),y(t)] at t=t0 in terms of x
PARA_TANGENT(v,t,t0,x)	line tangent to v=[x(t),y(t)] at t=t0 in terms of x
PARTITION(v,n,d)	partition of vector v into vectors of length n with an offset delta of d
PARTS(n)	number of decompositions of n into integer summands

PARTS_LIST(n)	n+1 element vector of PARTS(0) through PARTS(n)
PELL(n)	nth Pell number
PENTATOPE(n)	nth pentatope number
PERFECT(n)	nth perfect number (i.e. numbers that are equal to the sum of their divisors)
PERPENDICULAR(y,x,x0)	line perpendicular to y(x) at x=x0
PICARD(r,p,x,y,x0,y0)	improved series approximation of ODE, given the series p(x)
PIVOT(A,i,j)	force column j below row i to 0 by pivoting

PlotInt(u,x,a,b)	plots the definite integral of the function u(x) from x = a to b
POCHHAMMER(a,x)	Pochhammer symbol function (a)x
POISSON_DENSITY(k,t)	Poisson probability density
POISSON_DISTRIBUTION(k,t)	cumulative probability Poisson distribution function
POLAR(r,q)	2D coordinate vector of point at radius r and co-longitude q
POLAR_ARC_LENGTH(r,q,q1,q2)	arc length of polar r(q) from q1 to q2

POLAR_ARC_LENGTH(r,q,q1,q2,m)	integral of m(q) along arc r(q)
POLAR_AREA(r,r1,r2,q,q1,q2)	area of q=q1 to q2 and r=r1(q) to r2(q)
POLAR_AREA(r,r1,r2,q,q1,q2,m)	integral of m(q) over region
POLAR_CENTER_OF_CURVATURE(r,q)	center of curvature of r(q)

POLAR_CURVATURE(r,q)	curvature of r(q)
POLAR_DIF(r,q,n)	nth derivative of r(q)
POLAR_OSCULATING_CIRCLE(r,q,q0,F)	circle osculating r(q) at q=q0 in terms of F
POLAR_PERPENDICULAR(r,q,q0,x)	line perpendicular to r(q) at q=q0 in terms of x
POLAR_TANGENT(r,q,q0,x)	line tangent to r(q) at q=q0 in terms of x

POLY_COEFF(u,x,n)	coefficient of x^n term in polynomial u(x)
POLY_DEGREE(u,x)	degree of polynomial u(x)
POLYGON_FILL(u)	fills the 2D or 3D convex polygon u 
POLY_INTERPOLATE(A,x)	polynomial interpolation of data matrix A
POLY_INTERPOLATE_EXPRESSION(u,x,a)	polynomial in x that interpolates u given 1D vector of points a
POLYGAMMA(n,z,m)	m+1 terms of series approximation for the nth polygamma function Yn(z)

POLYGONAL(n,p)	nth p-sided polygonal number
POLYGONAL_PYRAMID(n,p,d)	nth p-sided d-dimensional polygonal pyramid number
POLYLOG(n,z,m)	m terms of series approximation for Jonquière's polylogarithm function Li(n)(z)
PRIMEPI(x,d,a)	number of primes p £ x, such that p is of the form p = k·d + a for some k ³ 0
PRIME_POWER?(n)	if n is a power of a prime number, returns true; otherwise returns false

PRIMITIVE_ROOT(n)	smallest primitive root mod n, if one exists; otherwise a ?
PROVE_SUM(t,k,a,n,s)	if SUM(t,k,a,n)=s, return [0,0]

RANDOM_MATRIX(m,n,s)	m by n matrix with random elements from -s to s
RANDOM_NORMAL(s,m)	random normal value with a standard deviation of s and a mean value of m
RANDOM_POLY(x,d,s)	poly of degree d in x with random coefficients from -s to s
RANDOM_SIGN	random 1 or -1
RANDOM_VECTOR(n,s)	n element vector with random elements from -s to s
RATIO_TEST(t,n)	if < 1, SUM(t,n,a,inf) converges; if > 1, sum diverges

RAYS(w,z,z00,zmn,m,n)	2D plots w(z) as rays over the z-plane grid from z00 to zmn
RECURRENCE(u,v,v0,m)	m recurrences of u(v) starting with vector v=v0
RECURRENCE1(r,x,y,x0,y0,n)	n steps of y(x+1)=r(x,y(x)), y(x0)=y0
RHOMBIC_DODECAHEDRAL(n)	nth rhombic dodecahedral number
RK(r,v,v0,h,n)	fourth order Runge-Kutta solution of system of 1st order differential equations
ROTATE_X(j)	matrix A so that A . [x,y,z] rotates angle j about x axis

ROTATE_Y(j)	matrix A so that A . [x,y,z] rotates angle j about y axis
ROTATE_Z(j)	matrix A so that A . [x,y,z] rotates angle j about z axis

SCALE_ELEMENT(v,i,s)	multiply element i of v by s
SEPARABLE(p,q,x,y,x0,y0)	specific solution of separable equation y'=p(x)q(y)
SEPARABLE_GEN(p,q,x,y,c)	general solution of separable equation y'=p(x)q(y)
SI(z)	sine integral Si(z)
SMOOTH_COLUMN(A,j)	matrix A with column j smoothed
SMOOTH_VECTOR(v)	smoothed copy of vector v
SOLVE_MOD(u,x,m)	vector of solutions of the linear congruence equation u(x) mod m

SPHERE(r,q,F)	3D coordinate matrix of a sphere of radius r
SPHERICAL_BESSEL_Y(n,z)	closed-form spherical Bessel function of 2nd kind,yn(z)
SPHERICAL_BESSEL_J(n,z)	spherical Bessel function of 1st kind jn(z) for integer n
SPHERICAL_BESSEL_J_LIST(n,z)	vector of spherical Bessel functions of 1st kind j0(z) through jn(z)
SPHERICAL_BESSEL_Y(n,z)	spherical Bessel function of 2nd kind yn(z) for integer n

SPHERICAL_VOLUME(r,r1,r2,q,q1,q2,F,F1,F2)	volume of region specified in spherical coordinates
SPHERICAL_VOLUME(r, r1,r2,q,q1,q2,F,F1,F2,m)	integral of m(r,q,F) over the region
SQUARE_ROOT(a,p)	square root of integer a mod prime p, if one exists; otherwise ?
SQUARE_WAVE(x)	square wave of x

SQUAREFREE(n)	if n is not divisible by the square of a prime, returns true; otherwise returns false
STAR(n)	nth star (i.e. 12-sided centered) number
STIRLING(n,k)	Stirling number
STIRLING1(n,k)	Stirling cycle number of the 1st kind
STIRLING2(n,k)	Stirling subset number of the 2nd kind
STIRLING_CYCLE(n,k)	Stirling cycle number of the 1st kind
STIRLING_SUBSET(n,k)	Stirling subset number of the 2nd kind

STUDENT(t,v)	student's cumulative probability distribution A(t|v)
SUBTRACT_ELEMENTS(v,i,j,s)	subtract element j·s from element i of v
SURFACE_AREA(z,x,x1,x2,y,y1,y2)	area of surface z(x,y)
SURFACE_AREA(z,x,x1,x2,y,y1,y2,m)	integral of m(x,y) over surface z(x,y)
SWAP_ELEMENTS(v,i,j)	interchange elements i and j of vector v

TANGENT(y,x,x0)	line tangent to y(x) at x=x0
TANGENT_PLANE(u,v,v0)	plane tangent to u(x,y,z)=0 at [x,y,z]=v=v0
TAYLOR_INVERSE(u,x,y,x0,n)	nth order series expansion of inverse of y=u(x)
TAYLOR_ODE1(r,x,y,x0,y0,n)	nth order Taylor series solution of y'=r(x,y) with y=y0 at x=x0
TAYLOR_ODE2(r,x,y,v,x0,y0,v0,n)	nth order Taylor series solution of y''=r(x,y,y')
TAYLOR_ODES(r,x,y,x0,y0,n)	vector of nth order Taylor series solutions of system of  differential equations
TAYLOR_SOLVE(u,x,y,x0,y0,n)	nth order series solution y(x) of u(x,y)=0
TETRAHEDRAL(n)	nth tetrahedral number
TORUS(r,q,F)	3D coordinate matrix of torus of radius r
TRIANGULAR(n)	nth triangular number

U_LUCAS(n,p,q)	nth term of the Lucas sequence L(n) where L(0)=0, L(1)=1, and L(n+2)=p·L(n+1)-q·L(n)
U_MOD(n,p,q,m)	U_LUCAS(n, p, q) mod m, but is more efficient

V_LUCAS(n,p,q)	nth term of the Lucas sequence L(n) where L(0)=2, L(1)=p, and L(n+2)=p·L(n+1)-q·L(n)
V_MOD(n,p,q,m)	V_LUCAS(n,p,q) mod m, but is more efficient
VOLUME(x,x1,x2,y,y1,y2,z,z1,z2)	volume y=y1(x) to y2(x), z=z1(x,y) to z2(x,y)
VOLUME(x,x1,x2,y,y1,y2,z,z1,z2,m)	integral of m(x,y,z) over region
VOLUME_CENTROID(x,x1,x2,y,y1,y2,z,z1,z2)	volumetric centroid of region

VOLUME_CENTROID(x,x1,x2,y,y1,y2,z,z1,z2,m)	centroid of density m(x,y,z)
VOLUME_INERTIA(x,x1,x2,y,y1,y2,z,z1,z2)	volumetric inertia tensor
VOLUME_INERTIA(x,x1,x2,y,y1,y2,z,z1,z2,m)	inertia tensor of m(x,y,z)
VOLUME_OF_REVOLUTION(y,x,x1,x2)	volume of y(x) revolved about x-axis

VOLUMEY_OF_REVOLUTION(y,x,x1,x2)	volume of y(x) revolved about y-axis

WEBER_D(n,x)	Weber's nth parabolic cylinder function Dn(x)





Derive Reserved System Names

The following are the reserved system names in Derive in alphabetical order.  These names, along with the names of the built-in Derive Constants and Derive Functions, can not be used for user variable or function names:


Angle			Hexadecimal			raDical
Approximate		Implicit			Rational
ArrowKeyMode	InputBase			Real
Asterisk		InputMode			Schmidt
Auto			Insensitive			Scientific
Binary		Integer			ScientificThreshold
Branch		LineEdit			Sensitive
CaseMode		Logarithm			Set
Character		Logical			SimplifyRelations
Collect		Mixed				Sines
Complex		Nonscalar			Squarefree
Compressed		Normal			Subexpression
Cosines		Notation			TimesOperator
Decimal		NotationDigits		Trigonometry
Degree		Number			Trigpower
DisplayFormat	Octal				Trivial
DisplaySteps	OutputBase			Turing
Dot			Precision			VariableOrder
Exact			PrecisionDigits		Vector
exit			Principal			Word
Expand		Radian	
Exponential		Radical






Entering Mathematical Expressions

Mathematical expressions are entered using mathematical functions, operators, and constants (see Built-in Functions and Constants).  Of particular importance are the four basic Numerical Operators +, -, *, and /.  Parentheses are used to control the order operators are applied.  For example, the parentheses in the expression

-2*(8+7)/3

are necessary to force the addition of 8 and 7 before being multiplied by -2 and then divided by 3.

If you try to enter an expression on the expression entry line and there is a syntax error, a warning message is displayed indicating the type of syntax error.  Also, the cursor is positioned where the error was detected to help locate and correct the error.  Note that the error may actually have occurred anywhere to the left of the cursor on the line.

To easily determine if the parentheses on the expression entry line match, put the cursor on either side of a parenthesis or bracket and use the shortcut key combination Ctrl+Alt+M to toggle back and forth between matching parentheses or brackets.

While entering an expression, you can press the F3 key or right click on the mouse to insert the currently highlighted expression or subexpression on the expression entry line.  Press F4 to insert the currently highlighted expression enclosed in parentheses on the expression entry line.

Note that in the various dialog boxes for entering expressions, the highlighted expression in the active algebra window can be changed at any time.  First click in the algebra window to highlight the desired expression or subexpression (see Selecting Objects and Subexpressions).  Then click on the expression entry line and move the blinking cursor to the desired location before pressing the F3 or F4 key.




Entering Greek and Math Characters

While entering mathematical expressions on the expression entry line, you can use the Greek symbol toolbar to enter Greek letters and the math symbol toolbar to enter mathematical symbols.  Click on the desired Greek letter or math symbol to insert it on the expression entry line at the current cursor position.  Use the Window > Customize > Toolbars command to turn on and off the Greek and math symbol toolbars.

Alternatively, you can enter Greek letters and math symbols by typing in their equivalent names on the keyboard.  The equivalent keyboard names for all the characters on the Greek and math symbol toolbars is displayed as a tool tip when the mouse cursor is moved over the character.  See Derive Constants and Derive Operators for the equivalent keyboard names of the math symbols.

The equivalent keyboard names for the upper case Greek letters is their Latin name with the first letter in upper case (for example, Gamma for Ã and Delta for Ä).  The equivalent keyboard names for the lower case Greek letters is their Latin name spelled out in all lower case letters (for example, gamma for ã and delta for ä).  The one exception to this naming convention is pi which denotes the area of the unit circle (i.e. 3.1415...).  To use the lower case Greek letter pi as a variable or function name, it must be entered by selecting it off the Greek symbol toolbar.

Finally, several of the most common mathematical constants and operators can be entered using the following hotkeys by pressing the indicated letter while holding down the Ctrl key:


Control key	Math symbol	Description
Ctrl+P	p	area of the unit circle (3.14159...)
Ctrl+E	e	base of the natural logarithms (2.71828...)
Ctrl+I	i	imaginary unit (square root of -1)
Ctrl+0	¥	plus infinity
Ctrl+O	°	degree postfix operator
Ctrl+U	È	set union operator
Ctrl+N	Ç	set intersection operator
Ctrl+T	`	matrix transpose/set complement operator
Ctrl+B	¯	vector/matrix subscript operator
Ctrl+Q	Ö	square root operator
Note that the Ctrl+X, Ctrl+C, Ctrl+V, and Ctrl+H hotkeys are reserved by Windows for the cut, copy, paste, and backspace operations respectively.





Selecting Objects and Subexpressions

Note that the highlight (selection) is automatically moved to each new mathematical expression, plot or text object added to the worksheet in the algebra window, except for those expressions resulting from the various Declare commands.

Use one of the following methods to select a single object:

·	Click once on the object using the left mouse button.

·	Press  (press the up arrow key) to select the object above the currently selected object.

·	Press ¯ (press the down arrow key) to select the object below the currently selected object.

·	Press Ctrl+Home (press the home key while holding down the control key) to select the first object in the worksheet.

·	Press Ctrl+End (press the end key while holding down the control key) to select the last object in the worksheet.

·	Press PgUp (press the page-up key) to scroll the display up and then select the object at the top of the algebra window.

·	Press PgDn (press the page-down key) to scroll the display down and then select the object at the bottom of the algebra window.

·	Press Ctrl+PgUp (press the page-up key while holding down the control key) to select the object at the top of the algebra window.

·	Press Ctrl+PgDn (press the page-down key while holding down the control key) to select the object at the bottom of the algebra window.
Use one of the following methods to select multiple contiguous objects:

·	Click the left mouse button once outside the selected object and drag the mouse up or down to highlight previous or subsequent objects.

·	With the currently selected object as an anchor, press and hold the Shift key and click on the last object in the range of objects to be selected.

·	Press Ctrl+Shift+ to include the object above the currently selected objects in the selected objects.

·	Press Ctrl+Shift+¯ to include the object below the currently selected objects in the selected objects.

·	Press Ctrl+Shift+Home to include all the objects above the currently selected objects in the selected objects.

·	Press Ctrl+Shift+End to include all the objects below the currently selected objects in the selected objects.

Use the following method to select multiple non-contiguous objects:

·	Press and hold the Ctrl key and then click once with the left mouse button on each object to add to the selection.

To highlight a subexpression of an expression, highlight the expression and then use one of the following methods:

·	Repeatedly click the left mouse button on a subexpression until only the desired subexpression is highlighted.

·	Press Shift+®, Shift+¬, Shift+ or Shift+¯ (press one of the arrow keys while holding down the shift key) to highlight the desired subexpression.

·	Double click the left mouse button on a subexpression to highlight the smallest subexpression at the mouse point.




Ordering Variables in Expressions

Since addition and multiplication are commutative and associative, the terms of a sum and the factors of a product could be arranged in any order.  However, the Derive normal form orders terms and factors in a certain way to aid the collection of similar terms and factors.  For example, the similar terms of

5·y·x + 7 - 3·x·y

are much easier to find and collect if the terms are first rearranged as

5·x·y - 3·x·y + 7

The Options > Mode Settings > Output command lets you control the ordering used to sort variables.  This variable ordering has a strong influence on how the terms of a sum and the factors of a product are ordered.

Derive maintains a list of variables that specifies the ordering used to sort variables.  The factory default variable order list consists of the variables x, y, and z in that order.

A variable on the list is more main than variables after it on the list or variables not on the list.  A variable not on the list is less main than variables on the list or variables before it in alphabetical order.  For example, x is more main than y, which is more main than a.

When an expression has more than one variable, the most main variable is called the primary variable.  The next most main variable is called the secondary variable, and so on.  For example, x is the primary variable of

     2       
5·a·x  + x·y 

y is the secondary variable, and a is the tertiary variable.

The coefficient of a product consists of those factors that do not contain the primary variable of the product.  For example, if x is the primary variable of

     2  5 
3·a·x ·y  

then 3·a·y^5 is the coefficient, and 3 is the numeric coefficient.

The ordering of the factors in a product is based solely on the bases of the factors; the exponents of the factors have no influence on the ordering.  Bases of a product that consist of a variable on the order list are sorted in that order.  For example,

z^2·x^3·y^5

displays as

 2  3  5 
z ·x ·y  

and simplifies to

 3  5  2 
x ·y ·z  

Bases of a product that consist of a variable not on the order list are sorted in alphabetical order before bases that consist of a variable on the order list and after the numeric coefficient of the product.  For example,

z^3·b^2·a·2·x^5·c

displays as

 3  2      5   
z ·b ·a·2·x ·c 

and simplifies to

     2    5  3 
2·a·b ·c·x ·z  

When ordering the terms of a sum, terms that contain the primary variable come before terms free of the variable.  Moreover, terms that contain the primary variable come before terms that contain that variable to a lower degree.  For example,

5·y^3+2·x^2-3·a·x

displays as

   3      2         
5·y  + 2·x  - 3·a·x 

and simplifies to

   2              3 
2·x  - 3·a·x + 5·y  

The coefficients of terms are used to break ties in the ordering of sums.  The terms of the sum that do not contain the primary variable of the sum are ordered using their own primary variable.

Derive sometimes rearranges the terms of a sum to produce more attractive output by eliminating a leading minus sign or displaying the real part of a sum before the imaginary part.  For example,

-x + y

simplifies to y-x.

Use the Options > Mode Settings > Output command to change and/or rearrange the variables on the variable order list.  This command displays the current list and invites you to make changes.  Note that existing expressions must be resimplified to see the effect of changing the variable order list.

When a new variable ordering is entered, this command generates an expression of the form

VariableOrder := [x1, x2, ..., xn]

where x1, x2, ..., xn are variables.  The variable ordering can also be changed by entering on the expression entry line an expression of the above form using upper and lower case for VariableOrder exactly as shown.  [x, y, z] is the factory default variable order setting.

If changing the variable order list does not yield exactly the desired form for a simplified expression, you can rearrange the expression using the Edit > Expression command.

Subexpressions are less likely to be expanded if their variables are least main.  Similarly, ratios are least likely to be combined if variables in sums in their denominators are least main.  Thus the ordering of variables can dramatically affect the conciseness of a simplified result and the time required to obtain it.  For example, if x is more main than y (as it is by default),

(x + 1)^9 + y

simplifies to

 9    8     7     6      5      4     3     2             
x + 9x + 36x + 84x + 126x + 126x + 84x + 36x + 9x + y + 1 

because the subexpression (x+1)^9 is expanded.  However, if you change the variable order list to y,x,z using the assignment

VariableOrder := [y, x, z]

then

(x + 1)^9 + y

simplifies to

           9 
y + (x + 1)  

because the subexpression (x+1)^9 is not expanded, thus giving a compact result that requires less time to compute.  Before continuing, we recommend restoring the default Derive variable ordering by issuing the command

VariableOrder := [x, y, z]

Expression growth from an unfortunate ordering of variables can exhaust memory before a result is derived.  If this occurs while simplifying a multivariate expression, change the ordering of the variables and try resimplifying the expression.  Alternatively, use the Simplify > Variable Substitution command to interchange the names of the variables in the expression before resimplifying.




Controlling Notation

Precision is the accuracy used to compute numbers (see the Precision field of the Options > Mode Settings > Simplification command).  A related but separate issue is the notation used to display numbers.

Numbers can be displayed using rational notation:  Integers are displayed as integers and fractions are displayed as ratios of integers.  Rational notation has the advantage that all stored numbers can be displayed exactly.  However, numbers that require many digits to display in rational notation are difficult to comprehend.

Thus, it is also possible to display fractions using decimal point notation.  It is also possible to display large magnitude and small magnitude numbers using scientific notation.  Finally, it is possible to display numbers in mixed notation using whichever style is most concise:  rational notation if a number is simple, decimal point notation if a number's magnitude is not extreme.  Otherwise use scientific notation.

You can also control the maximum number of fractional digits displayed in decimal point notation or the maximum number of significant digits displayed in scientific notation.  This number can be more, less, or the same as the number of digits of precision set in the Precision field of the Options > Mode Settings > Simplification command.  For decimal fraction, scientific, or mixed notation, it is usually advisable to display no more digits than are accurate and necessary for your purposes.  This policy avoids misleading results and increases comprehension.

Use the Notation and Digits fields of the Options > Mode Settings > Output command to see and/or change the notation style and the number of digits used when displaying numbers on the screen and when saving numbers in mth files.  Regardless of the number in the Digits field, rational notation uses as many digits as necessary to display results.  Thus, set the Digits field to the digits you want displayed for decimal fraction, scientific, or mixed notation.

When a new notation style is selected, this command generates an expression of the form

Notation := style

where style is Decimal, Mixed, Rational, or Scientific.  When a new number of digits to display is entered, the command generates an expression of the form

NotationDigits := digits

where digits is a positive integer.  The notation style and digits to display can also be changed by entering on the expression entry line expressions of the above form using upper and lower case exactly as shown.

If you use the Precision field of the Options > Mode Settings > Simplification command to change the precision to exact mode, the notation style is automatically changed to rational.  If you change the precision to approximate mode, the notation style is changed to scientific.  If you change the precision to mixed mode, the notation style is changed to mixed.

If you use the Precision field of the Options > Mode Settings > Simplification command to change the number of digits of precision, the number of digits displayed is changed to the requested precision.

Normally these automatic changes made to the notation by the precision commands make it unnecessary for you to have to change the notation yourself.  However, if you want some other notation, the notation command must be issued after the precision command.

For example, if you use the Precision field of the Options > Mode Settings > Simplification command to set precision to approximate mode using 6 significant digits, then p simplifies to 3.14159, a decimal approximation for p.  Then if you use the Notation field of the Options > Mode Settings > Output command to set the notation style to rational, then p simplifies to 355/113, a rational approximation for p.






Controlling Radix Base

Use the Radix field of the Options > Mode Settings > Input command to view and/or change the current input base.  Use the Radix field of the Options > Mode Settings > Output command to view and/or change the current output base.  

Sometimes it is convenient to convert numbers between radix bases and/or to work with numbers in bases other than base ten.  The above commands make it possible to independently control the base used for entering numbers and the base used for displaying numbers.

The most commonly used radix bases are binary (base two), octal (base eight), decimal (base ten), and hexadecimal (base sixteen).  You can specify a radix base for the above commands by selecting Binary, Octal, Decimal, or Hexadecimal from a menu, or by typing in an integer between 2 through 36, inclusive.  In the latter case, enter the integer using decimal (base ten) notation.

When you specify a new input radix base, the Options > Mode Settings > Input command generates an expression of the form

InputBase := base

where base is Binary, Octal, Decimal, Hexadecimal, or an integer between 2 and 36, inclusive.  When you specify a new output radix base, the Options > Mode Settings > Output command generates an expression of the form

OutputBase := base

where base is Binary, Octal, Decimal, Hexadecimal, or an integer between 2 and 36, inclusive.  The input and output radix bases can also be changed by entering on the expression entry line expressions of the above form using upper and lower case exactly as shown.

For radix bases greater than ten, the letter A is used to represent the digit ten, the letter B is used to represent the digit eleven, and so on through the letter Z for the digit thirty-five.  To avoid ambiguity with variables, such numbers that start with a letter are displayed and must be entered using a leading zero (0) digit.  For example, in base sixteen the decimal number fourteen is displayed and must be entered as 0E.

If you enter a number and it displays differently than what you typed, you may have inadvertently changed the input and/or output radix.  You can use one of the above commands to determine the current radix.




Controlling Expression Format

Use the Expression display field of the Options > Mode Settings > Output command to control how expressions are displayed on the screen or sent to the printer.

Click on the Normal or Compressed radial button to select the display format for expressions.  In normal display format, spaces are used around some operators, like + and -, to enhance the readability of expressions.  In compressed display format, nonessential spaces around operators are eliminated.  Compressed format may make it possible to display a large expression without having to wrap the expression on multiple lines or to scroll it horizontally.  Normal is the factory default display format setting.

The proper symbol to use for the times operator, used to indicate multiplication, is a subject of heated debate and a matter of personal taste.  Therefore, Derive gives you a choice.  Use the Multiplication operator field of the Options > Mode Settings > Output command to select the Asterisk, Dot, or Implicit to indicate multiplication.  If Implicit is selected, a space is inserted between operands to indicate multiplication.  Dot is the factory default times operator setting.

When a new display format is selected, this command generates an expression of the form

DisplayFormat := format

where format is Normal or Compressed.  When a new times operator is selected, this command generates an expression of the form

TimesOperator := operator

where operator is Asterisk, Dot, or Implicit.  The display format and times operator can also be changed by entering on the expression entry line expressions of the above form using upper and lower case exactly as shown.

Note that selecting both Compressed display format and the Implicit times operator results in poorly spaced expressions.  For example, examine

a·b+c·d

using each of the six possible settings provided by the Expression display and Multiplication operator fields of the Options > Mode Settings > Output command.




Expanding Polynomials

Use the Simplify > Expand command or the Expansion Functions to expand a polynomial with respect to some or all of its variables.

The general objective when expanding a polynomial with respect to designated variables is to maximize the number of terms that are algebraically independent with respect to those variables.  Terms having the same degrees for all expansion variables are collected.  Non-expansion variables that occur in these collected terms are not expanded unnecessarily.  

Comprehensibility tends to decline with the number of expansion variables.  Most problems only require expanding with respect to a single variable.




Expanding Rational Functions

Use the Simplify > Expand command or the Expansion Functions to expand a rational function into partial fraction form with respect to some or all of its variables.

When a rational function is expanded, the following sequence of transformations occurs:

·	If the rational function is improper with respect to the primary expansion variable, it is transformed using polynomial division into an expanded polynomial quotient plus a proper rational function.

·	The denominator of the proper rational function is factored with respect to the expansion variables.  The amount of factoring is that specified by the Denominator Factoring Type field of the Simplify > Expand command or by the amount argument of the EXPAND or TERMS function.

·	The proper rational function is expanded into a sum of independent super-proper rational function terms.  The denominator of each of these terms is one of the factors of the proper rational function's denominator raised to a power not exceeding its power in the denominator.

·	If the numerator of a super-proper term is a sum that contains expansion variables, the denominator of that term is distributed over those terms of the numerator that contain expansion variables.

If the sum of the degrees of the expansion variables in the denominator of a rational function exceeds two, the rational or radical factoring of the denominator can make partial fraction expansion quite slow.  Therefore, expand such rational functions with respect to as few variables as possible.

An alternative to partial fraction expansion is to separately highlight and expand the numerator and denominator of a rational function.  For rational functions with a denominator having expansion variables raised to high degrees, this is usually much quicker than partial fraction expansion.  However, the resulting expression does not clearly indicate the zeros, poles, or residues of the rational function.




Factoring Numbers

Use the Simplify > Factor command or the Factoring Functions to factor a number into prime decomposition form.

The prime decomposition (factorization) of a rational number is a product of prime numbers raised to integer (possibly negative) powers.  For example, the prime decomposition of

1234567890/49

is

    2              
 2·3 ·5·3607·3803  
----------------- 
         2         
        7          

The methods Derive uses to factor numbers include trial division, perfect power testing, Pollard/Brent's r (rho), Pollard's p-1, William's p+1, and Lenstra's elliptic curve method.

If Display Steps mode is on when Derive is trying to factor an integer, the part of the integer that remains un-factored and the factoring method being used is displayed on the status line.  You can turn on Display Steps mode using the check box on the Simplification tab of the Options > Mode Settings Command.  For example, turn on Display Steps mode and try factoring the Mersenne number

2^146-1

Factoring a number may take a long time if it has two or more prime factors, each with more than ten decimal digits.  Click on the Calculation Progress dialog box's Abort button or press the Esc key to abort an Simplify > Factor command that is taking too long (for details, see the Simplify Basic command).




Factoring Polynomials

Use the Simplify > Factor command or the Factoring Functions to factor a polynomial with respect to some or all of its variables.

The general objective when factoring a polynomial with respect to designated variables is to maximize the number of independent factors in which the designated variables occur linearly and which have the simplest possible coefficients.  There is often a tradeoff between these two objectives.  For example, linear factors might be achievable only at the expense of complex coefficients.  The following summarizes the types of polynomial factoring:

·	If trivial content factoring a polynomial, it is placed over a common denominator, and the gcd of the numeric coefficients and the least powers of variables of terms are factored out.  For example,

6·x^2 + 10·x^3/y

trivial content factors to

    2              
 2·x ·(5·x + 3·y)  
----------------- 
         y         

·	If squarefree factoring a polynomial, in addition to trivial content factoring, powers of sums or products of different powers of sums are factored.  For example,

x^4 + 2·x^3 - 3·x^2 - 8·x - 4

squarefree factors to

       2   2      
(x + 1) ·(x  - 4) 

Note that x²-4 was not factored since x+2 and x-2 are the same power (i.e. the first power) of sums.

·	If rationally factoring a polynomial, in addition to squarefree factoring, products of sums are factored so long as no new fractional powers or complex numbers are introduced.  For example, the expression above rationally factors to

                       2 
(x + 2)·(x - 2)·(x + 1)  

·	If radically factoring a polynomial, in addition to rational factoring, the possibility of introducing fractional powers of numbers, such as Ö2, is allowed.  For example,

x^2 - 3

radically factors to

(x + Ö3)·(x - Ö3)

·	If complex factoring a polynomial, in addition to radical factoring, the possibility of introducing complex numbers is allowed.  For example,

x^2 + 3

radically factors to

(x + Ö3·i)·(x - Ö3·i)

Fractional powers of complex numbers may introduce trigonometric and inverse trigonometric functions to achieve normal rectangular form.  In approximate or mixed mode, such subexpressions simplify to approximate real or complex numbers for numeric arguments.  In exact mode, they are left in symbolic form, which may be quite large.

Use radical factoring if you want real factors that are factored as far as possible.  Use complex factoring if you want factors that are linear factors in a variable.  Do not use radical or complex factoring if you want a concise expression without new fractional powers and/or complex numbers.

Subexpressions that do not contain factorization variables are simplified without being unnecessarily transformed.  In other words, subexpressions involving only non-factoring variables are neither expanded nor factored unnecessarily.  Similar powers of factoring variables are collected and simplified.  New radicals introduced by radical or complex factoring may include non-factorization variables as well as numbers.

Factoring a polynomial may take a long time depending on the size of the expression, the type of factoring, and the number of factorization variables.  Click on the Calculation Progress dialog box's Abort button or press the Esc key to abort an Simplify > Factor command that is taking too long (for details, see the Simplify > Basic command).  

Factoring only subexpressions of an expression or factoring with respect to a different variable may drastically reduce the computing time and improve the comprehensibility of a result.




Factoring Matrices

Use the Simplify > Factor command or the Factoring Functions to factor a matrix into Turing LU form or Gram-Schmidt QR form.

The result of factoring a matrix into Turing form is the matrix product P·L·D·U·R, where P is a permutation matrix, L is a unit lower-triangular matrix, D is a diagonal matrix, U is a unit upper-triangular matrix, and R is the reduced row echelon form of the original matrix.  Thus Turing factoring is a generalization and combination of LU factoring and reduction to row echelon form (for details, see Row Echelon Form).

The P (permutation) matrix is based on partial pivoting for numerical entries in the matrix and on non-symbolic pivoting for symbolic entries.  For example, the P matrix resulting from Turing factoring the matrix

[x, 3, 1; 2, 5, 3; 3, 3, 2]

is

é 0  0  1 ù
ê         ú
ê 0  1  0 ú
ê         ú
ë 1  0  0 û

since the numerical entries 2 and 3 in the first column of the original matrix are preferred over the symbolic entry x, and the 3 is preferred over the 2 because of partial pivoting.

The D matrix resulting from Turing factoring the above matrix is

é 3  0      0     ù
ê                 ú
ê 0  3      0     ú
ê                 ú
ê          x + 6  ú
ê 0  0  - ------- ú
ë            9    û

Note that the determinant of this D matrix (i.e. the product of the diagonal entries) is zero if x equals -6.  This indicates that the factors of the original matrix may not be valid for the special case x equals -6.  In general when a matrix containing symbolic entries is factored into Turing form, the special cases can be determined by setting the determinant of the D matrix equal zero.  For these special cases, the factoring should be examined separately.

When Turing factoring is used to find the LU factors of a matrix and the results compared with textbooks, it should be noted that different writers use different definitions of LU factoring.  Specifically, Crout LU factors combine the L and D matrices into a single new matrix L, while Doolittle LU factors combine the D and U matrices into a single new matrix U.

The result of factoring a square, full-rank matrix into Gram-Schmidt form is the matrix product Q·R, where Q is an orthonormal matrix (meaning Q·Q` = Q`·Q = I), and R is a right, or upper, triangular matrix.  

The result of factoring a rectangular, full-rank matrix into Gram-Schmidt form is the matrix product Q·R corresponding to the reduced QR factors (meaning that Q has the same dimensions as A).  In this case, Q is no longer orthonormal, but it is still the case that Q`·Q = I.

The result of factoring a rank deficient matrix into Gram-Schmidt form is the matrix product Q·R·P, where P is a permutation matrix that collects zero columns at the end of the matrix, but full column pivoting is not used.

Note that QR factoring is unique up to choices of sign.  For example, the matrix

[5, 1; 12, 3]

QR factors to

é   5      12  ù é      41  ù
ê ----  - ---- ú ê 13  ---- ú
ê  13      13  ú ê      13  ú
ê              ú·ê          ú
ê  12      5   ú ê       3  ú
ê ----   ----  ú ê  0  ---- ú
ë  13     13   û ë      13  û

however

é     5     12   ù é         41  ù
ê - ----   ----  ú ê -13  - ---- ú
ê    13     13   ú ê         13  ú
ê                ú·ê             ú
ê    12       5  ú ê          3  ú
ê - ----  - ---- ú ê  0   - ---- ú
ë    13      13  û ë         13  û

is also a valid QR factoring of the matrix.





Step-by-Step Equation Solving

This topic illustrates how the Edit > Object and Simplify commands can be used to solve equations and relations manually by issuing a sequence of commands.  This procedure is useful for learning how to solve such problems.  Use the Solve > Expression command to automate the process of solving equations and relations.

If an equation is added to an equation, the result is an equation whose left side is the sum of the left sides of the original equations and whose right side is the sum of the rights sides of the original equations.  Similar remarks apply to subtracting, multiplying, and dividing an equation by an equation.

If an expression, other than an equation, is added to an equation, the expression is added to both sides of the equation.  Similar remarks apply to subtracting, multiplying, and dividing an equation by an expression.

The ability to combine equations with expressions makes it possible to solve equations in a step-by-step manner.  For example, to manually solve the linear equation

2·x - 3 = 5

for x, first enter the equation.  Then press the F4 key to copy the equation to the expression entry line enclosed in parentheses and add 3 to both sides of the equation by entering the expression

(2·x - 3 = 5) + 3

which simplifies to

2·x = 8

Then press the F4 key again and divide both sides of the equation by 2 by entering the expression

(2·x = 8)/2

which simplifies to the solution of the original equation

x = 4

Quadratic equations can also be solved manually by completing the square.  For example, to solve the quadratic equation x²+5·x+6=0 for x, start by subtracting 6 from both sides of the equation by entering the expression

(x^2 + 5·x + 6 = 0) - 6

which simplifies to

 2            
x  + 5·x = -6 

Then complete the square by adding 5/2 squared to both sides of the equation by pressing the F4 key and entering the expression

(x^2 + 5·x = -6) + (5/2)^2

which factors to

          2        
 (2·x + 5)      1  
------------ = --- 
      4         4  

Then press the F4 key and multiply both sides of the equation by 4 giving

         2     
(2·x + 5)  = 1 

Taking the square root of both sides of this equation giving the two linear equations

2·x + 5 = 1  
2·x + 5 = -1 

that can be solved as described previously.

Quadratic and higher order polynomial equations can be solved by collecting all the terms on one side of the equation and factoring.  For example, rationally factoring the equation

 2               
x  - 5·x + 6 = 0 

yields the equation

(x - 2)·(x - 3) = 0

Then set the factors equal to 0 by highlighting each factor and using the Edit > Object command.  This gives the two linear equations

x - 2 = 0
x - 3 = 0

that can be solved as described previously.

The result of applying a function to an equation is an equation whose left and right sides are the result of independently applying the function to the left and right sides of the original equation.  For example, to solve the equation

LN(x) = 5

where LN is the natural logarithm function (see Built-in Functions and Constants), use the Edit > Object command to apply the exponential or inverse logarithm function EXP to the equation.  This gives

EXP(LN(x) = 5)

which simplifies to the solution of the original equation

     5 
x = ê  

Be aware that applying one of the Inverse Trigonometric Functions to an equation discards all solutions not on the principal branch.  Operations such as clearing the denominator or squaring both sides of an equation can introduce spurious solutions.  For example, squaring both sides of the equation

SQRT(x) = -1

yields x=1, which is not a solution.  Solutions should always be verified by substituting them into the original relation.


Solving Equations and Inequalities Algebraically

You can use the Solve > Expression command and the SOLVE and SOLUTIONS functions to solve equations and inequalities exactly using algebraic methods.  The Solve > Expression command and the SOLVE function return solutions in the form of equations and/or inequalities.  The SOLUTIONS function returns solutions in the form of a vector of values that satisfy the equations or inequalities.

The first argument of SOLVE and SOLUTIONS is the equation or inequality to be solved.  If neither an equation nor inequality, it is assumed equal to 0.  The second argument is the solution variable.  If the third argument is the constant Real, only solutions not having an imaginary component are returned.  For example,

SOLVE(x^3 + x^2 + x + 1, x)

simplifies to

x = -î Ú x = î Ú x = -1

whereas,

SOLVE(x^3 + x^2 + x + 1, x, Real)

simplifies to

x = -1

Given an equation or inequality, the Solve > Expression command and the SOLVE function return the solutions as a Boolean expression logically equivalent to the input but in disjunctive normal form.  That is an expression of the form

relation1 OR relation2 OR ...

where relationi is an equation or inequality.  For example, the equation

SOLVE(x^2-1 = 0, x)

simplifies to

x = -1 Ú x = 1

and the inequality

SOLVE(ABS(ABS(2·x + 1) - 5) > 2, x)

simplifies to

x < -4 Ú -2 < x < 1 Ú x > 3

Given a 1-element vector whose element is an equation or inequality, the Solve > Expression command and the SOLVE function return a vector of solutions, each in the form of a relation.  For example,

SOLVE([x^2-1 = 0], x)

simplifies to

[x = -1, x = 1]

Given an equation or inequality or a 1-element vector whose element is an equation or inequality, SOLUTIONS returns a vector of values that satisfy the equation or inequality.  For example,

SOLUTIONS(x^2-1 = 0, x)

simplifies to

[1, -1]

Unless restricted to the real domain, the solve commands and functions attempt to find all the real and complex solutions of the equation or inequality.  The set of solutions returned is not restricted by the declared domains of the solution variables (see Author > Variable Domain command).  

The solve commands and functions can directly solve binomial, linear, quadratic, cubic, and quartic polynomial equations.  They can also solve higher degree polynomial equations that can be exactly factored into such equations.

To help solve equations involving trigonometric functions, try various settings of the trigonometry field of the Options > Mode Settings > Simplification command.

Often equations involving trigonometric functions have infinitely many solutions.  For example, the solution to the equation  sin(x)=0  is  x = 0 Ú x = p Ú x = -p Ú x = 2·p Ú x = -2·p Ú ... .  Since Derive has no way to represent an infinite number of disjuncts, the solve commands and functions return a representative sample of several solutions near the origin.  For example,

SOLVE(SIN(x) = 0, x)

simplifies to

x = -p Ú x = p Ú x = 0

If the given equation or inequality is too difficult to solve completely, one or more implicit relations are displayed as an equation or an inequality with an expression containing the variable in an inextricable way on the left and a zero on the right.  For example,

SOLVE(3^x = x^2, x)

simplifies to

 x    2     
3  - x  = 0 

Equations and inequalities can have any number of solutions, including none.  When there are no solutions, the truth-value false or the empty vector [ ] is returned, as appropriate.  For example,

SOLVE(x = x + 1, x)

simplifies to false.

An equation or inequality is degenerate if it is true for all values of the solution variable.  Given a degenerate equation or inequality, both the Solve > Expression command and the SOLVE function return the truth-value true.  For example,

SOLVE(|x - 2| >= 0, x)

simplifies to true.  Given a degenerate equation or inequality, the SOLUTIONS function returns a 1-element vector of the form [@n] where n is an integer.  You can think of "@" as an abbreviation for "arbitrary" or "anything".  n starts at 1 and increments by 1 each time a new variable is required.  For example,

SOLUTIONS(|x - 2| >= 0, x)

simplifies to [@1].




Solving Equations Numerically

You can use the Solve > Expression command and the NSOLVE and NSOLUTIONS functions to solve an equation dependent on one variable using approximate numerical methods.  NSOLVE and NSOLUTIONS cannot solve equations dependent on more than one variable, inequalities, or systems of equations.  Functions are defined in the EquationSolving.mth utility file to solve systems of equations dependent on more than one variable using numerical methods.

The NSOLVE and NSOLUTIONS functions always use approximate numerical methods to solve an equation.  If Derive is in approximate mode and the functions SOLVE and SOLUTIONS are unable to solve an equation using algebraic methods, they switch to numerical methods to solve the equation.

The solutions returned by NSOLVE and NSOLUTIONS are in the same form as those returned by SOLVE and SOLUTIONS, respectively (see Solving Equations and Inequalities Algebraically).  In particular, if the third argument is the constant Real, only solutions not involving imaginary numbers are returned.  For example,

NSOLVE(x^5 - 2·x^3 + 4·x^2 + 2·x - 3 = 0, x)

simplifies to

x = 1.013396467 - 1.152395734·î Ú
x = 1.013396467 + 1.152395734·î Ú
x = 0.7265501429 Ú
x = -1.753343077 Ú
x = -1

whereas

NSOLVE(x^5 - 2·x^3 + 4·x^2 + 2·x - 3 = 0, x, Real)

simplifies to

x = 0.7265501429 Ú x = -1.753343077 Ú x = -1

As the examples above show, given a polynomial equation with numeric coefficients, NSOLVE and NSOLUTIONS return all the real and complex solutions to the equation.  However, for any other type of equation, NSOLVE and NSOLUTIONS return only one solution to the equation.

If the third and fourth arguments of NSOLVE and NSOLUTIONS approximate to numbers, the search for a solution is restricted to that interval and only one solution is returned.  For example, to find an approximate solution to the equation x·sin(x) = 1 between x=2 and 4, simplify the expression

NSOLVE(x·SIN(x) = 1, x, 2, 4)

If you have no idea where a solution occurs, you can plot the difference in the two sides of the equation to find an interval where the plot crosses or touches the x-axis.  To find a solution other than ones already found, specify an interval that excludes the known solutions.

The numerical equation solving commands and functions will find an approximate solution if the difference in the two sides of the equations is continuous and has different signs at the ends of the interval.  Even if the equation is discontinuous in the interval or does not have different signs at the ends, these commands and functions usually find a solution if one exists in the interval.

The numerical equation solving commands and functions are normally able to return a solution accurate to the current digits of precision specified in the Precision field of the Options > Mode Settings > Simplification command.  However, catastrophic cancellation of approximate large magnitude terms can make the difference in the two sides equal 0 even though the approximate solution is not accurate to the current digits of precision.

Rationally factoring the difference in the two sides of an equation (see the Simplify Factor command) before using these commands and functions often results in more accurate solutions obtained more quickly.  For example,

NSOLVE((x - pi)^4 = 0, x, 3, 4)

simplifies to x = 3.141592653 which is a good approximation for p, whereas

NSOLVE(x^4 - 4·pi·x^3 + 6·pi^2·x^2 - 4·pi^3·x + pi^4 = 0, x, 3, 4)

simplifies to x = 3.140685047 which is a poor approximation.


Solving Systems of Equations

You can use both the Solve > Expression and Solve > System command commands to solve systems of polynomial equations.  You can also use the SOLVE and SOLUTIONS functions to solve such systems.  The first argument of SOLVE and SOLUTIONS is the system of equations to be solved.  The second argument is a vector of the solution variables.

All these methods use the Gröbner Basis to reduce the system of polynomial equations to a single univariate equation.  This univariate equation is then solved algebraically or numerically, and the result back-substituted into the other equations.

Given a conjunction of equations, the Solve > Expression command and the SOLVE function return the solutions as a Boolean expression logically equivalent to the input but in disjunctive normal form.  That is an expression of the form

conjunct 1 OR conjunct 2 OR ... 

where conjunct i is an expression of the form

relation i1 AND relation i2 AND ...

where relation ij is an equation or inequality.  For example,

SOLVE(x^2 + y^2 = 2·a^2 AND x - y = 0, [x, y])

simplifies to

(x = -a Ù y = -a) Ú (x = a Ù y = a)

Given a vector of equations, the Solve > Expression command and the SOLVE function return a vector of solutions.  The Solve System command always returns the solutions in this form.  For example, 

SOLVE([x^2 + y^2 = 2·a^2, x - y = 0], [x, y])

simplifies to

[x = a Ù y = a, x = -a Ù y = -a]

No matter how the equations are given, SOLUTIONS returns a vector of vectors (i.e. a matrix) of solution values.  For example,

SOLUTIONS(x^2 + y^2 = 2·a^2 AND x - y = 0, [x, y])

simplifies to

é  a   a ù
ê        ú
ë -a  -a û

A system of linear equations is singular if the equations are not independent of one another.  Singular systems of linear equations can be either consistent or inconsistent.

Given a consistent singular system of linear equations, both the Solve commands and the SOLVE function return a simplified equivalent system of equations.  For example,

SOLVE(2·x + 6·y = 2 AND 3·x = 3 - 9·y, [x, y])

simplifies to

x + 3·y = 1

Given a consistent singular system of linear equations, the SOLUTIONS function returns a vector of solutions containing one or more arbitrary values of the form @n where n is an integer.  The number of distinct arbitrary values is equal to the number of solution variables minus the number of independent equations.   For example,

SOLUTIONS(2·x + 6·y = 2 AND 3·x = 3 - 9·y, [x, y])

simplifies to

é      1 - @1  ù
ê @1  -------- ú
ë         3    û

Given an inconsistent singular system of linear equations, the Solve commands and the SOLVE function return the truth-value false or the empty vector [ ], depending on how the system is given.  For example,

SOLVE(x + 3·y = 1 AND 2·x + 6·y = 3, [x, y])

simplifies to false and

SOLVE([x + 3·y = 1, 2·x + 6·y = 3], [x, y])

simplifies to [ ].

The Solve commands and the SOLVE and SOLUTIONS functions cannot directly solve a system of equations if they are not polynomial in their solution variables.  Functions are defined in the EquationSolving.mth utility file for computing approximate real or complex solutions to systems of non-polynomial equations.






Vectors and Matrices

These sections describe how vectors and matrices are entered and manipulated using Derive's built-in functions and operators.  The file VECTOR.MTH defines functions that perform additional vector and matrix operations.

The only limitation on the number of elements in vectors and matrices is the amount of space available for storing their elements.  Thus, the maximum number of elements depends strongly on the mathematical complexity of the elements.  Many of the matrix operations described in these sections may dramatically increase the complexity of the resulting elements.

Generating Vectors and Matrices 
Vector Manipulation Functions 
String Processing Functions 
Vector Operations  
Matrix Operations 
Row Echelon Form 
Eigenvalues 
Vector and Matrix Algebra 
Differential Vector Calculus 
Integral Vector Calculus

 


Generating Vectors and Matrices

Use the Author > Vector command to enter a new vector.  Use the Author > Matrix command to enter a new matrix.  Use the Calculus > Vector command or the VECTOR function to generate vectors and matrices.  Use the Calculus > Table command or the TABLE function to generate tables of expression values.

An identity matrix is a square matrix whose elements are 1 on the main diagonal and 0 off the main diagonal.  Use the IDENTITY_MATRIX function to generate an identity matrix.  IDENTITY_MATRIX(n) simplifies to an n by n identity matrix.  For example,

IDENTITY_MATRIX(3)

simplifies to the 3 by 3 identity matrix

é 1  0  0 ù
ê         ú
ê 0  1  0 ú
ê         ú
ë 0  0  1 û




Vector Manipulation Functions

Use the functions and operators in this section to extract, concatenate, delete, insert, reverse, select, and sort elements of vectors.  They can also be used to perform these same operations on the characters of a string or the digits of an integer (see the String Processing Functions).

Many of these functions and operators have arguments or operands that specify the index of a vector element.  If an index is a positive integer n, it specifies the nth element from the left end of the vector.  If an index is a negative integer n, it refers to the -nth element from the right end of the vector.

The dimension of a vector is the number of elements of the vector.  Use DIM to compute the dimension of a vector and the number of elements of a set.  Since a matrix is just a vector of vectors, the dimension of a matrix is the number of rows of the matrix.  For example,

DIM([[a, b, c], [1, 2, 3]])

simplifies to 2 since the matrix has two rows, and

DIM([[a, b, c], [1, 2, 3]] SUB 1)

simplifies to 3 since the first row of the matrix has three columns.

Use the SUB infix operator to extract the elements of a vector or matrix.  If v is a vector, v SUB n returns the nth element of v.  As an alternative to typing SUB on the expression entry line, it can be entered by clicking on the ¯ on the math symbol toolbar.  In the algebra window worksheet, subscripts are displayed using standard subscript notation.  For example,

[a, b, c, d] SUB 2

displays as

[a, b, c, d]  
            2 

and simplifies to b.  Use SUB twice to extract the elements of a matrix.  For example,

[a, b, c; d, e, f; g, h, i] SUB 2 SUB 3

displays as

é a  b  c ù    
ê         ú    
ê d  e  f ú    
ê         ú    
ë g  h  i û    
           2,3 

and simplifies to f.  If the right operand of SUB is a vector of indices, a vector of the specified elements is returned.  For example,

[a, b, c, d] SUB [4, 2]

simplifies to [d, b], and

[a, b, c; d, e, f; g, h, i] SUB [3, 1]

simplifies to

é g  h  i ù
ê         ú
ë a  b  c û

The SUB operator can be used in conjunction with the := assignment operator (see the Author > Variable Value command) to change designated elements of vectors assigned to variables.  If the value of the variable A is a vector and a subscripted assignment of the form

A SUB n := u

is simplified, the nth element of A is replaced by u.  If a subscripted assignment of the form

A SUB [n1, n2, ..., nm] := [u1, u2, ..., um]

is simplified, the elements n1, n2, ..., nm of A are replaced by u1, u2, ..., um, respectively.  Note that unlike regular assignments, subscripted assignments must be simplified in order to take effect.

Since matrices are stored as vectors of vectors, subscripted assignments can also be used to change designated elements of matrices assigned to variables.  If the value of the variable A is a matrix and a subscripted assignment of the form

A SUB n SUB m := u

is simplified, the mth element on the nth row of A is replaced by u.

The SUB operator can similarly be used in conjunction with the update operators :+, :-, :*, and :/ (for details see Procedural Programming) to update the elements of vectors and matrices.

Use the SUB SUB operator to extract the columns of a matrix.  If A is a matrix, A SUB SUB n returns the nth column of A as a vector.  For example, A¯¯3 returns the 3rd column of A; whereas A¯3 returns the 3rd row of A.  This scheme naturally extends to higher dimensional matrices.  For example, three SUB operators extract a plane from a 3-dimensional matrix.

Finally, if the right operand of SUB SUB is a vector of indices, a matrix of the specified columns is returned.  This makes it easy to extract arbitrary sub-matrices of a matrix.  For example,

A ¯ [2, 3] ¯¯ [3, ..., 7]

returns the sub-matrix consisting of rows 2 and 3, and columns 3 through 7 of A.

The ELEMENT function is equivalent to the SUB operator but is entered using functional notation.  ELEMENT(v, n) simplifies to the nth element of the vector v.  For example,

ELEMENT([a, b, c, d], 2)

simplifies to b.  ELEMENT(m, j, k) simplifies to the element in row j and column k of the matrix m.  For example,

ELEMENT([a, b, c; d, e, f; g, h, i], 2, 3)

simplifies to f.  Since the SUB operator is displayed using standard subscript notation, we recommend using it rather than the ELEMENT function.

Use the APPEND function to concatenate two or more vectors.  APPEND(v1, v2, ..., vn) simplifies to a vector consisting of the elements of the vectors v1 through vn.  For example,

APPEND([a, b], [c, d], [e, f])

simplifies to [a, b, c, d, e, f].  If A is a matrix, APPEND(A) simplifies to a vector consisting of the elements of A.  For example,

APPEND([[a, b], [c, d], [e, f]])

also simplifies to [a, b, c, d, e, f].  To append the columns of two matrices, use the function APPEND_COLUMNS defined in the VECTOR.MTH utility file.

The functions FIRST, REST, and ADJOIN can be used to process the elements of vectors analogously to the way lists are processed in the LISP programming language (see Procedural Programming).  FIRST(v) simplifies to the first element of the vector v.  REST(v) simplifies to a vector of all but the first element of v.  If n is a positive integer, REST(v,n) simplifies to a vector of all but the first n elements of v.  If n is a negative integer, REST(v,n) simplifies to a vector of all but the last n elements of v.  ADJOIN(u,v) simplifies to a vector whose first element is u and whose remaining elements are the same as v.  For example,

ADJOIN(FIRST([a, b, c]), REST([d, e, f]))

simplifies to [a, e, f].

Use the DELETE function to delete one or more elements from a vector.  If v is a vector and n is an integer, DELETE(v, n) simplifies to a copy of v but with the nth element deleted.  For example,

DELETE([a, b, c, d], 2)

simplifies to [a, c, d].  Note that if v is a matrix, the nth row of v is deleted.  If w is a collection (i.e. a vector or set) of integers, DELETE(v, w) simplifies to a copy of v but with the elements specified in w deleted.  For example,

DELETE([a, b, c, d], [2, -1])

simplifies to [a, c].

Use the INSERT function to insert an element into a vector.  INSERT(u, v, n) simplifies to a copy of vector v but with expression u inserted before the nth element.  For example,

INSERT(d, [a, b, c], 2)

simplifies to [a, d, b, c].  n defaults to 1.  If n is one more than the dimension of the vector, the new element is added to the end of the vector.

Use the REPLACE function to replace an element in a vector.  REPLACE(u, v, n) simplifies to a copy of vector v but with expression u replacing the nth element.  For example,

REPLACE(d, [a, b, c], 2)

simplifies to [a, d, c].  n defaults to 1.

Use the REVERSE function to reverse the elements of a vector.  REVERSE(v) simplifies to a copy of vector v but with the elements reversed.  For example,

REVERSE([a, b, c])

simplifies to [c, b, a].

Use the POSITION function to find the position (i.e. index) of an element in a vector.  If e is an expression that occurs in the vector v, POSITION(e, v) simplifies to the position of the first occurrence of e.  If e does not occur in v, POSITION(e, v) simplifies to false.  For example,

POSITION(c, [a, b, c, d, c, e])

simplifies to 3, and

POSITION(f, [a, b, c, d, c, e])

simplifies to false.  If n is an integer and e is an expression that occurs at or after the nth element of vector v, POSITION(e, v, n) simplifies to the position of the first such occurrence of e.  For example,

POSITION(c, [a, b, c, d, c, e], 4)

simplifies to 5.

Use the SELECT function to find those elements of a vector that satisfy some test criteria.  SELECT(u, k, v) simplifies to a vector of those elements k of v for which u(k) is true.  For example,

SELECT(PRIME(k), k, [3, 5, 7, 9, 11])

simplifies to [3, 5, 7, 11].  SELECT can also be used to test the elements of a sequence.  SELECT(u, k, m, n, s) simplifies to a vector of those k for which u(k) is true with the variable k stepping from m through n in steps of size s.  s defaults to 1.  For example,

SELECT(PRIME(k), k, 1, 100)

simplifies to a vector of all the prime numbers less than 100.

Use the SORT function to sort the elements of a vector or set, and return the result as a vector.  Given a vector or set of numbers, SORT returns a vector of the numbers sorted in ascending numerical order of their real parts with ties broken on their imaginary parts.  Variable names are sorted lexicographically after numbers.  For example,

SORT([3, 2, y, pi, #e, SQRT(2), z, x, 1, 0, 2, 0, 0, -3])

simplifies to

[-3, 0, 0, 0, 1, Ö2, 2, 2, ê, 3, p, x, y, z]

Given a vector or set of vectors, the vectors are sorted by comparing their first elements with ties being broken by comparing their second elements, etc.  For example,

SORT({[2, 3], [3, 1], [2, 1], [1, 5]})

simplifies to

é 1  5 ù
ê      ú
ê 2  1 ú
ê      ú
ê 2  3 ú
ê      ú
ë 3  1 û

If, in addition to a vector or set, SORT is given a predicate and two variables, the ordering is based on the truth-value returned by the predicate.  For example,

SORT([-5, -2, 0, 3, 4], ABS(x)<ABS(y), x, y)

simplifies to

[0, -2, 3, 4, -5]




String Processing Functions

All the Vector Manipulation Functions treat the characters of strings and the digits of integers as if they were the elements of a vector.  Thus, you can use these same functions and operators to do a wide range of string processing operations, useful for cryptographic and other applications.  Note that strings are entered on the expression entry line enclosed in double quotes, but they are displayed in the algebra window worksheet without the double quotes.

In particular, the SUB subscript operator can be used to extract the characters of strings or the digits of integers.  For example,

"Derive" SUB 3

simplifies to string "r",

"Derive" SUB [1, 2, 6, 3]

simplifies to the string "Deer", and

123456789 SUB [1, 3, 5, -3, -1]

simplifies to the integer 13579.

Also, the DIM function can be used to determine the length of strings or the number of digits of integers.  For example,

DIM("Derive")

simplifies to 6, and

DIM(123456789)

simplifies to 9.

Also, the vector manipulation functions work on strings and integers as expected.  For example,

REVERSE(1234567890)

simplifies to the integer 987654321,

APPEND("a", "b", "c", 3)

simplifies to the string "abc3", and

DELETE("Derive", 2)

simplifies to the string "Drive".  Note that these can also accept negative indices to specify characters from the right end of a string.  For example,

DELETE("Derive", -5)

also simplifies to "Drive".

Similarly, the POSITION function can be used to search for a string in a string or in the digits of an integer.  For example, after taking a few seconds

POSITION("0000", FLOOR(10^15000*pi))

simplifies to the position of the first occurrence of four 0s in the decimal expansion of ð.

Use the STRING function to convert expressions to strings.  If u is a variable, STRING(u) simplifies to the string having the same name as u, but enclosed in double quotes.  If u is a number, STRING(u) simplifies to the string having the same digits as u, but enclosed in double quotes.  For example,

STRING(123456789)

simplifies to the string "123456789".  Note that the digits representing u are determined by the current output radix base set by the Options > Mode Settings > Output command.

If u is a function composition, STRING(u) simplifies to a vector consisting of the string variable corresponding to the expression's top-level function or operator, followed by the function's arguments or operator's operands.  Note that the arguments and operands are not converted to strings.  For example,

STRING(x+y-z)

simplifies to ["+", x, y, -z], and

STRING(COS(x^2))

simplifies to ["COS", x^2].  The STRING function distributes over the elements of vectors and sets.

Use the NAME_TO_CODES function to convert a string or integer to a vector of ASCII codes for the characters in the string or the digits in the integer.  For example,

NAME_TO_CODES("Exact")

simplifies to [69, 120, 97, 99, 116].

Use the CODES_TO_NAME function to convert a vector of ASCII codes to the corresponding string or integer.  For example,

CODES_TO_NAME([69, 120, 97, 99, 116])

simplifies to the string "Exact", and

CODES_TO_NAME([45, 52, 49])

simplifies to the integer -41.  To generate a 16 by 16 matrix showing the character corresponding to each ASCII code, simplify the expression

VECTOR(VECTOR(CODES_TO_NAME(j + 16·i), i, 0, 15), j, 0, 15)

Note that strings containing the ASCII codes 0, 10, 13, and 34 are not allowed.




Vector Operations

In Derive a matrix is just a vector of vectors.  Therefore, the vector operations described in this section also apply to matrices.

Use ABS to compute the magnitude (length) of a vector.  The absolute value of a vector is the square root of the sum of the squares of its elements.  For example,

ABS([a, b, c])

simplifies to the square-root of a²+b²+c².  When applied to a matrix, ABS computes the Frobenius norm of the matrix. 

Use the plus operator, +, to add the corresponding elements of vectors and matrices.  Vectors must have the same number of elements, and matrices must have the same number of rows and columns.  Enter the plus operator by clicking on the + on the math symbol toolbar or by typing + on the keyboard.  For example,

[a, b, c] + [d, e, f]

simplifies to

[a + d, b + e, c + f]

Use the minus operator, -, to subtract the corresponding elements of vectors or matrices.  Vectors must have the same number of elements, and matrices must have the same number of rows and columns.  Enter the minus operator by clicking on the - on the math symbol toolbar or by typing - on the keyboard.  For example,

[a, b, c] - [d, e, f]

simplifies to

[a - d, b - e, c - f]

Use the times operator, ·, or implicit multiplication to multiply each element of a vector or matrix by a scalar.  Enter the times operator by clicking on the · on the math symbol toolbar or by typing * on the keyboard.  For example,

3·[a, b, c]

simplifies to

[3·a, 3·b, 3·c]

Use the quotient operator, /, to divide each element of a vector or matrix by a scalar.  Enter the quotient operator by clicking on the / on the math symbol toolbar or by typing / on the keyboard.  For example,

[a, b, c]/3

simplifies to

é a    b    c ù
ê---, ---, ---ú
ë 3    3    3 û

Use the times operator or implicit multiplication to compute the sum of the products of corresponding elements of the two vectors.  (Use the dot and cross product operators discussed below to compute the dot and cross products of vectors.)  Note that the vectors must have the same number of elements, and that the result is a scalar.  For example,

[a, b, c]·[d, e, f]

simplifies to

a·d + b·e + c·f

Use the exponentiation operator, ^, to raise vectors to powers.  If n is a positive integer and v is a vector, v^n simplifies to the product v·v^(n-1).  If n is a negative integer, v^n  simplifies to (v/(v·v))^-n.  For example,

[a, b, c]^(-2)

simplifies to

       1       
-------------- 
  2    2    2  
 a  + b  + c   

The product of a matrix and a vector, in that order, is the vector whose elements are the product of the vector and the rows of the matrix.  Thus the number of elements of the vector must equal the number of columns of the matrix.  For example,

[a, b; c, d]·[2, 3]

displays as

é a  b ù        
ê      ú·[2, 3] 
ë c  d û        

and simplifies to

[2·a + 3·b, 2·c + 3·d]

The product of a vector and a matrix, in that order, is the vector whose elements are the product of the vector and the columns of the matrix.  Thus the number of elements of the vector must equal the number of rows of the matrix.  For example,

[2, 3]·[a, b; c, d]

displays as

       é a  b ù
[2, 3]·ê      ú
       ë c  d û

and simplifies to

[2·a + 3·c, 2·b + 3·d]

The product of two matrices is the matrix whose elements are the product of the rows of the first matrix and the columns of the second matrix.  Thus the number of columns of the first matrix must equal the number of rows of the second matrix.  For example,

[a, b; c, d]·[2; 3]

displays as

é a  b ù é 2 ù
ê      ú·ê   ú
ë c  d û ë 3 û

and simplifies to

é 2·a + 3·b ù
ê           ú
ë 2·c + 3·d û

As another, more general, example,

[2, 3; 4, 5]·[a, b, c; d, e, f]

displays as

é 2  3 ù é a  b  c ù
ê      ú·ê         ú
ë 4  5 û ë d  e  f û

and simplifies to

é 2·a + 3·d  2·b + 3·e  2·c + 3·f ù
ê                                 ú
ë 4·a + 5·d  4·b + 5·e  4·c + 5·f û

If variables are being used to represent vectors or matrices, declare them to be of vector type using the Author > Variable Domain command so their products will not be re-ordered or re-associated.

Use the dot product operator, ·, to compute the dot product (also called the inner product or scalar product) of two vectors.  Enter the dot operator by clicking on the · on the math symbol toolbar or by typing DOTPRODUCT on the keyboard.  The dot product of two vectors is the sum of the products of the elements of the first vector times the complex conjugate of the corresponding elements of the second vector.  Note that the vectors must have the same number of elements, and that the result is a scalar.  For example,

[a + b·#i, c + d·#i] DOTPRODUCT [e + f·#i, g + h·#i]

simplifies to

a·e + b·f + c·g + d·h - #i·(a·f - b·e + c·h - d·g)

and in particular,

 [a + b·#i, c + d·#i] DOTPRODUCT [a + b·#i, c + d·#i]

simplifies to

 2    2    2    2
a  + b  + c  + d 

Use the cross product operator, ´, to compute the cross product (also called the vector product) of two vectors.  Enter the cross product operator by clicking on the ´ on the math symbol toolbar or by typing CROSSPRODUCT on the keyboard.  Note that both vectors must have three elements or both must have two elements.  Three element cross products result in a vector; whereas, two element cross products result in a scalar.  For example,

[a, b, c] CROSSPRODUCT [d, e, f]

simplifies to

[b·f - c·e, c·d - a·f, a·e - b·d]

and

[a, b] CROSSPRODUCT [c, d]

simplifies to

a·d - b·c

Use the OUTER function defined in the VectorMatrixFunctions.mth utility file to compute outer products.




Matrix Operations

The functions and operators described in this section only apply to matrices.

The ROW and COL infix operators can be used as an alternative to the SUB operator (see Vector Manipulation Functions) to extract rows and columns of matrices.  If A is a matrix, A ROW n and A COL n return the nth row and column of A as a vector, respectively.  For example,

[a, b, c; d, e, f; g, h, i] ROW 2

simplifies to [d, e, f], and

[a, b, c; d, e, f; g, h, i] COL 2

simplifies to [b, e, h].  If the right operand of ROW or COL is a vector of indices, a matrix of the specified rows or columns is returned.  For example,

[a, b, c; d, e, f; g, h, i] ROW [3, 1]

simplifies to

é g  h  i ù
ê         ú
ë a  b  c û

and

[a, b, c; d, e, f; g, h, i] COL [3, 1]

simplifies to

é c  a ù
ê      ú
ê f  d ú
ê      ú
ë i  g û

Note that the ... ellipsis can be used to extract a range of rows or columns.  For example,

A ROW [3, ..., 7]

returns a matrix consisting of the 3rd through 7th rows of the matrix A.

The transpose of a matrix is the matrix resulting from interchanging its rows and columns.  The transpose of a scalar or a vector of scalars is the original scalar or vector of scalars.  Use the `(back-accent) postfix operator to generate the transpose of a matrix.  For example,

[[a, b, c], [1, 2, 3]]`

displays as

é a  b  c ù  
ê         ú` 
ë 1  2  3 û  

and simplifies to

é a  1 ù 
ê      ú 
ê b  2 ú 
ê      ú 
ë c  3 û 

A square matrix is a matrix with the same number of rows as columns.  Use DET to compute the determinant of a square matrix.  For example,

DET([2, 3; a, b])

simplifies to 2·b - 3·a.

The trace of a square matrix is the sum of its diagonal elements.  Use TRACE to compute the trace of a square matrix.  For example,

TRACE([a, b, c; d, e, f; g, h, i])

simplifies to a + e + i.

Use the ^ operator to raise a square matrix to an integer power.  For example,

[2, 3; a, b]^2

simplifies to

é  3·a + 4    3·b + 6 ù
ê                     ú
ê                   2 ú
ë a·(b + 2)  3·a + b  û

A singular matrix is a square matrix whose determinant is 0.  A singular matrix has no inverse.  For example,

[2, 3; 4·a, 6·a]^(-1)

does not simplify further since the matrix is singular.

Inverting a matrix can produce dramatically more complicated elements than the original matrix.  The complexity of the inverse of an n by n matrix with symbolic elements often grows combinatorially with n.  Even for numeric matrices, the elements of an inverse computed in exact or mixed mode can have dramatically more digits than the given elements.  

A system of linear equations can be represented as a vector of constants that is equal to the product of a coefficient matrix and a vector of unknowns.  Provided the matrix is nonsingular, you can use the matrix inverse and product operations to solve this matrix equation.  For example, to solve the system of equations

5·x + 3·y - 7·z  =  4
2·x - 8·y +  z  =  6
-x + 9·y + 4·z  =  5

enter the expression

[5, 3, -7; 2, -8, 1; -1, 9, 4]^(-1)·[4, 6, 5]

which approximates to the solution vector for x, y, and z

[2.910596026, 0.1754966887, 1.582781456]

Note that the exact rational solution can be found by simplifying, instead of approximating, the equation.

The above method is only able to solve systems of linear equations that are nonsingular.  Also since it requires the explicit computation of the inverse of a matrix, it is both space and time inefficient.  In contrast, the Solve commands and the function ROW_REDUCE (see Row Echelon Form) can solve larger as well as singular systems of linear equations, so long as they are consistent.




Row Echelon Form

Another method for solving systems of linear equations involves reducing a matrix to row echelon form.  In addition to being able to solve both singular and nonsingular systems, this method can simultaneously determine solutions to more than one set of constants on the right side of the equations.

Row echelon form is sometimes called reduced row echelon form or Hermite normal form.  A matrix is in row echelon form if:

·	the first nonzero element in every row is 1,

·	the first nonzero element in every row occurs to the right of the first nonzero element in the row above it, and

·	all the elements above the first nonzero element in a row are 0.

Use ROW_REDUCE to compute the row echelon form of a matrix.  The only matrix operations used are multiplying rows by scalars and adding rows.  These elementary row operations do not change the solution set.

If ROW_REDUCE is given two matrices, it adjoins them and returns the row echelon form of this augmented matrix.  Thus, to solve the matrix equation A·X = B where A and B are matrices and X is a vector of variables, enter and simplify (or approximate) an expression of the form

ROW_REDUCE(A, B)

If A is nonsingular, the result is a matrix in row echelon form: the identity matrix adjoined to the solution matrix.  For example,

ROW_REDUCE([1, 2; 5, 6], [3, 4; 7, 8])

simplifies to

é 1  0  -1  -2 ù
ê              ú
ë 0  1   2   3 û

and the solution is

é -1  -2 ù
ê        ú
ë  2   3 û

If A is singular, rows having 0 on the main diagonal are consistent only with augmented columns having 0 in the same row, in which case the corresponding element of X is arbitrary.  For example, since

ROW_REDUCE([1, 1; 2, 2], [1, 1; 2, 1])

simplifies to

é 1  1  1  0 ù
ê            ú
ë 0  0  0  1 û

the right column is inconsistent, but the column preceding it is consistent.

RANK(A) simplifies to the rank of matrix A.  The rank of a matrix is equal to the number of nonzero rows in the row echelon form of the matrix.  For example,

RANK([2, 3, 5; 4, 6, 10; 1, 2, 3])

simplifies to 2, since the second row is a multiple of the first.  Note that in approximate mode, RANK may return erroneous results due to roundoff errors.

If a matrix contains symbolic entries, reducing it to row echelon form may result in the loss of information about special cases.  For example,

ROW_REDUCE([1, 0; 0, x-2])

simplifies to [1,0;0,1].  However, in the special case x=2

ROW_REDUCE([1, 0; 0, 2-2])

simplifies to [1,0;0,0].

Turing LU matrix factoring is useful to determine the location of such special cases.  The last factor of a Turing factorization is the row echelon form of the matrix.  If the determinant of the third factor is nonzero, this row echelon form is always valid.  However, if the matrix contains variables and there are sets of values for those variables such that the determinant of the third factor is zero, the row echelon form must be re-computed separately for each of those sets of values.  For example,

FACTOR([1, 0; 0, x - 2], Turing)

simplifies to

é 1  0 ù é 1  0 ù é 1    0   ù é 1  0 ù é 1  0 ù
ê      ú·ê      ú·ê          ú·ê      ú·ê      ú
ë 0  1 û ë 0  1 û ë 0  x - 2 û ë 0  1 û ë 0  1 û

and

DET([1, 0; 0, x - 2])

simplifies to x-2.  For more information about Turing LU matrix factoring see Factoring Matrices.




Gröbner Basis

Use the function GROEBNER_BASIS to construct the Gröbner basis for a collection of polynomials based on lexicographic ordering of the variables.  If polys is a vector (set) of polynomials and vars is a vector of variables,

GROEBNER_BASIS(polys, vars)

simplifies to a vector (set) of polynomials that form the Gröbner basis for polys based on the lexicographic ordering of vars.

Note that the Gröbner basis of a collection of polynomials is unique, once the order for the variables is fixed.  If the ordering of the variables is changed, the Gröbner basis could change.  For example,

GROEBNER_BASIS([x*z^3+2*y+2, y*z^3-y*z^2-z^2+y^2+y], [x, y, z])

simplifies to

é 2       3    2         2     3          ù
ëy  + y·(z  - z  + 1) - z , x·z  + 2·y + 2û

whereas

GROEBNER_BASIS([x*z^3+2*y+2, y*z^3-y*z^2-z^2+y^2+y], [z, y, x])

simplifies to a more complicated basis consisting of six polynomials.

The Gröbner basis has numerous applications.  For example, consider the problem of finding the intersection of the following three surfaces: the sphere centered at the origin with a radius of the square root of 2 (x^2+y^2+z^2=2); the paraboloid (z=x^2+y^2); and the vertical cylinder along the z axis with a radius of 1 (x^2+y^2=1).  The fact that

GROEBNER_BASIS([x^2+y^2+z^2-2, x^2+y^2-z, x^2+y^2-1], [x, y, z])

simplifies to [z - 1, x^2 + y^2 - 1] shows that the intersection of the three surfaces is a circle of radius 1 parallel to the xy plane at height 1.

To verify that the following two paraboloids do not intersect in R^3 (i.e. the system has no real roots), note that 

GROEBNER_BASIS([x^2+y^2-z+1, -x^2-y^2-1-z], [x, y, z])

simplifies to [z, x^2 + y^2 + 1].

To verify that the following two paraboloids do not intersect in C^3 (i.e. the system has no roots), note that

GROEBNER_BASIS([x^2+y^2-z+1, x^2+y^2-z+3], [x, y, z])

simplifies to [1].  It is a requirement of Hilbert's Nullstellensatz that the geometric interpretation of the Gröbner basis must always be done in C^n, not in R^n.




Eigenvalues

The characteristic polynomial of a square matrix is the determinant of the difference of the matrix and a variable times the identity matrix.  If A is a square matrix and v is a variable, CHARPOLY(A, v) simplifies to the characteristic polynomial of A in terms of v.  For example,

CHARPOLY([2, 3; a, b], z)

simplifies to

 2                         
z  - z·(b + 2) - 3·a + 2·b 

The default value of the variable used by CHARPOLY is w.

The eigenvalues of a square matrix are the zeros of its characteristic polynomial.  If A is a square matrix and v is a variable, EIGENVALUES(A, v) simplifies to a vector of the eigenvalues of A in terms of v.  For example,

EIGENVALUES([2, 3; 0, b], z)

simplifies to [z = 2, z = b].  If no variable is given, a vector of just the eigenvalues is returned.

The degree of the characteristic polynomial equation that EIGENVALUES must solve is equal to the dimension of the matrix.  Since characteristic polynomials rarely factor exactly over the rational numbers, exact results usually require the cubic formula for 3 by 3 matrices or the quartic formula for 4 by 4 matrices.  Exact results are usually impossible for matrices larger than 4 by 4.  Moreover, the quartic formula generates such bulky results that the exact eigenvalues of 4 by 4 matrices often exhaust memory.  Thus, exact eigenvalues are rarely attainable for matrices larger than 3 by 3.

The characteristic polynomial of a numerical matrix is univariate.  Thus real and complex eigenvalues can be approximated by finding the zeros of the characteristic polynomial using the Solve > Expression command.  Note that the eigenvalues of symmetric and Hermitian matrices are all real.

The file LinearAlgebra.mth defines functions for computing exact and approximate eigenvectors.


Vector and Matrix Algebra

Derive automatically uses the rules of vector and matrix algebra to simplify and normalize expressions involving vectors and matrices.  If the variables a, b, and c are declared to be vectors (see the Author > Variable Domain command), the following transformations are used:


 a``  Þ  a
(a^-1)`  Þ  a`^-1
(a + b)`  Þ  a` + b`
(a · b)`  Þ  b` · a`
a · (b + c)  Þ  a · b + a · c
(b + c) · a  Þ  b · a + c · a
(a · b) · c  Þ  a · (b · c)
(a · b)^-1    Þ  b^-1 · a^-1 
DET(a^-1)  Þ  1/DET(a)




Differential Vector Calculus

Derive can do differential vector calculus in any orthogonal, curvilinear coordinate system.  For example, you can compute gradients, divergences, and curls in rectangular (Cartesian), polar-cylindrical, or spherical coordinates.  The three-dimensional rectangular coordinate system is the default with x, y, and z used as the names of the coordinate variables.

Use GRAD to compute the gradient of an expression.  For example,

GRAD(x·y^2·z^3)

simplifies to

é  2  3         3       2  2ù
ë y ·z , 2·x·y·z , 3·x·y ·z û

To compute the general form of the gradient in rectangular (Cartesian) coordinates, define F(x,y,z) to be an arbitrary function (see the Author > Function Definition command) using the assignment

F(x, y, z) :=

then

GRAD(F(x, y, z))

simplifies to

éd              d              d            ù
ê-- F(x, y, z), -- F(x, y, z), -- F(x, y, z)ú
ëdx             dy             dz           û

To specify rectangular coordinates with other coordinate variables, call GRAD with a vector of coordinate variables as the second argument.  For example,

GRAD(c·w + x^2 + y^3 + z^4, [w, x, y, z])

simplifies to the four-element vector

é           2     3ù
ëc, 2·x, 3·y , 4·z û

For other orthogonal coordinate systems, provide a second argument that is a coordinate geometry matrix of the form

ê x1  x2  ...  xn ú
ê                 ú
ê h1  h2  ...  hn ú

The first row consists of the coordinate variables associated with successive elements of vectors.  The second row consists of the scale factors such that the squared infinitesimal length is given by

  2           2           2                 2
ds  = (h1·dx1)  + (h2·dx2)  + ... + (hn·dxn) 

The file VECTOR.MTH assigns polar-cylindrical and spherical coordinate geometry matrices to the variables cylindrical and spherical respectively as follows:

               é r  q  z ù
cylindrical := ê         ú
               ë 1  r  1 û

and

             é r      q     F ù
spherical := ê                ú
             ë 1  r·SIN(F)  r û

Thus, if VECTOR.MTH is loaded,

GRAD(r·SIN(theta)·COS(phi), spherical)

simplifies to

[COS(j)·SIN(q), COT(j)·COS(q), - SIN(j)·SIN(q)]

For a right-hand coordinate system having the positive z-axis associated with the north pole, this definition of spherical coordinates measures colatitude F in radians south from the north pole and measures colongitude q in radians east from the positive x-axis.  Be aware that some references define spherical coordinates differently, such as interchanging the definitions of q and F.

All the differential vector functions take an optional second argument that is a Cartesian coordinate vector or a coordinate geometry matrix.

Use DIV to compute the divergence of a vector.  For example,

DIV([y^2·z^3, 2·x·y·z^3, 3·x·y^2·z^2])

simplifies to

      2        3  
x·(6·y ·z + 2·z ) 

Use LAPLACIAN to compute the divergence of the gradient of an expression.  For example,

LAPLACIAN(x·y^2·z^3)

simplifies to 

      2        3  
x·(6·y ·z + 2·z ) 

Use CURL to compute the curl of a vector having two or three elements.  For example,

CURL([y^2, 2·x·z, 0])

simplifies to

[- 2·x, 0, 2·z - 2·y]

The curl of a planar vector field is a vector perpendicular to that plane.  Thus, the curl of a two element vector is a three element vector whose first two elements are zero.  In this case Derive follows the more common convention of just returning the third element as a scalar.  For example,

CURL([v^2, u], [u, v; 1, 1])

simplifies to 1 - 2·v.



Integral Vector Calculus

Derive can do integral vector calculus in any orthogonal, curvilinear coordinate system.  For example, you can compute scalar or vector potentials in rectangular (Cartesian), polar-cylindrical, or spherical coordinates.

Use POTENTIAL to compute a scalar potential of a vector.  For example,

POTENTIAL([y^2·z^3, 2·x·y·z^3, 3·x·y^2·z^2])

simplifies to

    2  3 
 x·y ·z  

As with antiderivatives, scalar potentials are unique only to within a constant. Thus, POTENTIAL may give a different result than one derived manually.  Such additive constants can be well disguised -- particularly in expressions involving logarithms or inverse trigonometric functions.  However, the gradient of a potential should be equivalent to the original vector.

Not all vectors have an associated scalar potential.  POTENTIAL merely computes a certain line integral involving the given vector.  If there is no potential, then the gradient of the resulting scalar will not be equivalent to the original vector.  It is your responsibility to check this.  In the case of a vector of two or three elements, it may be easier to see if the CURL of the given vector is equivalent to zero, as is necessary and sufficient for the existence of a scalar potential.

POTENTIAL takes an optional second argument that is a vector specifying the starting coordinates for the line integrals.  This argument defaults to a vector of zeros.  An inappropriate choice may lead to an infinite or unknown potential.  Try other values if this happens.  What you want is starting coordinates at which the given gradient is simple and finite.  p/2 and other simple rational multiples of p are often good alternatives for angular starting coordinates.  Infinity is often a good starting nonangular coordinate when 0 is not.  1 is often a good starting coordinate if the given gradient involves logarithms of that coordinate.

POTENTIAL also takes an optional third argument that is a Cartesian coordinate vector or a coordinate geometry matrix (see Differential Vector Calculus).  Three-dimensional rectangular coordinates is the default using successive variables x, y, and z.

Use VECTOR_POTENTIAL to compute a vector potential of a three-element vector.  For example,

VECTOR_POTENTIAL([x, 0, y - z])

simplifies to

é    2           ù
ê   y            ú
ê- ----, - x·z, 0ú
ë   2            û

As with POTENTIAL, VECTOR_POTENTIAL takes optional second and third arguments for specifying the starting coordinates and a coordinate geometry matrix.

Vector potentials are unique only to within an arbitrary gradient.  Consequently, two equally valid vector potentials may be quite different.  However, the curls of both vector potentials should be equivalent to the original vector.

Not all vectors have an associated vector potential.  VECTOR_POTENTIAL merely computes a certain line integral involving the given vector.  If there is no vector potential, the curl of the resulting vector will not be equivalent to the original vector.  It is your responsibility to check this.  Alternatively, it may be easier to see if the DIV of the given vector is zero, as is necessary and sufficient for the existence of a vector potential.



Significance of Domain Declarations

Some transformations for simplifying mathematical expressions are valid for both real and complex expressions.  For example,

(Öz)²  ®  z

is valid whether z is a real or complex expression.  Some transformations are valid only for real expressions.  For example,

Ö(x²)  ®  |x|

is valid only if x is real.  Some transformations are valid only for a restricted interval of real values.  For example,

Ö(x·y)  ®  Ö(x)·Ö(y)

is valid for real x and y unless both are negative.  Some transformations are valid only for integer-valued expressions.  For example,

sin(n·ð)  ®  0

is valid only if n has an integer value.  Even as basic a transformation as commuting the operands of a product is valid only if the operands are scalars.

When simplifying an expression, Derive exploits a transformation only if it can determine that the transformation is valid.  This determination depends heavily on the declared domain of the variables in the expression.  Use the Author > Variable Domain command to examine or change the domain declaration of a variable.

Since real-valued variables are the most common, the default domain of undeclared variables is real.  However, if an expression contains variables that only assume integer values or a subset of real values, you can restrict the domain of these variables.  On the other hand, if an expression contains variables that can be complex or even a vector, set, or logical truth-value, you can expand the domain of these variables.

The transformation

x - x  ®  0 · x  ®  0

is essential for simplifying expressions.  Since this and other transformations are questionable if x is infinity, Derive does not permit variable domains to include an infinite magnitude.  Thus infinite bounds are always strict.

Although variables cannot be declared infinite, you can substitute an infinite value for a variable in an expression (see the Simplify > Variable Substitution command).  However, you risk an invalid result if the expression was derived using transformations, such as the above, which are questionable for infinite values.

As might be expected, Derive simplifies both x/x and x^0 to 1, even if the domain of the variable x includes 0.  For consistency, Derive also simplifies 0^0 to 1, since this is just a special case of the above x^0 simplification.

The domains of variables are used during simplification of fractional powers, absolute values, logarithms, and some other irrational functions.  They do not restrict the values that can be substituted for variables (see the Simplify > Variable Substitution command).  Thus, you can substitute a complex value for a real variable or a negative value for a positive variable.  Such substitutions are made at your own risk.



Using and Saving State Variables

The settings of the algebra state variables affect how expressions are input, simplified, and output.  When Derive starts or when a new worksheet is created using the File > New command, the state variables are assigned their factory default settings.  When a dfw file is opened using the File > Open command, the state variables are assigned the values they had at the time the file was saved. 

The algebra state variable settings can be examined and/or changed using the following tabs Options > Mode Settings command’s dialog box:

·	Input tab
·	Simplification tab
·	Output tab

Alternatively, if you know the state variable name and the desired value, you can use either the Author > Variable Value command or the Author > Expression command to generate the appropriate assignment statement.

When an algebra window worksheet is saved as a dfw file using the File > Save command or File > Save As command, the state variable settings are automatically saved in the file.  When the dfw file is subsequently opened, the settings are restored to those existing at the time the file was saved.

When an algebra window worksheet is saved as a mth file using the File > Save As command, check the Save State Variables box to save the state variable settings in the file.  When the mth file is subsequently opened or loaded, the settings are restored to those existing at the time the file was saved.



Derive Initialization File

When exiting Derive, information such as window sizes and colors, printing options, and the Math file directory is saved in the Derive6.ini file.  The settings in this file are used to initialize Derive when it starts, unless you choose to use the factory default settings as allowed by the Derive Startup dialog box (see the Options > Startup command).  If the initialization file does not exist when Derive starts, it automatically creates a Derive6.ini file using the factory default settings.

Note that in Derive 6, the algebra state variables are no longer saved in the initialization file.  Instead, they are saved in dfw and mth files as described in Using and Saving State Variables.

If Derive is launched by clicking on a shortcut icon on the Windows desktop, the Derive6.ini file used is the one stored in the Start in directory (also called the working directory) specified by the properties of the shortcut.  To examine and/or change the Start in directory, right click on the Derive desktop icon and select the Properties option.

If Derive is launched by clicking on a dfw worksheet file or a mth math file from Windows explorer or some other program, the Derive6.ini file used is the one stored in the same directory as the Derive6.exe application file.  Normally the application file resides in the directory named \Derive6 which is created when Derive is installed.

Derive6.ini is a standard Windows ini file that can be edited with a text editor.  However, we do not recommend editing the ini file yourself.  In any event, do not edit or delete the ini file while Derive is running, since it uses and modifies the file as it runs.



Multiple Plots

To plot multiple expressions in the same 2D-plot window simply change the highlighted expression in the algebra window, switch to the 2D-plot window and issue a Insert > Plot command for each expression to be plotted.

A vector of two expressions will be plotted as a parametric plot (see Parametric Plots).  However, if a vector of three or more expressions is highlighted, the Insert > Plot command plots each element of the vector.

Use the Author > Vector command to type in a vector of new expressions.  Alternatively, use the Calculus > Vector command to generate a vector of an expression evaluated at a sequence of points.  For example,


VECTOR(x^k, k, 0, 2, 1/4)

simplifies to

é    1/4   1/2   3/4      5/4   3/2   7/4   2ù
ë1, x   , x   , x   , x, x   , x   , x   , x û

and plots as a family of curves in the 2D-plot window.

Note that multiple plots all share the same plot scale and range.  Therefore, you may have to zoom out and/or move the center of the 2D-plot window to see all of the plot lines simultaneously.  Also, you can press the Esc key to stop any subsequent plots from being plotted in the 2D-plot window.

To move a plot line relative to the others, add an offset to the corresponding expression in the algebra window.  To magnify or shrink a plot line relative to the others, multiply the corresponding expression by a scaling factor in the algebra window.  Sometimes it is advisable both to shift and scale plot lines in order to optimally frame several of them in a single window.  Or, instead of individually scaling expressions, expressions may be plotted in multiple plot windows, each with their own scales (see the Window > New 2D-plot Window command).

To compare coordinate values of multiple plot lines you may want to turn on trace mode using the Options > Trace Plots command.  When you switch on trace mode the cross (displayed as a small box) will move to the plot line of the last expression in the list at the current x-coordinate.  You may then use the mouse or right and left arrow keys as described previously to trace along the plot.  To trace another plot line use mouse or the up and down arrow keys as follows:

·	Up arrow  or click the right mouse button and choose Trace previous plot to move the box to the previous expression’s plot line.

·	Down arrow or click the right mouse button and choose Trace next plot to move the box to the next expression’s plot line.

In trace mode the number of the expression being traced is displayed in the 2D-plot window title bar.  Thus when plotting several expressions, trace mode is a good way to determine the correlation between plot line and expression.

Use the Options > Display > Plot Color command to customize the colors used for multiple plot lines.

A particular plot line may be deleted by using the Edit > Delete Plot command.

Whenever a 2D-plot window changes size, all plots currently contained in that plot window will be recalculated and subsequently replotted.

If it takes too long to regenerate the plots while resizing a plot window using the sizing handles, you can turn off the Show Window Contents While Dragging feature of Windows.  When this feature is on, a window’s contents is displayed while it is moved or resized.  When this feature is off, only an outline of a window is displayed while it is moved or resized.  So, turning this feature off allows the plot window to be resized before any plots are regenerated.

To toggle this feature on or off, run the Window’s Control Panel Display program.  If running Windows 98, click on the Effects tab of the dialog box.  If running Windows NT or Windows 95 with Microsoft Plus!, click on the Plus! tab.  Finally click on the Show Window Contents While Dragging check box to toggle the feature on or off.



Polar Plots

To make polar plots of expressions use the Set > Coordinate System command to select the polar coordinate system.  See the on-line help for that command for a summary of how plots of expressions and equations are interpreted in polar coordinates.

In polar coordinates the 2D-plot window's Insert > Plot command prompts you to enter information into the Parametric Plot Parameters dialog box.

In polar coordinates the position of the cross is displayed in polar coordinates on the status bar.  The radial distance of the cross from the origin is the first coordinate.  The angle of the cross, represented in either radians or degrees depending on the angle mode, is measured counterclockwise from the positive x-axis and is the second coordinate.

Trace mode is available in both rectangular and polar coordinates.  When you start tracing in polar coordinates, the cross goes to the midpoint of the parameter range.  The midpoint of the parameter range is calculated from the value in the Points field when plotted in discrete mode.  The midpoint of a continuous plot is calculated from the current value in the Points field.

When tracing plots in polar coordinates, the 2D-plot window title bar shows a message of the form

Tracing expression #n, at t = x.xxxxxxx 

where n is the number of the expression being traced and x.xxxxxxx is the parameter value at the box location.

For tracing purposes, the angular range of the polar plot is divided into equally spaced points.  The number of points is 10 times the number of points entered in the Parametric Plot Parameters  dialog box.  When tracing a polar plot, use the direction keys or mouse to move the box along the plot as follows:

·	Left arrow  or click the right mouse button and choose Move left one unit to decrease the parameter value to move the box the distance of one point along the plot.

·	Right arrow or click the right mouse button and choose Move right one unit to increase the parameter value to move the box the distance of one point along the plot.

·	Ctrl+Left arrow or click the right mouse button and choose Move left multiple units to decrease the parameter value to move the box the distance of ten points along the plot.

·	Ctrl+Right arrow or click the right mouse button and choose Move right multiple units to increase the parameter value to move the box the distance of ten points along the plot.

The Up arrow and Down arrow keys as well as the mouse can be used to trace another rectangular or polar plot line in a 2D-plot window with multiple expressions plotted (see Multiple Plots ).

Alternatively, the trace box may be moved to a specific location using the mouse.  Simply click the left mouse button at the desired angular coordinate to move the box to the corresponding plot value at that coordinate.

The polar plot line only spans expression values from the minimum parameter to the maximum parameter specified.  When tracing a polar plot, the box can be moved off the edge of the plot line in order to visualize the shape of the plot if the parameter range were extended.



Parametric Plots

A parametric plot results from plotting a vector of two univariate expressions dependent on the same variable.  In rectangular coordinates the value of the first expression is the x-coordinate, and the value of the second expression is the y-coordinate.  In polar coordinates the value of the first expression is the radial distance from the origin.  The value of the second expression is the angle, represented in either radians or degrees depending on the angle mode (see Angular Unit field), and measured counterclockwise from the positive x-axis.

When plotting a parametric plot the 2D-plot window's Insert > Plot command prompts you to enter information into the Parametric Plot Parameters dialog box.

When making a continuous parametric plot, the parameter interval is recursively subdivided until the curve can be accurately approximated by a straight line.  This may take an unacceptably long time if subdividing the curve is outside the window or in the neighborhood of a singularity.  If this occurs, use the Edit > Delete Plot command to delete the continuous plot and replot the parametric expressions using the Parametric Plot Parameters dialog box to select discrete points.

Since parametric plots are done in a standard 2D-plot window, you can zoom, move the cross, and plot any mixture of expressions as described previously.  Tracing a parametric plot works in the same way as tracing a polar plot (see Polar Plots).

The file 2D-plotExamples.dfw in the Users\Plotting directory includes several parametric expressions that are interesting to plot.

Functions for plotting parametrically defined space curves such as helixes are defined in the Graphics Functions.mth utility file.



Data Point Plots

2D-plot windows interpret a vector of two numbers as the coordinates of a data point.  In rectangular coordinates, the first element of the vector is the x-coordinate of the point and the second is the y-coordinate.  In polar coordinates, the first element of the vector is the r-coordinate of the point and the second is the q-coordinate.  See the Set > Coordinate System command for details.  

2D-plot windows plot such vectors as a single point.  For example, in rectangular coordinates,

[2, 1]

plots as the point 2 units to the right of y-axis and 1 unit above the x-axis.  In polar coordinates, it plots as the point 2 units from origin and 1 radian measured counter-clockwise from the positive x-axis.

2D-plot windows plot a vector of two-dimensional data points (i.e. a data matrix) as a collection of data points.  For example, in rectangular coordinates,

[[2, 2], [2, -2], [-2, -2], [-2, 2]]

plots as 4 points in a square centered on the origin.  In polar coordinates, it plots as 4 points in a rectangle also centered on the origin.

Use the Options > Display > Points command to set the size (small, medium, or large) of data points, and to turn on or off the option to connect successive data points with line segments.  For example, in rectangular coordinates, if the option to connect successive data points is on

[[2, 2], [2, -2], [-2, -2], [-2, 2]]

plots as an open box.  In polar coordinates, it plots as a Z-shape on its side.

Note that if either or both elements of a two-element vector depend on a single variable, the vector is plotted parametrically (for details, see Parametric Plots).  If either or both elements of a two-element vector depend on more than one variable, each element of the vector is plotted separately (for details, see Multiple Plots).

Simplifying an expression of the form TABLE(u, x, a, b, s) generates a data matrix for the univariate expression u depending on x, as x goes from a to b in steps of size s (for details, see the Calculus > Table command).  For example,

TABLE(x!, x, 0, 5)

simplifies to a data matrix of factorials.



Implicit Plots

Functions implicitly defined by an equation may be plotted using a relatively efficient algorithm of linear interpolation upon triangles.  As described in the 2D-plot window Insert > Plot command, the form of an implicitly defined equation is u = v
, where u and v are expressions of at most two variables.  Examples of such equations are

 2    2    
x  + y  = 4

 3    2    
x  = y  - 5
x = 3

and

 2             
r  + cos(q) = 0

To produce an implicit plot in rectangular coordinates, the variables in the equation are assigned to the horizontal and vertical axes.  Usually, the primary variable is assigned to the horizontal axis, the secondary variable to the vertical axis (see Ordering Variables in Expressions).  If the equation contains only one variable, it will normally be assigned to the vertical axis.  However, if the variable is x, as in the third equation above, x will be assigned to the horizontal axis.  In general, if an equation contains the variable x, the equation will always be plotted with x assigned to the horizontal axis.  Thus, for implicit plotting in rectangular coordinates we recommend using x for the horizontal and y for the vertical coordinate. 

To produce an implicit plot in polar coordinates, the angle and the distance from the origin are assigned to variables in the equation.  Usually, the primary variable is assigned to the angle, the secondary variable to the distance from the origin.  However, if one of the variables in the equation is a Greek letter, it is assigned to the angle.  For implicit plotting in polar mode we recommend using r for the distance from the origin and q for the angle.

The implicit plotting algorithm starts in the top left corner of the 2D-plot window, plotting points in a top to bottom, left to right fashion.  Unlike most explicit plots, implicit plots may not be automatically scaled; nor may an implicit plot line be traced.

Explicit plots are faster and more accurate than implicit plots.  Before plotting, when possible, Derive automatically converts a function implicitly defined by an equation into a function explicitly defined by an equation of the form y = u where y is a variable and u is a univariate expression in another variable.  For example, the linear equation

2x + 3y = 6

is transformed into the equation

y = -2/3x + 2

and then plotted using the more expeditious explicit plotting algorithm.

A function implicitly defined by an equation may be solved for one of its variables in terms of the other by using the algebra window’s Solve > Expression command to generate explicit solutions.  If explicit solutions of the equation are achievable, explicit plots of these solutions may be superimposed in a 2D-plot window.

An alternate method for generating explicit solutions for implicitly defined equations is to substitute polar coordinates for the variables and solve for the distance from the origin in terms of the angle. For example,

 5    4    5    4 
x  + x  = y  + y  

cannot be solved exactly for either x or y.  However, substituting r cos(q) for x and r sin(q) for y, then solving for r gives the two explicit solutions

r = 0

and

                   2    
       1 - 2 COS(q)     
r = ------------------- 
           5         5  
     COS(q)  - SIN(q)   

These explicit solutions may then be plotted in polar coordinates in the 2D-plot window.

Implicit 2D plots of a family of plot lines can be used to make contour plots of functions of two variables.  In a 2D-plot window after issuing the Options > Simplify Before Plotting command, plotting an expression of the form

VECTOR (z = u, z, m, n, s)

produces a contour plot of the function z = u where u is a function of x and y as z varies from m to n in steps of size s.  For example, the function

z = 10/(2^2+(x-2)^2+y^2) + 10/(2^2+(x+2)^2+y^2)

plots as "two mountains" in a 3D-plot window; whereas the vector

VECTOR(z = 10/(2^2+(x-2)^2+y^2) + 10/(2^2+(x+2)^2+y^2), z, 1, 3, 0.1)

plots as a contour plot of the function in a 2D-plot window.  Note that the Calculus > Vector command is an easy way to enter such expressions. 
 


Parametric Plot Parameters

If the expression being plotted is a vector of two univariate expressions dependent on the same variable, the 2D-plot window Insert > Plot command displays a dialog box with the following fields:


Minimum value:  Enter the minimum value for the parameter of a parametric plot (see Parametric Plots ) or the minimum value for the angle in a polar plot (see Polar Plots).  The default initial minimum value is a numerical approximation of -p in radian angle mode and -180 in degree angle mode.

Maximum value:  Enter the maximum value for the parameter of a parametric plot (see Parametric Plots ) or the maximum value for the angle in a polar plot (see Polar Plots).  The default initial maximum value is a numerical approximation of p in radian angle mode and 180 in degree angle mode.

When changing the minimum and maximum parameter values, use radians if in radian angle mode and degrees if in degree angle mode.  See the Angular Unit field for information on changing the angle mode.

Plot Mode:

·	Click the Line button to plot the expression as a continuous line.

·	Click the Points button to plot the expression as a series of discrete points.

Points:

·	Click the Small button to display a data point as a 1 pixel rectangle.

·	Click the Medium button to display a data point as a 3 by 3 pixel filled rectangle.

·	Click the Large button to display a data point as a 5 by 5 pixel filled rectangle.

·	In the Number of field, enter the number of discrete points to plot.

Apply parameters to rest of plot list:  This option is displayed at the bottom of the Parametric Plot Parameters dialog box only if the expression being plotted is a multi-element vector.  Check this option if you wish to apply the above parameters to the remaining parametric plots.  Do not check this option if you wish to specify different parameters for the remaining parametric plots.

(The underlined button name in a field indicates the default initial setting.)



Data Point Plots

3D-plot windows interpret a vector of three numbers as the coordinates of a data point.  The coordinate system selected by the Set > Coordinate System command determines the meaning of coordinate vectors as follows:

·	In rectangular coordinates, the coordinate vector [x, y, z] represents the point x units from the y-z plane, y units from the x-z plane, and z units from the x-y plane.

·	In spherical coordinates, the coordinate vector [r, q, j] represents the point r units from the origin, q radians from the positive x-axis, and j radians from the positive z-axis.

·	In cylindrical coordinates, the coordinate vector [r, q, z] represents the point r units from the z-axis, q radians from the positive x-axis, and z units from the x-y plane.

In the 3D-plot window, the form of the vector or matrix of coordinate vectors being plotted determines how the data is displayed.  If xi, yi, and zi are numerical constants, the following summarizes how such vectors and matrices are plotted:

·	Both the coordinate vector [x, y, z] and the 1 by 3 matrix of coordinate values [[x, y, z]] each plot as a single isolated point.

·	The vector of n 1 by 3 matrices of coordinate values [[x1, y1, z1]; [x2, y2, z2]; ...; [xn, yn, zn]] plots as n isolated points.  For example, in rectangular coordinates

[[0, 0, 0]; [2, 0, 0]; [0, 2, 0]]

plots as three points in the x-y plane.

·	The n by 3 matrix of coordinate values [x1, y1, z1; x2, y2, z2; ...; xn, yn, zn] plots as n-1 connected line segments.  For example, in rectangular coordinates

[0, 0, 0; 2, 0, 0; 0, 2, 0; 0, 0, 0]

plots as a triangle in the x-y plane.

·	The n by m matrix of z-values [z11, z12, ..., z1m; z21, z22, ..., z2m; ...; zn1, zn2, ..., znm] plots as the functional surface defined by the n·m rectangular coordinate vectors [i, j, zij].  For example, if the Approximate Before Plotting option is turned on,

VECTOR(VECTOR(SIN(x) + COS(y), x, -10, 10), y, -10, 10)

plots as the undulating surface z = sin x + cos y.  Note that if m (i.e. the number of columns) is 3, data matrices of this form are plotted as n-1 connected line segments as described above.

·	The n by m matrix of coordinate vectors

[ x11, y11, z11; x12, y12, z12; ...; x1m, y1m, z1m ]
[ x21, y21, z21; x22, y22, z22; ..., x2m, y2m, z2m ]
...
[ xn1, yn1, zn1; xn2, yn2, zn2; ...; xnm, ynm, znm ]

plots as the parametric surface defined by the n·m coordinate vectors [xij, yij, zij].  For example, in rectangular coordinates

[[ 3,  3,  3;  3,  3, -3],
 [ 3, -3,  3;  3, -3, -3],
 [-3, -3,  3; -3, -3, -3],
 [-3,  3,  3; -3,  3, -3],
 [ 3,  3,  3;  3,  3, -3]]

plots as an open ended box.



Framing 3D Plots

Imagine that the surface of an expression being plotted is enclosed in a transparent box just spanning the maximum and minimum computed values of x, y, and z.  Your monitor screen is between the box and an eye fixed somewhere in front of the screen.  Each point on the wire frame projects onto the screen along the line joining that point to the eye.

For maximum resolution it is usually desirable to magnify the surface as much as possible while keeping it entirely within the 3D-plot window.  Therefore, Derive automatically magnifies the image horizontally so the surface just fits the full width of the 3D-plot window.  Also, if using the optional automatic vertical centering and scaling, Derive automatically tries to magnify and shift the image vertically so the surface just fits the height of the 3D-plot window.  Naturally this is impossible if the surface projects as a horizontal line, in which case Derive generates an error beep.

To impose a specific scaling in all three directions, turn off the automatic centering and scaling of new plots using the Options > Autoscale New Plots command.  For example, you may want to impose equal scaling in all three directions.  Alternatively, you may want to magnify certain details at the expense of having portions clipped at the top or bottom edge of the plot window.

The framing challenge for three dimensions is more difficult than for two dimensions because of the lower effective resolution and the extra dimension to search.  If a few experiments do not reveal appropriate ranges for the two variables in your expression or equation, then use a 2D-plot window to plot cross-sections obtained by substituting various numeric values for one or the other of the two variables.  The ten-fold greater resolution of 2D plots often more quickly reveals appropriate ranges for viewing the two variables in a 3D-plot window.  If you zoom in on a 2D plot until the features of interest are at least 1/nth of the window width, they have a chance of being resolved in a 3D-plot window of that size using n grid lines for that coordinate.




Programming in Derive

In Derive, a program is a mth file of related function definitions and variable assignments.  The utility files distributed with Derive are examples of such programs.  To use a program, load the mth file into an algebra window using the File Load Utility command.  Once loaded, the functions and variables defined in the mth file can be used in mathematical expressions in the same way that the built-in functions and constants are used.

See the Author > Variable Value command for a description of how to assign values to variables.  See the Author > Function Definition command for a description of how to define functions.

These topics describe how to write your own programs using the various tools provided by Derive:

The ITERATES Function 
The ITERATE Function 
IF Expressions 
Nested IF Expressions 

Boolean Test Clauses 
Recursive Functions 
Mutual Recursion 
Procedural Programming 
Epilogue 


The ITERATES Function

In most programming languages numerical operations are usually done by iteration (i.e. loops and jumps) and/or by recursion (i.e. recursive function calls).  Many of these operations can easily be done in Derive using its built-in calculus and vector functions (see Calculus commands and Vectors and Matrices).  For example, SUM and PRODUCT can be used to add or multiply a sequence of expressions.  VECTOR can be used to generate a table of data.  The SUB operator can be used to extract data from a vector or table.

In addition to these specialized functions, Derive provides two built-in functions for general-purpose iteration:  ITERATE and ITERATES.  Simplifying or approximating an expression of the form

ITERATES (u, x, x0)

causes the update formula

x  ¬  u(x)

to be repeatedly applied, starting with x=x0, until x is equal to one of its earlier values.  The result is a vector of these values, starting with x0.

The fixed-point iteration method for solving an equation provides a good illustration of the use of ITERATES.  For example, to solve the transcendental equation x = exp(-x/20) plot the difference in the two sides of the equation

x - EXP(-x/20)

and note that a solution exists in the neighborhood of x=1.  To refine this initial guess, substitute the guess into the right side of the equation, and then approximate the result to determine a second approximation for x.  Then substitute this second approximation for x in the right side to determine a third approximation, and so on.

The function ITERATES can be used to automate this process.  For example, using the Simplify > Approximate command at 6 digits of precision,

solns := ITERATES(EXP(-x/20), x, 1)

approximates to the vector

[1, 0.951229, 0.953551, 0.953441, 0.953446, 0.953446, 0.953446, 0.953446]

of successively better approximations to x = exp(-x/20).

If the above expression involving ITERATES is simplified rather than approximated, no iterate would ever equal an earlier one and the iteration would never terminate.  Therefore, approximation is the appropriate operation to apply for this particular application of ITERATES.

Note that displayed in decimal notation the last four approximations in the above vector appear equal.  However if solns is simplified, the approximations are displayed in rational notation as

é    4681    349    8437    19559    21013    18412    18412 ù
ê1, ------, -----, ------, -------, -------, -------, -------ú
ë    4921    366    8849    20514    22039    19311    19311 û

and it becomes apparent that only the last two values are actually equal.  The decimal notation only makes it appear that ITERATES did more iterations than necessary.

ITERATES takes an optional fourth argument giving exactly how many iterations to perform.  For example, at 6 digits of precision

ITERATES(EXP(-x/20), x, 1, 5)

approximates to the six element vector

[1, 0.951229, 0.953551, 0.953441, 0.953446, 0.953446]

If the fourth argument of ITERATES is a negative integer, the inverse of the first argument is iterated upon.  For example,

ITERATES(TAN(x), x, x, -1)

simplifies to [x, ATAN(x)].  This feature is used to define INVERSE in MiscellaneousFunctions.mth.

The fixed-point iteration method often diverges since the magnitudes of successive iterates get bigger and bigger until memory is exhausted.  Thus, it is usually a good idea to make the fourth argument of ITERATES a small positive integer.  See EquationSolving.mth for more detailed discussion of fixed-point iteration.

Newton's method for solving an equation provides another good illustration of the use of ITERATES.  For example, if the function NEWTON is defined as

NEWTON(u, x, x0, n) := ITERATES(x - u/DIF(u, x), x, x0, n)

NEWTON can be used to solve equations of the form u=0 with an initial guess of x=x0.  It repeatedly applies the update formula

x ¬ x - u/u’

to correct the current approximation for x by subtracting u divided by the derivative of u and evaluating the result at x.  If n is a positive integer, the iteration is repeated n times; otherwise, it is repeated until x is equal to one of its earlier values.  For example,

NEWTON(x^2-3, x, 2)

approximates to a vector of successively better approximations to the square root of 3.  See EquationSolving.mth for a more detailed discussion of Newton's method.

As another example of the use of ITERATES, consider the continued fraction

              a           
b + --------------------- 
                a         
    b + ----------------- 
               ...        
                     a    
              b + ------- 
                       a  
                  b + --- 
                       x  

where there are n divisions.  Entering such expressions on the expression entry line would be tedious, especially for large n.  However, using ITERATES it is possible to generate the continued fraction by applying the update formula

r  ¬  b+ a/r

to itself n times, starting with r=x.  For example, if the function CF is defined as

CF(b, a, x, n) := ITERATES(b + a/r, r, x, n)

trivially factoring

CF(1, 1, x, 6)

yields a vector that allows you to guess the general form of the continued fraction a=1 and b=1 for n divisions.


The ITERATE Function

In many cases only the last iterate is of interest, particularly when the fourth argument is omitted or the Simplify Basic command is used so that convergence is less of an issue.  ITERATE is identical to ITERATES, except that ITERATE returns only the last iterate.  ITERATE returns ? if the iteration does not converge to a single unique value (i.e. if the cycle length is not 1).

For example, to compute the nth power of x, define the function

POWER(x, n) := ITERATE(a·x, a, 1, n)

Here the update formula  a <-- a·x  is being applied n times, starting the accumulator a with the initial value 1.  This iteration multiplies n copies of x, giving x^n.  Although Derive has a built-in ^ operator for raising an expression to a power, POWER is a good elementary application demonstrating the use of ITERATE.

When an iteration depends on two or more of the previous iterates, you can use a vector with ITERATE to store the previous iterates.  For example, the Fibonacci numbers are defined by the recurrence

FIB(n) = 0			if n = 0,
	FIB(n) = 1			if n = 1, and
	FIB(n) = FIB(n-1) + FIB(n-2)	if n > 1.

where n is a nonnegative integer.  Use a two-element vector v to store the value of FIB(n-2) and FIB(n-1).  Then by letting n=2 the above recurrence specifies that the initial value of v is [0, 1].  Also it specifies that to update v, make its new first component its previous second component and make its new second component the sum of the two previous components.  This initialization and update are accomplished using ITERATE as follows:

FIB(n) := ITERATE([v SUB 2, v SUB 1 + v SUB 2], v, [0, 1], n)

If FIB is defined as shown and n is a nonnegative integer, FIB(n) will simplify to a vector whose first element is the nth Fibonacci number and whose second is the n+1th Fibonacci number.  For example, FIB(100) simplifies to

	[354224848179261915075, 573147844013817084101]

and 354224848179261915075 is the 100th Fibonacci number.

Instead of a variable, the second argument of ITERATE and ITERATES can be a vector of variables and the third argument a vector of values for those variables.  This can simplify definitions using these functions by eliminating the need to use subscripts.  For example, this simplifes the definition for FIB given earlier to

FIB (n) := ITERATE([k, j+k], [j, k], [0, 1], n)

For additional examples of iteration, inspect the definitions of the functions


·	FIXED_POINT and NEWTONS in the file EquationSolving.mth,

·	IMP_DIF and PARA_DIF in the file DifferentiationApplications.mth, and

·	PICARD, EULER, TAYLOR_ODE1, TAYLOR_ODES and RK in the file ODEApproximation.mth.


IF Expressions

Often functions are defined in a piecewise manner using one or more conditions.  For example, a job may pay $10 per hour for the first 40 hours per week and $15 per hour for any additional hours.

IF expressions are a convenient way to express such conditions in Derive.  For example, if h hours are worked during a week, the above pay schedule can be entered as

	IF(h <= 40, 10h, 400 + 15·(h - 40))

When this IF expression is simplified and if Derive determines that the condition h <=40 is true using the current value or domain declaration of h, the second argument 10·h is simplified and returned.  If Derive determines that the condition is false, the third argument 400 + 15·(h - 40) is simplified and returned.  For example, if h is assigned a value of 50, this IF expression simplifies to 550.  Or if h is not assigned a value but is declared less than 30, it simplifies to 10h.

If Derive cannot determine whether the condition is true or false, the entire IF expression is returned.

Note that an IF expression can be used as a subexpression within another expression.  For example, adding a $100 bonus to the above pay schedule can be entered as

	100 + IF(h <= 40, 10h, 400 + 15·(h - 40))

A pair of expressions separated by one of the relational operators (=, /=, <, <=, >, or >=) is a relation (see Entering Equations and Relations).  When a relation is simplified, its two sides are simplified independently and Derive makes no attempt to determine the truth or falsehood of the relation.  However, when a relation appears as the first clause of an IF expression and the IF expression is simplified, Derive treats the relation as a condition and actively tries to determine its truth value.

The general form of the IF expression is


IF (test, then, else, unknown)

where the test clause is a condition, and the then, else, and unknown clauses are expressions.  If the test clause is not a relation or a logical combination of relations (see Boolean Test Clauses), it is treated as the condition test=0.

When an IF expression is simplified, Derive evaluates the test clause to determine its truth value.  If true, the then clause is simplified and returned as the value of the IF expression.  If false, the else clause is simplified and returned.  If the truth value cannot be determined, the unknown clause is simplified and returned.  Note that whichever clause is returned, the other two clauses are not simplified.

If the unknown clause is omitted and the truth value of the test clause cannot be determined, the entire IF expression is returned.  This is often informative, and subsequent assignments or domain declarations might enable you to resimplify the IF expression to a decisive result.  Alternatively, ? is often used as the unknown clause since it yields a more compact result when the truth value of the test clause cannot be determined.  ? is the expression signifying a quantity of unknown phase and magnitude.

If the else clause is also omitted from the IF expression, a default value of ? is assumed for it.  Finally, if the then clause is also omitted, IF returns 1 if the argument evaluates to true, otherwise it returns 0.  When used in conjunction with the SUM function, this is useful for counting the elements of a vector or sequence that satisfy some condition.  For example,

	SUM(IF(PRIME(n)), n, 1, 100)


simplifies to 25, the number of primes between 1 and 100.

An expression of the form


ITERATE (IF (test, x, u), x, x0)

can be used to search for a number or expression that satisfies the search condition test.  Given x, u generates the next number or expression to test.  For example,

	ITERATE(IF(PRIME(n) AND PRIME(n+2), n, n+2), n, 100001)

simplifies to 100151, the leading element of the first prime pair larger than 100000.  (Prime pairs are consecutive primes that differ by 2.)


IF expressions can be used on the right side of a function definition.  For example, most Derive functions are defined for complex as well as real values of their arguments, and many functions return complex results for some real values of their arguments.  However, in an educational setting devoted to the real domain, some instructors may prefer that functions return ? when an argument or a result is not real.  Using the following filter function, more restrictive variants can be defined that impose this constraint:

REAL_ONLY(x) := IF(IM(x) = 0, x)

Note that the else clause of the IF expression is omitted so that ? is automatically returned if Derive can determine that IM(x) is not 0.

As examples of using REAL_ONLY, you can define:

	REAL_LN(x) := REAL_ONLY(LN(x))

	REAL_ABS(x) := ABS(REAL_ONLY(x))

LN(x) is not real-valued if x is negative.  ABS(x) is real-valued even if x is not real.  These two facts account for the different placement of REAL_ONLY in the above definitions.

Since zero can be approached from either the positive or negative direction, or for that matter any direction in the complex plane, zero does not have a definite sign.  Thus, SIGN(0) simplifies to plus-or-minus 1 (see Complex Variable Functions
).


For additional examples of IF expressions, inspect the definitions in the files VectorMatrixFunctions.mth and NumericalApproximation.mth.


Nested IF Expressions

Sometimes multiple conditions are required to define a function.  For example, a job may pay $10 per hour for the first 40 hours per week, $15 per hour for additional hours through 50 per week, and $20 per hour for hours exceeding 50 per week.

Nested IF expressions are a convenient way to express multiple conditions.  Any clause of an IF expression can itself be an IF expression.  For example, the above pay schedule can be entered as

IF(h <= 40, 10h, IF(h <= 50, 400 + 15(h - 40), 550 + 20(h - 50)))

IF expressions can be nested arbitrarily deep; however, it is usually better to subdivide complicated IF expressions into more comprehensible components by defining auxiliary helper functions


Boolean Test Clauses

The Boolean AND operator makes it possible to express the conjunction of two conditions (see the Boolean Constants and Operators).  When used in the test clause of IF Expressions, this makes it possible to define functions that depend on both of two conditions being true.

For example, a job may pay a flat $10 per hour for any number of hours per week.  Obviously, at least 0 hours will be worked and at most 168 hours can be worked (i.e. the number of hours in a week).  Any number of hours outside that range must be a mistake.  If h hours are worked during a week, the following IF expression returns the correct pay when h is a valid number of hours, and it returns ? when h is not valid:

IF(0 <= h AND h <= 168, 10h, ?)

When an IF expression is simplified and AND is the top-level operator of the test clause, the truth value of the test clause is determined as follows:  The left operand of the AND is evaluated and


·	If its truth value is false, the value of the test clause is also false.  Note that in this case the right operand of the AND is not evaluated.

·	If its truth value is true, the right operand of the AND is evaluated and returned as the value of the test clause.

·	If its truth value cannot be determined, the right operand of the AND is evaluated and if it is false, the value of the test clause is also false.  Otherwise, the truth value of the test clause cannot be determined.

The Boolean OR operator makes it possible to express the disjunction of two conditions (see the Boolean Constants and Operators).  When used in the test clause of IF Expressions, this makes it possible to define functions that depend on either of two conditions being true.

For example, a triangle is isosceles if any two of its angles are equal.  CATEGORY is a function that returns "Isosceles" or "Scalene" depending on the three angles a, b and c:

CATEGORY(a,b,c) := 
	IF(a=b OR a=c OR b=c, "Isosceles", "Scalene")

Note that the OR operator corresponds to the phrase "and/or" in English.  Thus, CATEGORY returns "Isosceles" even if all three angles are equal.

When an IF expression is simplified and OR is the top-level operator of the test clause, the truth value of the test clause is determined as follows:  The left operand of the OR is evaluated and

·	If its truth value is true, the value of the test clause is also true.  Note that in this case the right operand of the OR is not evaluated.

·	If its truth value is false, the right operand of the OR is evaluated and returned as the value of the test clause.

·	If its truth value cannot be determined, the right operand of the OR is evaluated and if it is true, the value of the test clause is also true.  Otherwise, the truth value of the test clause cannot be determined.

Each operand of AND or OR can itself be an expression involving AND or OR.  For example, three values a, b, and c are a monotonic sequence if  a<=b<=c  or  a>=b>=c.  The following IF expression tests for monotonicity:

	IF(a<=b AND b<=c OR a>=b AND b>=c,
		"Monotonic", "Nonmonotonic")

AND has a higher precedence than OR (see the Boolean Constants and Operators), so the above test clause is interpreted as if it were parenthesized

(a <= b AND b <= c) OR (a >= b AND b >= c)

rather than

	a <= b AND (b <= c OR a >= b) AND b >= c

Each relational operator (see the Relational Operators) has a complementary operator equivalent to its negation.  Thus, the negation of a test clause can be transformed into a more readable and efficient one using the complementary operator.  For example, NOT(x>5) is equivalent to x<=5, and NOT(x=5) is equivalent to x/=5.

To avoid errors and save time and space, it is worth using Derive to find the simplest possible Boolean expression for use as the test clause of IF expressions (see the Boolean Constants and Operators).


Recursive Functions

A function definition is recursive if the right side of the definition calls the function being defined.  For example, if n is a nonnegative integer, the factorial of n can be computed recursively by the rules

	n! = 1		if n = 0, and
	n! = n(n-1)!	if n > 0.

The first rule is the terminal case for this definition.  The second rule is the recursive case.  The Derive definition corresponding to the above rules is

	FACT(n) := IF(n = 0, 1, n·FACT(n - 1))

To be computable, recursive definitions must have one or more terminal case rules, and the recursive case rules must make finite progress toward the terminal cases.  The above definition for computing factorials is computable because


·	When the terminal case rule is applicable (i.e. when n=0), the recursion is terminated.  

·	When the recursive case rule is applicable (i.e. when n>0), the problem is reduced to one closer to the terminal case.

·	The terminal case is reached after a finite number of applications of the recursive case rule.

If x is an expression and n is a nonnegative integer, raising x to the n power can be computed recursively by the rules

	RAISE(x, n) = 1			if n = 0, and
	RAISE(x, n) = x RAISE(x, n-1)	if n > 0.

If m and n are integers, the greatest common divisor (gcd) of m and n can be computed recursively by the rules

	GCD(m, n) = |m|			if n = 0, and
	GCD(m, n) = GCD(n, |m-n|)	if n /= 0.

The recursion terminates because both arguments must become nonnegative after two recursions, and thereafter the second argument decreases toward the terminal case by at least 1 for each recursion.  It is also true that any integer that evenly divides m and n, also evenly divides n and |m - n|, including the greatest common divisor.  It is also true that the greatest common divisor of m and 0 is |m|.  

The speeds of FACT and ! are approximately proportional for large n, as are the speeds of RAISE, POWER, and ^.  Although built-in operators or functions are faster, recursively defined functions can be reasonably efficient as well.  The next example illustrates the importance of writing efficient definitions.

If n is a nonnegative integer, the nth Fibonacci number can be computed recursively by the rules

	FIB(n) = 0			if n = 0,
	FIB(n) = 1			if n = 1, and
	FIB(n) = FIB(n-1) + FIB(n-2)	if n > 1.

An iterative definition of FIB that implemented these rules was discussed using the ITERATE Function.  The following recursive definition of FIB_SLOW is another way to implement this recurrence:

FIB_SLOW(n) := 
	IF(n < 2, n, FIB_SLOW(n - 1) + FIB_SLOW(n - 2))

The reason FIB_SLOW is so slow is because to compute FIB_SLOW(n), FIB_SLOW(n-2) is computed twice: once for FIB_SLOW(n) and once for FIB_SLOW(n-1).  Similarly, FIB_SLOW(n-3) is computed three times: once for FIB_SLOW
(n-1) and once for each of the two computations of FIB_SLOW(n-2).  In general, FIB_SLOW(n-i) must be computed the ith Fibonacci number of times.  Thus the number of redundant calculations, and hence the time required to compute the nth Fibonacci number using FIB_SLOW increases rapidly (i.e. Fibonaccially!) with n.

Such redundant computation is typical for recursive definitions that naively implement recurrences, like Fibonacci, that are doubly recursive.  Note that the recurrences for factorial, raising to a power, and gcd were just singly recursive and so did not suffer such redundancy.

In the case of Fibonacci this inefficiency is easy to overcome:  Just define an auxiliary helper function that has extra accumulation arguments to retain previously computed values so that they do not have to be recomputed.  The main function then invokes this helper function with the appropriate starting arguments.

FIB_AUX(n, f1, f0) := 
	IF(n=0, f0, FIB_AUX(n - 1, f1 + f0, f1))

FIB_FAST(n) := FIB_AUX(n, 1, 0)

For additional examples of recursive functions, see the definition of POLY_DEGREE in the file MiscellaneousFunctions.mth or the definitions of SPHERICAL_BESSEL_J and SPHERICAL_BESSEL_Y in the file BesselFunctions.mth.


Mutual Recursion

Sometimes a function invokes itself recursively via one or more intermediate functions rather than directly.  This is all right provided at least one of the mutually recursive functions has an IF expression that eventually terminates the recursion.  The F and G series from celestial mechanics provide an interesting example.  This series can be used to predict a conic trajectory of a comet given its position and velocity at one time.  The series is defined by

F(0) = 1

G(0) = 0

         d            d            d                  
F(n) = m·--F(n-1) + s·--F(n-1) + e·--F(n-1) - m·G(n-1)
         dm           ds           de                  

          d            d            d                
 G(n) = m·--G(n-1) + s·--G(n-1) + e·--G(n-1) + F(n-1)
          dm           ds           de               

for n>0, where


m := -3·m·s

s := e - 2·s²

and

e := -s·(m + 2·e)

To define a pair of mutually recursive functions F and G for computing the series, first make G an arbitrary function by the assignment

G(n) :=

then define F and G as follows:

F(n) := IF(n=0, 1,

	  d            d            d                   
	m·--F(n-1) + s·--F(n-1) + e·--F(n-1) - m·G(n-1))
	  dm           ds           de                 

and

G(n) := IF(n=0, 0,

        d            d            d                 
	m·--G(n-1) + s·--G(n-1) + e·--G(n-1) + F(n-1))
        dm           ds           de                

Making G an arbitrary function is necessary, so that the G that occurs in the definition of F is interpreted as a function rather than a variable.  G is assigned its actual definition by the final assignment above.

The above definition causes exponential recomputation of the same formulas:  F(n) requires F(n-1) and G(n-1), both of which redundantly compute F(n-2) and G(n-2), etc.  Thus it is worth redefining the recursion to use an auxiliary helper function that carries forward F(n-1) and G(n-1) in auxiliary variables.  The two final values F(n) and G(n) can be bundled together in a two-element vector and returned as the value of the function.  First, clear the definition of F and G and make them variables again by the assignments

f :=

g :=

Then define

FG_AUX(n, f, g) := IF(n=0, [f, g], FG_AUX(n-1,

	  d       d       d            d       d       d
	m·--f + s·--f + e·--f - m·g, m·--g + s·--g + e·--g + f))
	  dm      ds      de           dm      ds      de

and


FG(n) := FG_AUX(n, 1, 0)

Then for example, FG(4) simplifies to the vector


[m·(3·e + m - 15·s²), 6·m·s]

As a final matter of style in the preceding example, it would be better to use multiple-character names for the variables m, s and e to reduce the chance of a name conflict with any unassigned variables.  For example, use m_, s_ and e_.

In this topic an example of inefficient mutual recursion was given, and then an efficient direct recursion alternative.  Do not conclude from this that all mutual recursion is inefficient.  In fact, Derive itself is a large collection of mutually recursive functions!


Procedural Programming

Using the PROG and LOOP program control constructs in user-defined functions makes it possible to write multi-line, procedural programs in Derive.  Both these control constructs take any number of program statements (e.g. assignment statements and if-then-else statements).  The statements of a PROG construct are sequentially evaluated until an EXIT or RETURN statement is encountered or until its last statement is evaluated, which is returned as the value of the PROG construct.  The statements of a LOOP construct are sequentially evaluated repeatedly until an EXIT or RETURN statement is encountered, which terminates the loop and the last statement evaluated is returned as the value of the LOOP construct.

Temporary assignments to local variables of the function being defined are commonly made within the scope of the PROG and LOOP program control constructs.  Upon exit from the user-defined function, these variables are restored to their original values.  However, if assignments are made to non-local variables, these variables are not restored to their original values upon exit from the function.  Also, if a vector or matrix is assigned to different local variables, assignments to the elements of the vector or matrix affect the value of all the local variables.

If a RETURN statement is encountered at any point in the evaluation of a user-defined function, evaluation terminates and the value of RETURN's argument is returned as the value of the function.  If an EXIT statement is encountered at any point in the evaluation of a PROG or LOOP control construct, evaluation of the construct terminates and evaluation continues with the next statement in the user-defined function.

The following definition of Rev illustrates the use of the PROG and LOOP control constructs to reverse the elements of a vector.  (Note that the built-in function REVERSE can also be used to reverse the elements of a vector.)  Rev uses the built-in functions FIRST, REST, and ADJOIN (see Vector Manipulation Functions) to perform operations on vectors analogous to the way lists are processed in the LISP programming language.

Rev(v,w) := PROG(w:=[], LOOP(IF(v=[], RETURN w), w:=ADJOIN(FIRST(v),w), v:=REST(v)))

After entry, the definition is displayed in the more readable, multi-line indented format as

Rev(v, w) :=                   
  Prog                         
    w := []                    
    Loop                       
      If v = []                
         RETURN w              
      w := ADJOIN(FIRST(v), w) 
      v := REST(v)             

Then, for example,

Rev([a, b, c])

simplifies to [c, b, a].

The default initial value of a user-defined function’s local variables can be specified by including assignment statements in the function's formal argument list.  If a function is called with fewer actual arguments than it has local variables, the extra local variables are given their assigned values.  For example, if SUMSQ is defined as 

SUMSQ(x, y := 0, z := 0) := x^2 + y^2 + z^2

then the vector

[SUMSQ(5), SUMSQ(5, 3), SUMSQ(5, 3, 2)]

simplifies to [25, 34, 38].  Whereas, if SUMSQ is defined as

SUMSQ(x, y, z) := x^2 + y^2 + z^2

then the above vector simplifies to

é 2    2        2         ù
ëy  + z  + 25, z  + 34, 38û

Note that the default initial value can also be specified for the local variables of arbitrary user-defined functions.  For example, if FOO is defined as

FOO(x, y := 3, z) :=

then

FOO(5)

simplifies to FOO(5,3,z).

Specifying the default initial value of one or more of a function’s local variables often makes it possible to avoid using a PROG construct in the function’s definition.  For example, initializing the accumulator variable w to the empty vector shortens the definition of Rev to

Rev(v,w:=[]) := LOOP(IF(v=[], RETURN w), w:=ADJOIN(FIRST(v),w), v:=REST(v))

Alternatively, Rev can be even more elegantly defined using recursion as

Rev(v,w:=[]) := IF(v=[], w, Rev(REST(v),ADJOIN(FIRST(v),w)))

The evaluation of expressions in function definitions can be suppressed using the quote operator.  The single quote mark is used for the quote operator.  For example,

'(2+3)

simplifies to 2+3 instead of 5.  The quote operator is useful for quoting expressions in calls on functions that you do not want evaluated before being passed.  For example, 

TERMS('(x + x + x))

simplifies to the [x, x, x]; whereas

TERMS((x + x + x))

simplifies to [3·x].

User functions can be defined so they will accept any number of arguments.  If the single formal argument of a user-defined function is not enclosed in parentheses, then all the arguments in calls on the function are passed to the function as a vector.  This allows user-defined function to accept any number of arguments.  For example, after making the definition

FOO v := SUM(v)

then

FOO(2, 3, 5)

simplifies to 10 and

FOO(2, 3, 5, 7, 11)

simplifies to 28.


Programming Functions

The following are the built-in functions and operators especially useful for writing and debugging Derive programs:

Use the MAP and MAP_LIST functions to map functions over the elements of vectors and sets.  If u is an expression involving the variable x and c is a set or a vector, MAP_LIST(u, x, c) evaluates u(x) for x equal to each element of c and returns the results as a set or vector (depending on the type of c).  MAP_LIST(u,k,m,n,s) evaluates u(k) for k=m to n in steps of size s.  s defaults to 1.  The function MAP evaluates u identical to MAP_LIST, but it just returns the truth-value "true".

Use the ASSIGN function to assign values to variables generated by programs.  The := assignment operator (see the Author > Variable Value command) and the ASSIGN function are both used to assign values to variables.  The left operand of the := assignment operator must be a variable, since it is not simplified.  Whereas, the first argument of the ASSIGN function can be any expression, so long as it simplifies to a variable.  Therefore, use ASSIGN when it is necessary to generate a variable and then assign it a value.  For example, simplifying the expression

ASSIGN(APPEND("a", 1), 25)

generates the string variable "a1" and assigns it the value 25.

Use the following variable update operators to make user-defined functions more efficient and easier to read:

·	x :+ u  increments the variable x by the value of the expression u.

·	x :- u  decrements the variable x by the value of the expression u.

·	x :* u  multiplies the variable x by the value of the expression u.

·	x :/ u  divides the variable x by the value of the expression u.

For example, the statement x :+ 1 is faster than the equivalent statement x := x+1.  Similarly, the statement x :* 2 is faster than the equivalent statement x := 2·x.

Use the WRITE function in user-defined functions to show intermediate results of a transient nature.  WRITE(u) format the expression u as a single line of text, and displays the result on the Algebra window status line.  Any expression previously displayed on the status line is over-written.  WRITE is useful for displaying counters in program loops to help determine where programming errors have occurred.

Use the DISPLAY function in user-defined functions to display intermediate results in a text box.  DISPLAY(u,n) creates a new text box containing the expression u formatted in 2 dimensions using up to n lines of text.  n defaults to 1.  DISPLAY
 makes it possible for user-defined functions to show the steps involved in a calculation.


Epilogue

Programming is like chess.  Learning the rules of the game is easy, but it takes a great deal of practice and diligence to become proficient.  Experience using Derive's built-in mathematical capabilities makes it easier for you to use them in Derive programs.  However, if you are not an experienced programmer, we recommend writing some simple programs before attempting more ambitious ones.  And most important: test your programs thoroughly!


Entering Unicode Characters

Greek letters can be entered in Derive by clicking on the Greek Symbol Toolbar or by using a Greek keyboard, if available.  Alternatively, they can be entered by typing the Latin equivalent names Alpha, Beta... , Omega, alpha, beta... , omega.  There is one exception to this convention:  pi is interpreted as the mathematical constant ð (3.1415...).  Thus there is no Latin equivalent name for the lower case Greek letter ð; however, it can be entered as Ctrl+Backspace 03C0.

Built-in functions having Greek letter names are entered in all capital letters (for example, GAMMA for the Gamma function and ZETA for the Riemann zeta function).  Note that Greek letters entered in all capital letters that are not built-in functions are interpreted as products (for example, BETA is interpreted as b*e*t*a).

Keyboards installed by the local version of Windows are all functional.  Keyboard shortcuts peculiar to some versions of the OS can also be used.  For example, while editing a Derive text object in Windows XP, the Unicode character with hexadecimal value $nnnn can be entered as nnnn Alt+X. 

Derive provides an escape sequence for the occasional entry of isolated characters on the Expression Entry Line.  The Unicode character with hexadecimal value $nnnn can be entered as Ctrl+Backspace nnnn.  For example, the summation symbol, entered by typing Ctrl+Backspace 2211, looks like �2211 on the Expression Entry Line and is displayed as Ó in the algebra window.  In an ASCII mth file, the summation symbol is saved as �2211, where � is the Delete Control Character 127 (7F in hex). 

Users should be aware of the behavior of some spacing characters.  On some European keyboards, a space is needed after ^ circumflex, ` grave, and ~ tilde characters, if they are not be turned into a diacritic mark.  For example to raise x to the power of a, one must type

x circumflex space a


Reserved Unicode Characters

This section provides a short list of built-in constants, functions, and operators in Derive with their Unicode hexadecimal value, character symbol, name, comments and methods of input.

Constants

E7C2	ð	area of unit circle (not the same as the Greek letter ð)
			pi, Ctrl+Backspace E7C2, Ctrl+P, Math symbol toolbar
E7C0	e	base of natural logarithms (not the same as the Latin letter e)
			#e, Ctrl+Backspace E7C0, Ctrl+E, Math symbol toolbar
E7C1	i	imaginary unit (not the same as the Latin letter i)
			#i,  Ctrl+Backspace E7C1, Ctrl+I, Math symbol toolbar
E7C3	ã	Euler’s gamma constant (not the same as the Greek letter ã)
			euler_gamma, Ctrl+Backspace E7C3, Math symbol toolbar

221E	¥	positive infinity
			inf, Ctrl+Backspace 221E, Ctrl+0, Math symbol toolbar

Functions

007C	|	absolute value delimiter
			ABS, keyboard |
2202	¶	partial derivative
			DIF, Ctrl+Backspace 2202, Math symbol toolbar
220F	Ð	product (not the Greek letter Ð)
			PRODUCT, Ctrl+Backspace 220F, Math symbol toolbar
2211	Ó	Summation (not the Greek letter Ó)
			SUM, Ctrl+Backspace 2211, Math symbol toolbar
221A	Ö	Square root
			SQRT, Ctrl+Backspace 221A, Math symbol toolbar
222B	ò	Integral
			INT, Ctrl+Backspace 222B, Math symbol toolbar

E7C4	Ã	Gamma function (not the Greek letter Ã)
			GAMMA, Ctrl+Backspace E7C4, Math symbol toolbar
E7C5	æ	Zeta function (not the Greek letter æ)
			ZETA, Ctrl+Backspace E7C5, Math symbol toolbar
E7C6	X	Chi function (not the Greek letter ÷)
			CHI, Ctrl+Backspace E7C6, Math symbol toolbar
E7C7	ø	Digamma function (not the Greek letter ø)
			DIGAMMA, Ctrl+Backspace E7C7, Math symbol toolbar

Operators

002B	+	plus
			keyboard + , Math symbol toolbar
002D	-	minus (different than hyphen 2010, figure dash 2012,
			en dash 2013, and minus 2212)
			keyboard - , Math symbol toolbar
00B7	·	times (used for scalar and vector multiplication)
			keyboard * , Ctrl+Backspace 00B7, Math symbol toolbar
002F	/	quotient (different than fraction slash 2044 and division slash 2215)
			keyboard / , Math symbol toolbar
22C5	·	dot product
			keyboard . , Ctrl+Backspace 22C5

2A2F	x	cross product
			CROSSPRODUCT, Ctrl+Backspace 2A2F, Math symbol toolbar
005E	^	exponent
			keyboard ^ , Math symbol toolbar
2193	¯	subscript
			SUB, Ctrl+B, Math symbol toolbar
0025	%	percent
			keyboard % , Math symbol toolbar
0021	!	factorial
			keyboard !
00B1	±	plus-minus sign
			keyboard "+-", Ctrl+Backspace 00B1, Math symbol toolbar
0027	'	quote and differentiation
			keyboard '
003D	=	equation
			keyboard =, Math symbol toolbar

2260	¹	equation negation
			keyboard /= , Ctrl+Backspace 2260, Math symbol toolbar
003C	<	less than
			keyboard < , Math symbol toolbar
2264	£	less than or equal
			keyboard <= , Ctrl+Backspace 2264, Math symbol toolbar
003E	>	greater than
			keyboard > , Math symbol toolbar
2265	³	greater than or equal
			keyboard >= , Ctrl+Backspace 2265, Math symbol toolbar
0060	`	transpose
			keyboard `, Math symbol toolbar

00AC	¬	not
			NOT, Math symbol toolbar
2227	Ù	and
			AND, Ctrl+Backspace 2227, Math symbol toolbar
2228	Ú	or
			OR, Ctrl+Backspace 2228, Math symbol toolbar
22BB	Ú	exclusive or
			XOR, Ctrl+Backspace 22BB, Math symbol toolbar
2192	®	implication
			IMP, Ctrl+Backspace 2192, Math symbol toolbar
2194	«	if-and-only-if
			IFF, Ctrl+Backspace 2194, Math symbol toolbar
2229	Ç	intersection
			INTERSECTION, Ctrl+Backspace 2229, Math symbol toolbar

222A	È	union
			UNION, Ctrl+Backspace 2227, Math symbol toolbar
005C	\	back slash
			keyboard \ , Math symbol toolbar
2286	Í	subset or equal
			SUBSET, Ctrl+Backspace 2286, Math symbol toolbar
2254	:=	assignment
			keyboard := , Ctrl+Backspace 2254, Math symbol toolbar
E7C8	:å	domain declaration
			keyboard :epsilon , Ctrl+Backspace EFC8, Math symbol toolbar
00B0	°	degree
			Ctrl+O, Ctrl+Backspace 00B0, Math symbol toolbar



Unicode Bibliography

For information on Unicode:

·	The Unicode Consortium. The Unicode Standard, Version 4.0.0, defined by: The Unicode Standard, Version 4.0 (Reading, MA, Addison-Wesley, 2003. ISBN 0-321-18578-1)

·	The Unicode Standard, Version 4.0, http://www.unicode.org

·	Code Charts; the online PDF versions of code charts for the various Unicode Blocks can be found at http://www.unicode.org/charts

·	Barbara Beeton, Asmus Freytag and Murray Sargent III, Unicode Support for Mathematics, Draft Unicode Technical Report #25, in http://www.unicode.org/reports/...

For adventures in the Art of Typography:

·	Robert Bringhurst, The Elements of Typographic Style, 2nd edition, Hartley & Marks, 1996

·	Greek Letters: From Tablets to Pixels, Oak Knoll Books, Delaware, USA, 1996; Proceedings of an International Conference with the participation of many giants of Typography (Hermann Zapf, Matthew Carter, et al.)


Frequently Asked Questions and Answers

This section answers some of the questions commonly asked by users of Derive.  The questions and answers are divided into the following categories:


User Interface Questions 
	Simplification Questions 
	Plotting Questions 
	Printing Questions 
	System Requirement Questions 
	Network Installation Questions 


User Interface Questions

Q:	Unlike earlier versions of Derive, why are the algebra window’s state variable values saved in dfw files created by Derive 6? 

A:	In order to restore the environment in effect at the time worksheets are saved, the expressions in the algebra window, as well as all the user-defined functions and variable assignments, are saved in dfw files.  In earlier versions of Derive, the values of state variables (for example, the precision; notation; radix base; and the exponential, log, and trig simplification settings) were not saved in dfw files.  This made it impossible to fully restore the worksheet’s environment when it was opened.  Therefore, Derive 6 saves the state variable values in dfw files (for details, see Using and Saving State Variables).  So now if while working at 20 digits of precision you save a worksheet, that same precision is restored when the worksheet is re-opened. 

Q:	Unlike earlier versions of Derive, why are the algebra window’s state variable values not saved in the Derive 6 initialization file? 

A:	When earlier versions of Derive started and a new blank worksheet created, the state variable values were set to those in effect the last time Derive was shutdown.  These settings may have long since been forgotten by the user and/or not appropriate for the task at hand.  Therefore, to avoid confusion, when Derive 6 starts the state variable values are set to their factory defaults.  So there is no need to save state variable values in the initialization file.  However, Derive 6 continues to save the Windows state information (for example, window sizes and colors, printing options, etc.) in the file (for details, see the Derive Initialization File).

Q:	How do I highlight a subexpression of an expression or the elements of a vector or matrix? 

A:	To highlight a subexpression of an expression or an element of a vector or matrix, move the mouse pointer to the desired subexpression or element, and then click the left mouse button until only the subexpression or element is highlighted.  If you double click, the smallest subexpression containing the mouse pointer is highlighted.  Alternatively, you can press Shift+Right, Shift+Left, Shift+Up or Shift+Down arrow key combinations to highlight the desired subexpression (for details, see Selecting Objects and Subexpressions). 

Q:	How do I edit a highlighted expression?

A:	Press the Return key or use the Edit > Expression command to edit the highlighted expression.  Or, you can press F3 to copy the highlighted expression or press F4 to copy the highlighted expression with parentheses around it into the expression entry line.  Alternatively, if you copy the expression to the Windows Clipboard using the Edit > Copy command, you can paste it onto the editing line by pressing Ctrl+V.  Note that you can click the right mouse button to select either of these copying methods from a popup menu.

Q:	How do I copy Derive expressions into a word processing document?

A:	Highlight the expressions to be copied and issue the Edit > Copy command to copy the expressions to the Windows Clipboard in text format.  Then switch to your word processor and use its Paste command (usually found in the Edit menu) to paste the expressions from the clipboard into your document.  (Note that in Microsoft Word the "Use Smart Cut and Paste" option in the Tools Options Edit dialog should be turned off before you paste the Derive expressions.  If this option is on, multi-line expressions will be improperly displayed.)  After pasting, select the expressions and reformat them using the Derive Unicode font if it is not the default font.

Alternatively, use the File > Write > Rich Text Format File commands or press Ctrl+R to save all of the objects (except OLE objects) in the active Derive worksheet as an rtf file.  rtf files are suitable for loading into many word processing programs.

Q:	Why don’t the Derive expressions display nicely in my word processing document?

A:	The only font that will display all kinds of Derive expressions properly in a word processing document is the Derive Unicode font.  The reasons are twofold: 1) the Derive Unicode font correctly maps all the Greek and mathematical characters displayed in a Derive Algebra window; and 2) the Derive Unicode font is a fixed-width font.

Q:	How do I copy an image of a Derive plot window into a document in another Windows application?

A:	Using the plot window’s Edit > Copy Plot Window command or press Ctrl+C to copy an image of the plot window to the clipboard in bitmap format.  Then, switch to your Windows application and use the Paste command (usually found in the Edit menu) to paste the image into your document.  Note that the application you paste the image into must support the bitmap format.

Q:	When resizing a plot or algebra window using the sizing handles, how do I prevent the window from being redrawn before I let go of the mouse?

A:	If it takes too long to continuously display a window’s contents while resizing it, turn off the Show Window Contents While Dragging feature of Windows.  When this feature is off, only an outline of a window is displayed while it is moved or resized.  To turn it off, run the Window’s Control Panel Display program.  If running Windows 98, click on the Effects tab of the dialog box.  If running Windows NT or Windows 95 with Microsoft Plus!, click on the Plus! tab.  Finally click on the Show Window Contents While Dragging check box to turn the feature off. 

Q:	How do I change the size of the characters used to display mathematical expressions on the screen?

A:	Use the Options > Display > Font of All Expressions command to select the font size, style and color used to display expressions in the Algebra window.  The same font will be used for printing and previewing expressions.


Simplification Questions

Q:	Why does LN(e) not simplify to 1?

A:	In Derive e is just a variable and not the base of the natural logarithms (2.71828...).  The base of the natural logarithms is displayed as an italicized e, and can be entered by clicking on the e on the math symbol toolbar, by pressing Ctrl+E, or by typing #e.

Q:	Why does i^2 not simplify to -1?

A:	In Derive i is just a variable and not the imaginary unit (the square-root of -1).  The imaginary unit is displayed as an italicized i, and can be entered by clicking on the i on the math symbol toolbar, by pressing Ctrl+I, or by typing #i.

Q:	Why does LN(x^2-x)-LN(x) not simplify to LN(x-1)?

A:	This transformation is invalid if x is negative.  However, if you use the Author > Variable Domain command to declare x nonnegative, Derive will simplify the expression.  In general, Derive will not use a transformation unless it can determine that the transformation is valid.

Q:	How do I turn the name of a function I defined back into a variable name?

A:	Use the Author > Variable Domain command to declare the name a real-valued variable.

Q:	When I use square brackets when entering expressions like 3·[x+y], why does the result not behave correctly?

A:	In Derive square brackets are used exclusively for entering vectors and matrices.  Thus the above expression is interpreted as 3 times the one element vector [x+y].  Parentheses rather than brackets should be used to control the order in which operators are applied (see Entering Mathematical Expressions).

Q:	When I integrate the derivative of x/(x+1), why do I get -1/(x+1) instead of the original expression?

A:	Antiderivatives are not unique and may differ by a constant.  In this case x/(x+1) and -1/(x+1) differ by the constant 1, and both are valid antiderivatives.

Q:	Why doesn’t the integral of SIN(t)/t for t=0 to x simplify to the sine integral SI(x)?

A:	Derive returns antiderivatives of expressions only if they can be expressed in terms of the elementary functions and operators and/or the Gamma, Digamma, Error, Zeta, and Dilogarithm functions.  Note that Derive can compute numerical approximations to the integral of SIN(t)/t  when given numerical limits.


Q:	When calling on trig functions, how do I enter angles in degrees? 

A:	In Derive 6, the ° operator is used to enter an angle in degrees.  The ° operator can be entered by clicking on it on the math symbol toolbar, pressing Ctrl+O, or by typing deg on the expression entry line.  For example, SIN(45°) simplifies to Ö2/2.  Unlike earlier versions of Derive, selecting Degree in the Angular Unit field of the Simplification tab of the Options > Mode Settings command only effects the display of angles, not how angles are entered.  

Q:	In approximate mode, how do I get the inverse trig functions to return angles in degrees instead of radians? 

A:	In approximate mode, the built-in inverse trig functions (e.g. ASIN, ACOS, ATAN, etc.) always return angles in radians, even in Degree mode.  For example, in Degree mode ATAN(1) simplifies to 45° but approximates to 0.7853981633.  To always get angles returned in degrees use the inverse trig functions (e.g. ARCSIN, ARCCOS, ARCTAN, etc.) defined in MiscellaneousFunctions.mth instead of the built-in functions.  For example, ARCTAN(1) simplifies and approximates to 45.


Plotting Questions

Q:	Why does x^(1/3) not plot for negative x?

A:	The principal cube root of a negative number is complex and cannot be plotted directly.  Use the Branch field on the Simplification tab of the algebra window’s Options > Mode Settings command to make Derive select the real branch instead of the principal branch while plotting.

Q:	When I try to plot a vector of two expressions the 2D-plot window, why does Derive not plot them correctly?

A:	Derive plots a vector of two univariate expressions parametrically (see Parametric Plots).  However, you can add ? as a dummy third element to the vector so Derive produces the multiple plot you desire.

Q:	In the 2D-plot window, how do I make x²+y² = 4 plot like a circle instead of an ellipse?

A:	Issue the Set > Aspect Ratio command, and click on the Reset button and then the OK button to make the physical distance between horizontal and vertical tick marks the same.


Q:	How can I make a 3D plot of two intersecting surfaces?

A:	Highlight and plot the expression defining the first surface in the 3D-plot window.  Then return to the algebra window, and highlight and plot the expression defining the second surface.  Rotating the plots will help you visualize the intersection better.  Also increasing the number of grid intervals of both plots makes the intersection clearer.


Printing Questions

Q:	How do I print color plots?

A:	Turn off the "black and white only" printing option using the plot window’s Options > Printing > Black and White Only command and select a color printer using the File > Print command.


Q:	Why are some text lines cut-off when previewing the worksheet?

A:	Derive uses commercial software to print preview text objects.  The vendor of this software has confirmed a problem that causes the right end of text lines in Derive text objects to be truncated.  However, if you zoom the print preview all the way in, all the text will be displayed correctly.  Note that the text lines will be printed correctly, even if they are appear cut-off while previewing the worksheet.


System Requirement Questions

Q:	What are the system requirements to run Derive 6.1?

A. 	A computer running Microsoft Windows® (XP, 2000, mE or 98) or compatible operating system with a CD ROM drive and 10 megabytes of free space on the hard disk.  Windows 98 computers also require Internet Explorer 5.0 or greater be installed.  The minimum amount of physical RAM memory required to run Derive 6.1 is less than that of Windows.  So, if you have enough memory to run Windows, you have enough memory to run Derive.

Q:	Will Derive 6.1 work on computers running Windows 95 or NT?

A. 	No.  Derive 6.1 requires support for Unicode font not provided by earlier versions of Windows.

Q:	Does Derive make use of all the memory in my computer?

A:	Yes.  Derive takes full advantage of the physical (RAM) memory installed on your computer.  However, that does not mean taking all available memory for itself.  In a Windows environment in which other programs, including Windows itself, are running, Derive should not and does not take all the memory.

Thus, when Derive starts up, it determines how much physical memory is available, and then makes a request to Windows to allocate some percentage of that memory for itself.  By default Derive requests 20% of the memory, but you can change that percentage using the Derive Startup Options dialog box.  The percentage chosen should be a compromise between allowing the maximum amount of memory for Derive to store mathematical expressions, and leaving sufficient memory for other programs to run.  Of course, in the event Windows needs more physical memory for other programs, it automatically swaps Derive out of physical memory into virtual memory on the hard disk.


Network Installation Questions

Q:	Why don’t the Greek letters and mathematical symbols display correctly when Derive runs on network workstations other than the one from which Derive was installed?

A:	The Derive Unicode fonts need to be installed on each network workstation.  Using the fonts program included with Windows, install the four Derive Unicode fonts: Derive Unicode, Derive Unicode Bold, Derive Unicode Italic, and Derive Unicode Bold Italic.  These fonts are defined in the files DerUni_R.TTF, DerUni_B.TTF, DerUni_I.TTF, and DerUni_J.TTF, respectively.  The Derive installation program puts a copy of these files into the \Derive6 directory where Derive6.exe resides.

Q:	How do I install Derive on a computer network?

A:	If you have a network license for Derive, you are authorized to install the software on a network server so it can be run by workstations on the network.  Use the following procedure to install and configure Derive on a network:

1.	Install Derive on the network server.  From any workstation, login as a network supervisor with all rights.  Install Derive in a directory named \Derive6 on the network server. Grant at least read and execute rights to the Derive6 directory to all workstations requiring access to Derive.  Grant execute rights only to the file \Derive6\Derive6.exe to prevent illegal duplication of the Derive program.

2.	Install and register Derive Unicode fonts.  In order for Derive to properly display and print mathematical expressions, the Derive Unicode, Derive Unicode Bold, Derive Unicode Italic, and Derive Unicode Bold Italic fonts must be registered for each workstation on the network.  The Derive setup program automatically installs and registers these fonts in the Windows Fonts directory of the workstations on which the setup program is run.  Thus, the Derive Unicode fonts will automatically be installed and registered on workstations running Windows off the network server that share a common Windows Fonts directory.

However, for those workstations running Windows off a local hard drive or not sharing a common Windows Fonts directory, you will need to manually install the four Derive Unicode fonts. From each workstation requiring access to Derive run the Fonts program in the Windows Control Panel and install the four Derive font files.  These font files can be found in the \Derive6 directory on the network server.  The Fonts program will automatically register the Derive
 Unicode fonts.

Alternatively, the fonts can be installed on each workstation by running the Derive setup program from each workstation and installing Derive to the same \Derive6 directory on the network server.

3.	Create Derive shortcut icons for each workstation.  The Derive setup program automatically creates a shortcut icon for launching Derive on the desktop of the workstation from which the setup program is run.  For other workstations, you can manually create a shortcut icon for launching Derive.

4.	Configure Derive for each workstation on the network.  The Derive working directory is the directory displayed by the File > Open command.  Since the example files distributed with Derive are stored in the \Derive6\Users directory, it is the default Derive working directory.
The DERIVE Initialization file stores the settings used to initialize Derive when it starts.  These settings include the path to the current working directory.  The initialization file, named Derive6.INI, is normally stored in the \Derive6 directory.

If Derive is launched by clicking a shortcut icon on the Windows desktop, Derive searches for the initialization file in the "Start in" directory specified by the properties of the shortcut icon.  To examine and/or change the "Start in" directory, right click on the Derive desktop icon and select the "Properties" option.
Although Derive is loaded from the network server, it actually runs in the physical memory of each workstation.  In order to run Derive along with several Windows applications on workstations with a limited amount of physical memory, you may want to use Derive's Options > Startup command to reduce the amount of memory it uses.

There are two popular configurations for running Derive on a network.  One is to have all the workstations use a common read-only initialization file and a common working directory, so Derive starts in the same exact state for all users.  Use the following procedure to set up Derive for this configuration:


a)	Launch Derive from a workstation having read, write, and execute access to the \Derive6 directory on the network server.
b)	Use the File > Open command to open a DFW or MTH file in the directory on the network server that you want to be the Derive working directory (e.g. you can use the \Derive6\Users directory).  The path to this directory will automatically be saved as the working directory in the Derive initialization file.  At this time you can also make any other changes to Derive that you want saved in the initialization file (for example, you may want to use the Options > Startup command to change the percentage of workstation memory Derive uses when it runs).  Naturally, such changes must be done before the initialization file is made read-only in the next step.

c)	Make the Derive initialization file on the network server be read-only.
d)	On each workstation on the network right click on the Derive shortcut icon and select the "Properties" option.  Then in the "Start in" directory field, enter the full path name of the \Derive6 directory on the network server.  This will cause Derive to use the same read-only initialization file no matter which workstation it is launched from.

The other configuration is for each workstation to have its own copy of the Derive initialization file (with read and write access) and its own working directory.  Use the following procedure on each workstation on the network to set up Derive for this configuration:

a)	Create a working directory for Derive.  The working directory can be on the network server or on the respective workstation.
b)	Copy the files in \Derive6\Users directory on the network server to the newly created working directory.  
c)	Right click on the Derive shortcut icon and select the "Properties" option.  Then in the "Start in" directory field, enter the full path name of the newly created working directory.  This will cause Derive to create and use an initialization file in this working directory.

d)	Launch Derive and use the File > Open command to open a file in the newly created directory to make it the initial working directory.  At this time you can also make any other changes to Derive that you want saved in the initialization file (for example, you may want to use the Options > Startup command to change the percentage of workstation memory Derive uses when it runs).

5.	Limit users.  If your network license for Derive is for fewer workstations than there are on the network, use network metering software to limit the maximum number of instances of Derive that can be run at any one time.




































